summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-06 10:42:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-06 10:42:02 +0000
commit0da2b76e542912a766e04bc606c1506038296b40 (patch)
tree370e791b91c8290a9e0659b1d341c0f56f35b62d /app-pda/barry/barry-0.16.ebuild
parentFix building with GCC 4.5+ wrt #318429 by Kacper Kowalik. Force Python 2.x. (diff)
downloadgentoo-2-0da2b76e542912a766e04bc606c1506038296b40.tar.gz
gentoo-2-0da2b76e542912a766e04bc606c1506038296b40.tar.bz2
gentoo-2-0da2b76e542912a766e04bc606c1506038296b40.zip
Fix building with GCC 4.5+ and -Wl,--as-needed wrt #318583 by Kacper Kowalik.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/barry/barry-0.16.ebuild')
-rw-r--r--app-pda/barry/barry-0.16.ebuild24
1 files changed, 18 insertions, 6 deletions
diff --git a/app-pda/barry/barry-0.16.ebuild b/app-pda/barry/barry-0.16.ebuild
index a366691d3d5c..7250ebbc2dd6 100644
--- a/app-pda/barry/barry-0.16.ebuild
+++ b/app-pda/barry/barry-0.16.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/barry/barry-0.16.ebuild,v 1.4 2010/04/03 18:46:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/barry/barry-0.16.ebuild,v 1.5 2010/05/06 10:42:01 ssuominen Exp $
-inherit base
+inherit autotools base
DESCRIPTION="Allow synchronization, backup, restore,
program management, and charging for BlackBerry devices"
@@ -33,6 +33,17 @@ RDEPEND="dev-libs/libusb
>=dev-cpp/glibmm-2.4 )
opensync? ( =app-pda/libopensync-0.22* )"
+PATCHES=(
+ "${FILESDIR}/${P}-gcc45.patch"
+ "${FILESDIR}/${P}-asneeded.patch"
+ )
+
+src_unpack(){
+ base_src_unpack
+ cd "${S}"
+ eautoreconf
+}
+
src_compile(){
econf \
$(use_with boost boost =/usr/include) \
@@ -40,7 +51,8 @@ src_compile(){
$(use_with gui libtar =/usr/lib) \
$(use_with gui libz =/usr/lib) \
$(use_enable opensync opensync-plugin)
- emake || die "emake failed!"
+
+ emake || die
if use doc ; then
cd "${S}"
@@ -49,10 +61,10 @@ src_compile(){
}
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" install || die
if use doc; then
- dodoc AUTHORS NEWS README || die "dodoc failed"
- dohtml doc/www/doxygen/html/* || die "dohtml failed"
+ dodoc AUTHORS NEWS README || die
+ dohtml doc/www/doxygen/html/* || die
fi
# udev rules