summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-31 05:49:22 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-31 05:49:22 +0000
commitd6e92e251dac75d9d3a5374ef824b76984ae9116 (patch)
treefbf57f4bc3bbacdb372fc9732e334b019d6f7331 /app-pda/coldsync
parenttidy (diff)
downloadgentoo-2-d6e92e251dac75d9d3a5374ef824b76984ae9116.tar.gz
gentoo-2-d6e92e251dac75d9d3a5374ef824b76984ae9116.tar.bz2
gentoo-2-d6e92e251dac75d9d3a5374ef824b76984ae9116.zip
Fix building with GCC 4.3+ and merge -broken-c++.diff and -gcc3.diff here. Keyword for ~amd64. Don't use strict aliasing. Respect CC and CXX wrt #243694 by Diego Elio Pettenò. Use perl-module.eclass wrt #297204 by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/coldsync')
-rw-r--r--app-pda/coldsync/ChangeLog10
-rw-r--r--app-pda/coldsync/coldsync-2.2.5-r1.ebuild44
-rw-r--r--app-pda/coldsync/files/coldsync-2.2.5-toolchain.patch25
3 files changed, 69 insertions, 10 deletions
diff --git a/app-pda/coldsync/ChangeLog b/app-pda/coldsync/ChangeLog
index 62fc97e5801d..454871521149 100644
--- a/app-pda/coldsync/ChangeLog
+++ b/app-pda/coldsync/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/coldsync
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/ChangeLog,v 1.10 2009/07/27 10:12:29 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/ChangeLog,v 1.11 2011/03/31 05:49:22 ssuominen Exp $
+
+ 31 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> coldsync-2.2.5-r1.ebuild,
+ +files/coldsync-2.2.5-toolchain.patch:
+ Fix building with GCC 4.3+ and merge -broken-c++.diff and -gcc3.diff here.
+ Keyword for ~amd64. Don't use strict aliasing. Respect CC and CXX wrt #243694
+ by Diego Elio Pettenò. Use perl-module.eclass wrt #297204 by Diego Elio Pettenò.
27 Jul 2009; Diego E. Pettenò <flameeyes@gentoo.org>
coldsync-3.0_pre4.ebuild:
diff --git a/app-pda/coldsync/coldsync-2.2.5-r1.ebuild b/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
index c301da434a57..8ea9becf97dc 100644
--- a/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
+++ b/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/coldsync-2.2.5-r1.ebuild,v 1.11 2011/03/31 04:38:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/coldsync-2.2.5-r1.ebuild,v 1.12 2011/03/31 05:49:22 ssuominen Exp $
EAPI=2
-inherit eutils
+inherit eutils flag-o-matic perl-module toolchain-funcs
DESCRIPTION="A command-line tool to synchronize PalmOS PDAs with Unix workstations"
HOMEPAGE="http://www.coldsync.org/"
@@ -11,19 +11,41 @@ SRC_URI="http://www.coldsync.org/download/${P}.tar.gz"
LICENSE="Artistic"
SLOT="0"
-KEYWORDS="~ppc sparc x86"
+KEYWORDS="~amd64 ~ppc sparc x86"
IUSE="nls perl"
+RDEPEND="perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-2.2.5-gcc3.diff \
- "${FILESDIR}"/${PN}-2.2.5-broken-c++.diff
+ epatch "${FILESDIR}"/${P}-toolchain.patch
}
src_configure() {
+ tc-export CC CXX
+ append-cflags -fno-strict-aliasing
+
+ # TODO: i18n: msgfmt fails but doesn't || die
econf \
$(use_with nls i18n) \
- $(use_with perl)
+ --without-perl
+
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_compile
+ popd
+ fi
}
src_install() {
@@ -38,5 +60,11 @@ src_install() {
INSTALLVENDORMAN3DIR="${D}"/usr/share/man/man3 \
install || die
- dodoc AUTHORS ChangeLog HACKING NEWS README TODO
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_install
+ popd
+ fi
+
+ dodoc AUTHORS ChangeLog FAQ HACKING NEWS README* TODO
}
diff --git a/app-pda/coldsync/files/coldsync-2.2.5-toolchain.patch b/app-pda/coldsync/files/coldsync-2.2.5-toolchain.patch
new file mode 100644
index 000000000000..1a5392d97f0b
--- /dev/null
+++ b/app-pda/coldsync/files/coldsync-2.2.5-toolchain.patch
@@ -0,0 +1,25 @@
+--- src/symboltable.cc
++++ src/symboltable.cc
+@@ -11,8 +11,11 @@
+ #include <string>
+ #include <map>
+ #include <cstdlib> // For malloc() and friends
++#include <cstring> // For strlen() and friends
+ #include "symboltable.h"
+
++using namespace std;
++
+ static char *make_c_string(const string &s);
+
+ map<string,string> table; /* XXX - Is this going to cause problems on
+--- src/symboltable.h
++++ src/symboltable.h
+@@ -26,7 +26,7 @@
+ /* Initialize the symbol table based on the
+ * arguments. */
+ #ifdef __cplusplus
+-};
++}
+ #endif /* __cplusplus */
+
+ /* This is for Emacs's benefit: