summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2005-02-19 13:26:33 +0000
committerTony Vroon <chainsaw@gentoo.org>2005-02-19 13:26:33 +0000
commited11254c1918a0b52d8a7c36057e94e7fe1b2727 (patch)
treeddd18f385eef0bcf6f1b979bdc12ebcf7f523224 /app-pda/iripdb/iripdb-0.1.3b.ebuild
parentMarked ~ppc for bug #81613. (diff)
downloadgentoo-2-ed11254c1918a0b52d8a7c36057e94e7fe1b2727.tar.gz
gentoo-2-ed11254c1918a0b52d8a7c36057e94e7fe1b2727.tar.bz2
gentoo-2-ed11254c1918a0b52d8a7c36057e94e7fe1b2727.zip
Version bump, closes bug #78261.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-pda/iripdb/iripdb-0.1.3b.ebuild')
-rw-r--r--app-pda/iripdb/iripdb-0.1.3b.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-pda/iripdb/iripdb-0.1.3b.ebuild b/app-pda/iripdb/iripdb-0.1.3b.ebuild
new file mode 100644
index 000000000000..12ca501676bf
--- /dev/null
+++ b/app-pda/iripdb/iripdb-0.1.3b.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/iripdb/iripdb-0.1.3b.ebuild,v 1.1 2005/02/19 13:26:33 chainsaw Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_P=${P/iripdb/iRipDB}
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="iRipDB allows generating the DB files necessary for the iRiver iHP-1xx series of MP3/Ogg HD Player on Linux and Windows."
+HOMEPAGE="http://www.fataltourist.com/iripdb/"
+SRC_URI="http://www.fataltourist.com/iripdb/${MY_P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+IUSE=""
+DEPEND="virtual/libc
+ =media-libs/taglib
+ =sys-libs/zlib*"
+
+pkg_setup() {
+ if test_version_info 3.3
+ then
+ einfo "Using gcc 3.3*"
+ # gcc 3.3 doesn't support certain 3.4.1 options,
+ # as well as having less specific -march options
+ replace-flags -march=pentium-m -march=pentium3
+ filter-flags -march=k8
+ filter-flags -march=athlon64
+ filter-flags -march=opteron
+ strip-unsupported-flags
+ elif test_version_info 3.4
+ then
+ einfo "Using gcc 3.4*"
+ fi
+}
+
+src_compile() {
+ echo "$(tc-getCXX) ${CXXFLAGS} -c -o main.o main.cpp"
+ $(tc-getCXX) ${CXXFLAGS} -c -o main.o -I/usr/include/taglib main.cpp
+ echo "$(tc-getCC) ${CFLAGS} -o iripdb main.o -lz -lm -ltag -lstdc++"
+ $(tc-getCC) ${CFLAGS} -o iripdb main.o -lz -lm -ltag -lstdc++
+}
+
+src_install() {
+ dobin iripdb
+ dodoc AUTHORS README doc/iRivDB_structure
+}
+