summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-09-18 17:11:15 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-09-18 17:11:15 +0000
commite9621b12f1e6ad00bc20de8202f8825fe51ff5a1 (patch)
tree3066c1dc8f97f79b0885fc03078e2441990ed44b /app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild
parentVersion bumped, bug #182339. (diff)
downloadgentoo-2-e9621b12f1e6ad00bc20de8202f8825fe51ff5a1.tar.gz
gentoo-2-e9621b12f1e6ad00bc20de8202f8825fe51ff5a1.tar.bz2
gentoo-2-e9621b12f1e6ad00bc20de8202f8825fe51ff5a1.zip
Initial ebuild based upon bug 86017. Thanks to Serhij S. Stasyuk.
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild')
-rw-r--r--app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild b/app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild
new file mode 100644
index 000000000000..3347d16da79f
--- /dev/null
+++ b/app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild,v 1.1 2007/09/18 17:11:15 philantrop Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="jpilot-Mail is a jpilot plugin to deliver mail from the pilot and upload mail to it."
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/jpilot-Mail/${P}.tar.gz"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/jpilot-Mail/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2
+ >=app-pda/jpilot-0.99.7-r1"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}.patch"
+}
+
+src_compile() {
+ econf --enable-gtk2 || die "configure failed"
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" \
+ libdir=/usr/$(get_libdir)/jpilot/plugins \
+ || die "install failed"
+}