summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-31 15:35:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-31 15:35:02 +0000
commit8a20d62883295506813b6b1941b7ade543ac3afd (patch)
tree1690f2ec27a95b4b93614cc032c011137c5f32a6 /app-pda/libimobiledevice
parentUSE="python" is for building Cython based python binding for compability with... (diff)
downloadgentoo-2-8a20d62883295506813b6b1941b7ade543ac3afd.tar.gz
gentoo-2-8a20d62883295506813b6b1941b7ade543ac3afd.tar.bz2
gentoo-2-8a20d62883295506813b6b1941b7ade543ac3afd.zip
Version bump wrt #409941 by "feiyd"
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/libimobiledevice')
-rw-r--r--app-pda/libimobiledevice/ChangeLog10
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.1.2.ebuild60
2 files changed, 68 insertions, 2 deletions
diff --git a/app-pda/libimobiledevice/ChangeLog b/app-pda/libimobiledevice/ChangeLog
index 5c4f112e9825..aee82dee518b 100644
--- a/app-pda/libimobiledevice/ChangeLog
+++ b/app-pda/libimobiledevice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/libimobiledevice
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.22 2011/11/13 11:37:54 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.23 2012/03/31 15:35:02 ssuominen Exp $
+
+*libimobiledevice-1.1.2 (31 Mar 2012)
+
+ 31 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +libimobiledevice-1.1.2.ebuild:
+ Version bump wrt #409941 by "feiyd"
13 Nov 2011; Samuli Suominen <ssuominen@gentoo.org>
libimobiledevice-1.1.1.ebuild:
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.1.2.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.1.2.ebuild
new file mode 100644
index 000000000000..88619118bd71
--- /dev/null
+++ b/app-pda/libimobiledevice/libimobiledevice-1.1.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/libimobiledevice-1.1.2.ebuild,v 1.1 2012/03/31 15:35:02 ssuominen Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2:2.7"
+
+inherit python
+
+DESCRIPTION="Support library to communicate with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="python ssl static-libs"
+
+RDEPEND=">=app-pda/libplist-1.8-r1[python?]
+ >=app-pda/usbmuxd-0.1.4
+ ssl? ( dev-libs/openssl:0 )
+ !ssl? (
+ dev-libs/libgcrypt
+ >=dev-libs/libtasn1-1.1
+ >=net-libs/gnutls-2.2.0
+ )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ python? ( >=dev-python/cython-0.13 )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ >py-compile
+}
+
+src_configure() {
+ local myconf
+ use python || myconf="--without-cython"
+ use ssl || myconf="--disable-openssl"
+
+ econf \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS NEWS README
+ dohtml docs/html/*
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}