summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAbhishek Amit <abhishek@gentoo.org>2004-06-23 08:12:59 +0000
committerAbhishek Amit <abhishek@gentoo.org>2004-06-23 08:12:59 +0000
commit2ca5b69426ac3b8eba33c755cd0d3973aec2dfaa (patch)
tree9724d0768de90bd31bd2a2c086f8ca6bf7835714 /app-pda/orange
parentBumped yosucker-55 to x86 and removed broken versions of yosucker. (Manifest ... (diff)
downloadgentoo-2-2ca5b69426ac3b8eba33c755cd0d3973aec2dfaa.tar.gz
gentoo-2-2ca5b69426ac3b8eba33c755cd0d3973aec2dfaa.tar.bz2
gentoo-2-2ca5b69426ac3b8eba33c755cd0d3973aec2dfaa.zip
Added DEPEND on synce-libsynce and synce-librapi2, and gets orange to build with new gcc. Closes bug #54961.
Diffstat (limited to 'app-pda/orange')
-rw-r--r--app-pda/orange/ChangeLog7
-rw-r--r--app-pda/orange/orange-0.2-r1.ebuild14
2 files changed, 17 insertions, 4 deletions
diff --git a/app-pda/orange/ChangeLog b/app-pda/orange/ChangeLog
index 52708a885afd..4b014eb52829 100644
--- a/app-pda/orange/ChangeLog
+++ b/app-pda/orange/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/orange
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/orange/ChangeLog,v 1.3 2004/04/25 22:31:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/orange/ChangeLog,v 1.4 2004/06/23 08:12:59 abhishek Exp $
+
+ 22 Jun 2004; Abhishek Amit <abhishek@gentoo.org> orange-0.2-r1.ebuild:
+ Added DEPEND on synce-libsynce and synce-librapi2, and gets orange to build
+ with new gcc. Thanks to Xoom <admin@secnut.com> for reporting this. Closes bug
+ #54961.
25 Apr 2004; Aron Griffis <agriffis@gentoo.org> orange-0.2-r1.ebuild:
Add die following econf for bug 48950
diff --git a/app-pda/orange/orange-0.2-r1.ebuild b/app-pda/orange/orange-0.2-r1.ebuild
index 4f7bb1c884c7..766495da6aaa 100644
--- a/app-pda/orange/orange-0.2-r1.ebuild
+++ b/app-pda/orange/orange-0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/orange/orange-0.2-r1.ebuild,v 1.3 2004/04/25 22:31:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/orange/orange-0.2-r1.ebuild,v 1.4 2004/06/23 08:12:59 abhishek Exp $
DESCRIPTION="Orange is a tool and library for squeezing out juicy \
installable Microsoft Cabinet Files from self-extracting installers \
@@ -13,8 +13,16 @@ SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="app-pda/dynamite
- app-arch/unshield"
+DEPEND=">=app-pda/dynamite-0.1
+ >=app-arch/unshield-0.2
+ >=app-pda/synce-librapi2-0.8.9
+ >=app-pda/synce-libsynce-0.8.9"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -ie "s:-Werror::" lib/Makefile.am
+}
src_compile() {
econf || die "econf failed"