summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-08-08 14:37:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-08-08 14:37:59 +0000
commit685a462d18b4d9a9b5263a2497bff4610a8ade2d (patch)
tree48b11fd01a66ab52412a564c29765f03abde25fa /app-pda/synce-core
parentRemove tmpfiles.d from systemd locations, since that directory is used by Ope... (diff)
downloadgentoo-2-685a462d18b4d9a9b5263a2497bff4610a8ade2d.tar.gz
gentoo-2-685a462d18b4d9a9b5263a2497bff4610a8ade2d.tar.bz2
gentoo-2-685a462d18b4d9a9b5263a2497bff4610a8ade2d.zip
Dummy revision bump to let upstream ./configure determine udevdir from udev.pc pkg-config file.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/synce-core')
-rw-r--r--app-pda/synce-core/ChangeLog9
-rw-r--r--app-pda/synce-core/synce-core-0.16-r1.ebuild78
2 files changed, 86 insertions, 1 deletions
diff --git a/app-pda/synce-core/ChangeLog b/app-pda/synce-core/ChangeLog
index cb1b057ff274..fcb9c4875fcd 100644
--- a/app-pda/synce-core/ChangeLog
+++ b/app-pda/synce-core/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/synce-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-core/ChangeLog,v 1.3 2012/06/15 09:17:46 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-core/ChangeLog,v 1.4 2012/08/08 14:37:59 ssuominen Exp $
+
+*synce-core-0.16-r1 (08 Aug 2012)
+
+ 08 Aug 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +synce-core-0.16-r1.ebuild:
+ Dummy revision bump to let upstream ./configure determine udevdir from
+ udev.pc pkg-config file.
15 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> synce-core-0.16.ebuild:
Missing dev-python/python-gudev RDEPEND. Run python_convert_shebangs for
diff --git a/app-pda/synce-core/synce-core-0.16-r1.ebuild b/app-pda/synce-core/synce-core-0.16-r1.ebuild
new file mode 100644
index 000000000000..6193ec61ef92
--- /dev/null
+++ b/app-pda/synce-core/synce-core-0.16-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-core/synce-core-0.16-r1.ebuild,v 1.1 2012/08/08 14:37:59 ssuominen Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2:2.7"
+
+inherit flag-o-matic python
+
+DESCRIPTION="Base libraries, including RAPI protocol, tools and dccm daemon"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python static-libs"
+
+# AC_PATH_PROG -> pppd -> net-dialup/ppp
+# AC_PATH_PROG -> ifconfig -> sys-apps/net-tools
+RDEPEND="!app-pda/synce-connector
+ >=dev-libs/dbus-glib-0.98
+ >=dev-libs/glib-2.28
+ !dev-libs/librapi2
+ !dev-libs/libsynce
+ net-dialup/ppp
+ sys-apps/net-tools
+ || ( >=sys-fs/udev-171-r6[gudev] <sys-fs/udev-171[extras] )
+ python? (
+ >=dev-python/pyrex-0.9.6
+ dev-python/python-gudev
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # AC_PATH_PROG -> dhclient ->
+ local dhclient=true
+ type -P dhclient >/dev/null && dhclient=dhclient
+ sed -i -e "s:dhclient:${dhclient}:" configure || die
+
+ use python && python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ append-cflags -fno-strict-aliasing
+
+ # hal OR udev -> udev -> dbus -> build all of bluetooth, odccm, udev
+ econf \
+ $(use_enable static-libs static) \
+ --enable-dccm-file-support \
+ --enable-odccm-support \
+ --disable-hal-support \
+ --enable-udev-support \
+ --enable-bluetooth-support \
+ $(use_enable python python-bindings)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc BUGS ChangeLog README* TODO
+ newdoc bluetooth/README README.bluetooth
+
+ # prune_libtool_files() from eutils.eclass fails wrt #421197
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ # Always remove static archive from site-packages
+ use static-libs && find "${ED}" -name pyrapi2.a -exec rm -f {} +
+}