summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-12-07 00:47:10 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-12-07 00:47:10 +0000
commit794edbcdb14b76ef62c5f332fb6711a027d40dca (patch)
tree04e556d64dd17b830793be9e942ce3901a64c8bf /app-pda/usbmuxd
parentOld version cleanup (diff)
downloadgentoo-2-794edbcdb14b76ef62c5f332fb6711a027d40dca.tar.gz
gentoo-2-794edbcdb14b76ef62c5f332fb6711a027d40dca.tar.bz2
gentoo-2-794edbcdb14b76ef62c5f332fb6711a027d40dca.zip
Initial commit. Ebuild by Tomáš "scarabeus" Chvátal.
(Portage version: 2.2_rc55/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/usbmuxd')
-rw-r--r--app-pda/usbmuxd/ChangeLog10
-rw-r--r--app-pda/usbmuxd/files/usbmuxd-cmake.patch62
-rw-r--r--app-pda/usbmuxd/metadata.xml10
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.0.0_rc2.ebuild25
4 files changed, 107 insertions, 0 deletions
diff --git a/app-pda/usbmuxd/ChangeLog b/app-pda/usbmuxd/ChangeLog
new file mode 100644
index 000000000000..ba0e9e90f129
--- /dev/null
+++ b/app-pda/usbmuxd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-pda/usbmuxd
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/usbmuxd/ChangeLog,v 1.1 2009/12/07 00:47:08 chainsaw Exp $
+
+*usbmuxd-1.0.0_rc2 (07 Dec 2009)
+
+ 07 Dec 2009; <chainsaw@gentoo.org> +usbmuxd-1.0.0_rc2.ebuild,
+ +files/usbmuxd-cmake.patch:
+ Initial commit. Ebuild by Tomáš "scarabeus" Chvátal.
+
diff --git a/app-pda/usbmuxd/files/usbmuxd-cmake.patch b/app-pda/usbmuxd/files/usbmuxd-cmake.patch
new file mode 100644
index 000000000000..11e3bdfa3485
--- /dev/null
+++ b/app-pda/usbmuxd/files/usbmuxd-cmake.patch
@@ -0,0 +1,62 @@
+diff -urN usbmuxd-1.0.0-rc2.old/CMakeLists.txt usbmuxd-1.0.0-rc2/CMakeLists.txt
+--- usbmuxd-1.0.0-rc2.old/CMakeLists.txt 2009-10-31 02:30:59.000000000 +0100
++++ usbmuxd-1.0.0-rc2/CMakeLists.txt 2009-12-07 01:13:46.000000000 +0100
+@@ -16,13 +16,15 @@
+
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/Modules/")
+
++set( CMAKE_C_FLAGS "-Wall -O2 -g" )
++
+ add_subdirectory (libusbmuxd)
+ add_subdirectory (daemon)
+ add_subdirectory (tools)
+ add_subdirectory (udev)
+
+ # pkg-config
+-CONFIGURE_FILE ("${CMAKE_SOURCE_DIR}/libusbmuxd.pc.in" "${CMAKE_CURRENT_BINARY_DIR}/libusbmuxd.pc")
++CONFIGURE_FILE ("${CMAKE_CURRENT_SOURCE_DIR}/libusbmuxd.pc.in" "${CMAKE_CURRENT_BINARY_DIR}/libusbmuxd.pc")
+ # install pkg-config file
+ INSTALL (FILES "${CMAKE_CURRENT_BINARY_DIR}/libusbmuxd.pc" DESTINATION lib${LIB_SUFFIX}/pkgconfig/)
+
+diff -urN usbmuxd-1.0.0-rc2.old/daemon/CMakeLists.txt usbmuxd-1.0.0-rc2/daemon/CMakeLists.txt
+--- usbmuxd-1.0.0-rc2.old/daemon/CMakeLists.txt 2009-10-31 02:30:59.000000000 +0100
++++ usbmuxd-1.0.0-rc2/daemon/CMakeLists.txt 2009-12-07 01:13:34.000000000 +0100
+@@ -6,7 +6,8 @@
+ include_directories (${CMAKE_SOURCE_DIR}/daemon)
+ include_directories (${CMAKE_SOURCE_DIR}/libusbmuxd)
+
+-add_definitions(-Wall -O2 -g -DUSBMUXD_DAEMON -DUSBMUXD_VERSION="${USBMUXD_VERSION}")
++set( CMAKE_C_FLAGS "-Wall -O2 -g" )
++add_definitions(-DUSBMUXD_DAEMON -DUSBMUXD_VERSION="${USBMUXD_VERSION}")
+ add_executable(usbmuxd main.c usb-linux.c log.c ../common/utils.c device.c client.c)
+ target_link_libraries(usbmuxd ${LIBS})
+
+diff -urN usbmuxd-1.0.0-rc2.old/libusbmuxd/CMakeLists.txt usbmuxd-1.0.0-rc2/libusbmuxd/CMakeLists.txt
+--- usbmuxd-1.0.0-rc2.old/libusbmuxd/CMakeLists.txt 2009-10-31 02:30:59.000000000 +0100
++++ usbmuxd-1.0.0-rc2/libusbmuxd/CMakeLists.txt 2009-12-07 01:31:06.000000000 +0100
+@@ -1,8 +1,8 @@
+ include_directories (${CMAKE_SOURCE_DIR}/common)
++find_package(Threads)
+
+-add_library (libusbmuxd SHARED libusbmuxd.c sock_stuff.c ../common/utils.c)
+-find_library (PTHREAD pthread)
+-target_link_libraries (libusbmuxd ${PTHREAD})
++add_library (libusbmuxd SHARED libusbmuxd.c sock_stuff.c ${CMAKE_SOURCE_DIR}/common/utils.c)
++target_link_libraries (libusbmuxd ${CMAKE_THREAD_LIBS_INIT})
+ # 'lib' is a UNIXism, the proper CMake target is usbmuxd
+ # But we can't use that due to the conflict with the usbmuxd daemon,
+ # so instead change the library output base name to usbmuxd here
+diff -urN usbmuxd-1.0.0-rc2.old/tools/CMakeLists.txt usbmuxd-1.0.0-rc2/tools/CMakeLists.txt
+--- usbmuxd-1.0.0-rc2.old/tools/CMakeLists.txt 2009-10-31 02:30:59.000000000 +0100
++++ usbmuxd-1.0.0-rc2/tools/CMakeLists.txt 2009-12-07 01:24:27.000000000 +0100
+@@ -1,8 +1,7 @@
+ include_directories (${CMAKE_SOURCE_DIR}/libusbmuxd)
+ link_directories (${CMAKE_BINARY_DIR}/libusbmuxd)
+
+-add_definitions(-Wall -O2 -g)
+ add_executable(iproxy iproxy.c)
+ target_link_libraries(iproxy libusbmuxd pthread)
+
+-install(TARGETS iproxy RUNTIME DESTINATION bin)
+\ Chybí znak konce řádku na konci souboru
++install(TARGETS iproxy RUNTIME DESTINATION bin)
diff --git a/app-pda/usbmuxd/metadata.xml b/app-pda/usbmuxd/metadata.xml
new file mode 100644
index 000000000000..0bef3c15362f
--- /dev/null
+++ b/app-pda/usbmuxd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pda</herd>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/app-pda/usbmuxd/usbmuxd-1.0.0_rc2.ebuild b/app-pda/usbmuxd/usbmuxd-1.0.0_rc2.ebuild
new file mode 100644
index 000000000000..06d6243b7626
--- /dev/null
+++ b/app-pda/usbmuxd/usbmuxd-1.0.0_rc2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/usbmuxd/usbmuxd-1.0.0_rc2.ebuild,v 1.1 2009/12/07 00:47:08 chainsaw Exp $
+
+EAPI="2"
+
+inherit base cmake-utils
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://marcansoft.com/blog/iphonelinux/usbmuxd/"
+SRC_URI="http://marcansoft.com/uploads/${PN}/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-cmake.patch"
+)
+
+S=${WORKDIR}/${P/_/-}