summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2008-01-27 17:54:40 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2008-01-27 17:54:40 +0000
commit002b5432bbe45bb9ed2172225d3ee29739891374 (patch)
tree8bced57ac136a0c25e5eb4c6ba9a2e25581e6c66 /app-pda
parentinitial import, thanks to Bardur Arantsson <bugs-gentoo.org@scientician.net>,... (diff)
downloadgentoo-2-002b5432bbe45bb9ed2172225d3ee29739891374.tar.gz
gentoo-2-002b5432bbe45bb9ed2172225d3ee29739891374.tar.bz2
gentoo-2-002b5432bbe45bb9ed2172225d3ee29739891374.zip
Add 0.36.
(Portage version: 2.1.4)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libopensync-plugin-syncml/ChangeLog10
-rw-r--r--app-pda/libopensync-plugin-syncml/files/digest-libopensync-plugin-syncml-0.363
-rw-r--r--app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.36.ebuild52
3 files changed, 63 insertions, 2 deletions
diff --git a/app-pda/libopensync-plugin-syncml/ChangeLog b/app-pda/libopensync-plugin-syncml/ChangeLog
index 50b6c703d376..252ba3e6bb90 100644
--- a/app-pda/libopensync-plugin-syncml/ChangeLog
+++ b/app-pda/libopensync-plugin-syncml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/libopensync-plugin-syncml
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-syncml/ChangeLog,v 1.8 2007/12/29 14:46:40 peper Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-syncml/ChangeLog,v 1.9 2008/01/27 17:54:39 peper Exp $
+
+*libopensync-plugin-syncml-0.36 (27 Jan 2008)
+
+ 27 Jan 2008; Piotr Jaroszyński <peper@gentoo.org>
+ +libopensync-plugin-syncml-0.36.ebuild:
+ Add 0.36.
*libopensync-plugin-syncml-0.35 (21 Dec 2007)
diff --git a/app-pda/libopensync-plugin-syncml/files/digest-libopensync-plugin-syncml-0.36 b/app-pda/libopensync-plugin-syncml/files/digest-libopensync-plugin-syncml-0.36
new file mode 100644
index 000000000000..bf80167bb2c6
--- /dev/null
+++ b/app-pda/libopensync-plugin-syncml/files/digest-libopensync-plugin-syncml-0.36
@@ -0,0 +1,3 @@
+MD5 3c83493143fbfabf6600aea8d310167c libopensync-plugin-syncml-0.36.tar.bz2 51021
+RMD160 8e0f5de8e29f56dd0c011d0d61ab21ba501d3943 libopensync-plugin-syncml-0.36.tar.bz2 51021
+SHA256 d0db5ccdbf98012a9b70671c7b90cf8eed1f5133ac61563e97d7abf1533dc6e9 libopensync-plugin-syncml-0.36.tar.bz2 51021
diff --git a/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.36.ebuild b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.36.ebuild
new file mode 100644
index 000000000000..d675fbff920e
--- /dev/null
+++ b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.36.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.36.ebuild,v 1.1 2008/01/27 17:54:39 peper Exp $
+
+EAPI="1"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="OpenSync SyncML Plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="http +obex"
+
+DEPEND="=app-pda/libopensync-${PV}*
+ >=app-pda/libsyncml-0.4.6"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! use obex && ! use http; then
+ eerror "${CATEGORY}/${P} without support for obex nor http is unusable."
+ eerror "Please enable \"obex\" or/and \"http\" USE flags."
+ die "Please enable \"obex\" or/and \"http\" USE flags."
+ fi
+
+ if use obex && ! built_with_use app-pda/libsyncml obex; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"obex\""
+ eerror "USE flags, but app-pda/libsyncml was built without"
+ eerror "the \"obex\" USE flag."
+ eerror "Please rebuild app-pda/libsyncml with \"obex\" USE flag."
+ die "Please rebuild app-pda/libsyncml with \"obex\" USE flag."
+ fi
+
+ if use http && ! built_with_use app-pda/libsyncml http; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"http\""
+ eerror "USE flags, but app-pda/libsyncml was built without"
+ eerror "the \"http\" USE flag."
+ eerror "Please rebuild app-pda/libsyncml with \"http\" USE flag."
+ die "Please rebuild app-pda/libsyncml with \"http\" USE flag."
+ fi
+}
+
+src_compile() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable http HTTP)
+ $(cmake-utils_use_enable obex OBEX)"
+
+ cmake-utils_src_compile
+}