summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-07-24 20:40:09 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-07-24 20:40:09 +0000
commit0d1486cf25ca129c5aaa76f13e2a01e462bc4007 (patch)
tree030b42b95e54d473bcc33b59ea9f78ca97c68863 /app-pda
parentConfiguration files need to be owned by user unrealircd. (Manifest recommit) (diff)
downloadgentoo-2-0d1486cf25ca129c5aaa76f13e2a01e462bc4007.tar.gz
gentoo-2-0d1486cf25ca129c5aaa76f13e2a01e462bc4007.tar.bz2
gentoo-2-0d1486cf25ca129c5aaa76f13e2a01e462bc4007.zip
added bluetooth sdp patch for multisync. thanks to Ronny Haryanto <rh-gentoo@terasi.net> (#55758)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/multisync/ChangeLog7
-rw-r--r--app-pda/multisync/files/multisync-0.82-bluetooth-sdp.patch19
-rw-r--r--app-pda/multisync/multisync-0.82.ebuild3
3 files changed, 27 insertions, 2 deletions
diff --git a/app-pda/multisync/ChangeLog b/app-pda/multisync/ChangeLog
index a8a3219f96bc..f2c2e6fedd30 100644
--- a/app-pda/multisync/ChangeLog
+++ b/app-pda/multisync/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/multisync
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/ChangeLog,v 1.12 2004/07/01 19:23:59 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/ChangeLog,v 1.13 2004/07/24 20:40:09 liquidx Exp $
+
+ 24 Jul 2004; Alastair Tse <liquidx@gentoo.org>
+ +files/multisync-0.82-bluetooth-sdp.patch, multisync-0.82.ebuild:
+ added bluetooth sdp patch for multisync. thanks to Ronny Haryanto
+ <rh-gentoo@terasi.net> (#55758)
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
multisync-0.80-r1.ebuild, multisync-0.81-r1.ebuild, multisync-0.81.ebuild:
diff --git a/app-pda/multisync/files/multisync-0.82-bluetooth-sdp.patch b/app-pda/multisync/files/multisync-0.82-bluetooth-sdp.patch
new file mode 100644
index 000000000000..b088b2d4a69c
--- /dev/null
+++ b/app-pda/multisync/files/multisync-0.82-bluetooth-sdp.patch
@@ -0,0 +1,19 @@
+--- plugins/irmc_sync/configure.orig 2004-07-01 17:20:02.033042906 +1000
++++ plugins/irmc_sync/configure 2004-07-01 17:20:51.129570206 +1000
+@@ -4308,13 +4308,13 @@
+ fi
+
+ SDP=0
+-echo "$as_me:$LINENO: checking for sdp_list_free in -lsdp" >&5
+-echo $ECHO_N "checking for sdp_list_free in -lsdp... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for sdp_list_free in -lbluetooth" >&5
++echo $ECHO_N "checking for sdp_list_free in -lbluetooth... $ECHO_C" >&6
+ if test "${ac_cv_lib_sdp_sdp_list_free+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lsdp $LIBS"
++LIBS="-lbluetooth $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ /* confdefs.h. */
diff --git a/app-pda/multisync/multisync-0.82.ebuild b/app-pda/multisync/multisync-0.82.ebuild
index 8044f266819b..e34a1ba03c83 100644
--- a/app-pda/multisync/multisync-0.82.ebuild
+++ b/app-pda/multisync/multisync-0.82.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/multisync-0.82.ebuild,v 1.3 2004/07/09 23:40:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/multisync-0.82.ebuild,v 1.4 2004/07/24 20:40:09 liquidx Exp $
inherit eutils
@@ -49,6 +49,7 @@ src_unpack() {
# Fix the opie Makefile
cd ${S}
epatch ${FILESDIR}/${PN}-0.81-gentoo.patch
+ epatch ${FILESDIR}/${PN}-0.82-bluetooth-sdp.patch
}
src_compile() {