summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2007-03-03 16:32:15 +0000
committerHarald van Dijk <truedfx@gentoo.org>2007-03-03 16:32:15 +0000
commitfdae36677a664e28497f323c12922a7bb5bc6e33 (patch)
treecd9f9415b6687196f6d76b33a6bc99dca7900d8d /app-portage/cfg-update
parentDon't use which to determine where depend-java-query is installed but hardcod... (diff)
downloadgentoo-2-fdae36677a664e28497f323c12922a7bb5bc6e33.tar.gz
gentoo-2-fdae36677a664e28497f323c12922a7bb5bc6e33.tar.bz2
gentoo-2-fdae36677a664e28497f323c12922a7bb5bc6e33.zip
Install ChangeLog in the appropriate location, and put the checksum index in /var/lib (#166983)
(Portage version: 2.1.2-r12)
Diffstat (limited to 'app-portage/cfg-update')
-rw-r--r--app-portage/cfg-update/ChangeLog7
-rw-r--r--app-portage/cfg-update/cfg-update-1.8.0-r6.ebuild43
2 files changed, 40 insertions, 10 deletions
diff --git a/app-portage/cfg-update/ChangeLog b/app-portage/cfg-update/ChangeLog
index 5c863123fbe3..11a8bda1e63b 100644
--- a/app-portage/cfg-update/ChangeLog
+++ b/app-portage/cfg-update/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/cfg-update
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/ChangeLog,v 1.12 2007/03/03 12:07:20 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/ChangeLog,v 1.13 2007/03/03 16:32:15 truedfx Exp $
+
+ 03 Mar 2007; Harald van Dijk <truedfx@gentoo.org>
+ cfg-update-1.8.0-r6.ebuild:
+ Install ChangeLog in the appropriate location, and put the checksum index in
+ /var/lib (#166983)
03 Mar 2007; Raúl Porcel <armin76@gentoo.org> cfg-update-1.8.0-r6.ebuild:
x86 stable wrt bug 166983
diff --git a/app-portage/cfg-update/cfg-update-1.8.0-r6.ebuild b/app-portage/cfg-update/cfg-update-1.8.0-r6.ebuild
index 5a79c990e402..5f459c6eafa2 100644
--- a/app-portage/cfg-update/cfg-update-1.8.0-r6.ebuild
+++ b/app-portage/cfg-update/cfg-update-1.8.0-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/cfg-update-1.8.0-r6.ebuild,v 1.3 2007/03/03 12:07:20 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/cfg-update/cfg-update-1.8.0-r6.ebuild,v 1.4 2007/03/03 16:32:15 truedfx Exp $
DESCRIPTION="Easy to use GUI & CLI alternative for etc-update with safe automatic updating functionality"
HOMEPAGE="http://people.zeelandnet.nl/xentric/"
@@ -23,28 +23,53 @@ pkg_postrm() {
ewarn "If you want to permanently remove cfg-update from your system"
ewarn "you should manually remove the alias for emerge from /root/.bashrc"
ewarn "followed by running: unalias emerge"
- ewarn "and remove the index file /usr/lib/cfg-update/checksum-index"
+ ewarn "and remove the index file /var/lib/cfg-update/checksum.index"
ewarn
ewarn "If you are just updating to a newer version you should read the"
ewarn "installation instructions on http://people.zeelandnet.nl/xentric"
ewarn
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cat >>cfg-update.conf <<-EOF
+
+ INDEXFILE = /var/lib/cfg-update/checksum.index
+ EOF
+}
+
src_install() {
exeinto /usr/bin
doexe cfg-update emerge_with_indexing_for_cfg-update emerge_with_indexing_for_cfg-update_phphelper cfg-update_phphelper emerge_with_indexing_for_cfg-update_bashhelper
insinto /usr/lib/cfg-update
- doins .bashrc ChangeLog cfg-update
+ doins cfg-update .bashrc
+ dodoc ChangeLog
doman *.8
insinto /etc
doins cfg-update.conf
+ keepdir /var/lib/cfg-update
}
pkg_postinst() {
- einfo "Converting old backups to new filename format..."
- cfg-update --convert-old-backups &>/dev/null
- einfo "Trying to remove old emerge alias from /etc/profile..."
- cfg-update --remove-old-alias &>/dev/null
- ewarn "Please read the installation instructions on http://people.zeelandnet.nl/xentric"
- ewarn "You need to run cfg-update --on after installation!"
+ if [[ ! -e "${ROOT}"/var/lib/cfg-update/checksum.index \
+ && -e "${ROOT}"/var/lib/cfg-update/checksum.index ]]
+ then
+ ebegin "Moving checksum.index from /usr/lib/cfg-update to /var/lib/cfg-update"
+ mv "${ROOT}"/usr/lib/cfg-update/checksum.index \
+ "${ROOT}"/var/lib/cfg-update/checksum.index
+ eend $?
+ fi
+
+ if [[ ${ROOT} = / ]]
+ then
+ ebegin "Converting old backups to new filename format"
+ cfg-update --convert-old-backups &>/dev/null
+ eend $?
+ ebegin "Trying to remove old emerge alias from /etc/profile"
+ cfg-update --remove-old-alias &>/dev/null
+ eend $?
+ ewarn "Please read the installation instructions on http://people.zeelandnet.nl/xentric"
+ ewarn "You need to run cfg-update --on after installation!"
+ fi
}