summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-01-14 23:46:26 +0000
committerZac Medico <zmedico@gentoo.org>2009-01-14 23:46:26 +0000
commitc5aa431a1f74bc1f91a8ac9df7e7f01e97973dc6 (patch)
tree929569ebb947f40db170222a4cf6556116666a42 /app-portage/genlop
parentVersion bump, ebuild fixes submitted by Seth W. (Jzalae) Klein (diff)
downloadgentoo-2-c5aa431a1f74bc1f91a8ac9df7e7f01e97973dc6.tar.gz
gentoo-2-c5aa431a1f74bc1f91a8ac9df7e7f01e97973dc6.tar.bz2
gentoo-2-c5aa431a1f74bc1f91a8ac9df7e7f01e97973dc6.zip
*genlop-0.30.8-r2 (14 Jan 2009)
14 Jan 2009; Zac Medico <zmedico@gentoo.org> +genlop-0.30.8-r2.ebuild, +files/genlop-0.30.8-compiling-category.patch: Bug #254972 - Fix genlop -c to work with both new and old portage. (Portage version: 12514-svn/cvs/Linux i686)
Diffstat (limited to 'app-portage/genlop')
-rw-r--r--app-portage/genlop/ChangeLog10
-rw-r--r--app-portage/genlop/files/genlop-0.30.8-compiling-category.patch10
-rw-r--r--app-portage/genlop/genlop-0.30.8-r2.ebuild33
3 files changed, 51 insertions, 2 deletions
diff --git a/app-portage/genlop/ChangeLog b/app-portage/genlop/ChangeLog
index 87b1b44fb85b..adccdb9e42f4 100644
--- a/app-portage/genlop/ChangeLog
+++ b/app-portage/genlop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/genlop
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/genlop/ChangeLog,v 1.69 2007/11/19 01:40:13 kumba Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/genlop/ChangeLog,v 1.70 2009/01/14 23:46:26 zmedico Exp $
+
+*genlop-0.30.8-r2 (14 Jan 2009)
+
+ 14 Jan 2009; Zac Medico <zmedico@gentoo.org> +genlop-0.30.8-r2.ebuild,
+ +files/genlop-0.30.8-compiling-category.patch:
+ Bug #254972 - Fix genlop -c to work with both new and old portage.
19 Nov 2007; Joshua Kinard <kumba@gentoo.org> genlop-0.30.8-r1.ebuild:
Stable on mips, per #197215.
diff --git a/app-portage/genlop/files/genlop-0.30.8-compiling-category.patch b/app-portage/genlop/files/genlop-0.30.8-compiling-category.patch
new file mode 100644
index 000000000000..9f6c502b2adf
--- /dev/null
+++ b/app-portage/genlop/files/genlop-0.30.8-compiling-category.patch
@@ -0,0 +1,10 @@
+--- genlop
++++ genlop
+@@ -694,6 +694,7 @@
+ {
+ my $e_current;
+ $ebuild_arg =~ s/(\+)/\\$1/g;
++ $ebuild_arg =~ s/.*\///g;
+ foreach my $logfile (@logfiles)
+ {
+ my $handle;
diff --git a/app-portage/genlop/genlop-0.30.8-r2.ebuild b/app-portage/genlop/genlop-0.30.8-r2.ebuild
new file mode 100644
index 000000000000..1c3d562d51bd
--- /dev/null
+++ b/app-portage/genlop/genlop-0.30.8-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/genlop/genlop-0.30.8-r2.ebuild,v 1.1 2009/01/14 23:46:26 zmedico Exp $
+
+inherit eutils bash-completion
+
+DESCRIPTION="A nice emerge.log parser"
+HOMEPAGE="http://www.gentoo.org/proj/en/perl"
+SRC_URI="mirror://gentoo//${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.8.0-r12
+ >=dev-perl/DateManip-5.40
+ dev-perl/libwww-perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-version.patch"
+ epatch "${FILESDIR}/${P}-compiling-category.patch"
+}
+
+src_install() {
+ dobin genlop || die "failed to install genlop (via dobin)"
+ dodoc README Changelog
+ doman genlop.1
+ dobashcompletion genlop.bash-completion genlop
+}