summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2006-05-31 18:58:59 +0000
committerPaul Varner <fuzzyray@gentoo.org>2006-05-31 18:58:59 +0000
commit00df5bc0a71f21e9a85554a9243fefbc7d16b29e (patch)
tree9c4596d57bbd42f023ccc5605cf09b60e9e3292f /app-portage
parentFix for gcc-4.1, bug #133815 (diff)
downloadgentoo-2-00df5bc0a71f21e9a85554a9243fefbc7d16b29e.tar.gz
gentoo-2-00df5bc0a71f21e9a85554a9243fefbc7d16b29e.tar.bz2
gentoo-2-00df5bc0a71f21e9a85554a9243fefbc7d16b29e.zip
Release gentoolkit-0.2.2 for going stable in conjunction with portage-2.1
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoolkit/ChangeLog10
-rw-r--r--app-portage/gentoolkit/files/digest-gentoolkit-0.2.23
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.2.2.ebuild47
3 files changed, 59 insertions, 1 deletions
diff --git a/app-portage/gentoolkit/ChangeLog b/app-portage/gentoolkit/ChangeLog
index 35ded54a45fd..4615603b4890 100644
--- a/app-portage/gentoolkit/ChangeLog
+++ b/app-portage/gentoolkit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-portage/gentoolkit
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.79 2006/05/24 14:18:09 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.80 2006/05/31 18:58:59 fuzzyray Exp $
+
+*gentoolkit-0.2.2 (31 May 2006)
+
+ 31 May 2006; Paul Varner <fuzzyray@gentoo.org>
+ -gentoolkit-0.2.2_pre4.ebuild, -gentoolkit-0.2.2_rc1.ebuild,
+ +gentoolkit-0.2.2.ebuild:
+ Release gentoolkit-0.2.2 for going stable in conjunction with portage-2.1.
+ Remove outdated ebuilds.
*gentoolkit-0.2.2_rc1 (23 May 2006)
diff --git a/app-portage/gentoolkit/files/digest-gentoolkit-0.2.2 b/app-portage/gentoolkit/files/digest-gentoolkit-0.2.2
new file mode 100644
index 000000000000..a0fcb6480b98
--- /dev/null
+++ b/app-portage/gentoolkit/files/digest-gentoolkit-0.2.2
@@ -0,0 +1,3 @@
+MD5 5b9a3a4a4b481c749b22f773785091e4 gentoolkit-0.2.2.tar.gz 86175
+RMD160 0da25ea04d289095bea2782e58f5a6a18d96766f gentoolkit-0.2.2.tar.gz 86175
+SHA256 060ab184f9038dfbf13849b4a35d973065e3be2d5592dce44cbcba218b4cc5fa gentoolkit-0.2.2.tar.gz 86175
diff --git a/app-portage/gentoolkit/gentoolkit-0.2.2.ebuild b/app-portage/gentoolkit/gentoolkit-0.2.2.ebuild
new file mode 100644
index 000000000000..82eda2efcd37
--- /dev/null
+++ b/app-portage/gentoolkit/gentoolkit-0.2.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/gentoolkit-0.2.2.ebuild,v 1.1 2006/05/31 18:58:59 fuzzyray Exp $
+
+inherit eutils python
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/tools/index.xml"
+SRC_URI="mirror://gentoo/${P}.tar.gz http://dev.gentoo.org/~fuzzyray/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DEPEND=">=sys-apps/portage-2.0.51_pre21
+ >=dev-lang/python-2.0
+ >=dev-lang/perl-5.6
+ >=sys-apps/grep-2.4
+ userland_GNU? ( sys-apps/debianutils )"
+
+src_install() {
+ make DESTDIR=${D} install-gentoolkit || die
+}
+
+pkg_preinst() {
+ # FIXME: Remove from future ebuilds after gentoolkit-0.2.2 is stable
+ rm -f ${ROOT}/usr/lib/gentoolkit/pym/gentoolkit.py[co] ${ROOT}/usr/lib/gentoolkit/pym/gentoolkit/*.py[co]
+}
+
+pkg_postinst() {
+ python_mod_optimize ${ROOT}usr/lib/gentoolkit
+ echo
+ ewarn "The qpkg and etcat tools are deprecated in favor of equery and"
+ ewarn "are no longer installed in ${ROOT}usr/bin in this release."
+ ewarn "They are still available in ${ROOT}usr/share/doc/${PF}/deprecated/"
+ ewarn "if you *really* want to use them."
+ echo
+ einfo "Another alternative to qpkg and equery are the q applets in"
+ einfo "app-portage/portage-utils"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${ROOT}usr/lib/gentoolkit
+}