summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2011-12-12 18:44:29 +0000
committerPaul Varner <fuzzyray@gentoo.org>2011-12-12 18:44:29 +0000
commit0bb69e2de1b978e295cfbc06e5dad8207bf5a96f (patch)
treeee5f75751cf2b25be2f4c73deca0d8f5db97f7be /app-portage
parentStable for AMD64, wrt security bug #394095 (diff)
downloadgentoo-2-0bb69e2de1b978e295cfbc06e5dad8207bf5a96f.tar.gz
gentoo-2-0bb69e2de1b978e295cfbc06e5dad8207bf5a96f.tar.bz2
gentoo-2-0bb69e2de1b978e295cfbc06e5dad8207bf5a96f.zip
Revison bump to remove hardcoded /usr/lib/portage/pym path. Bug #394209
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/esearch/ChangeLog8
-rw-r--r--app-portage/esearch/esearch-1.0-r1.ebuild61
-rw-r--r--app-portage/esearch/files/1.0-fix-EPREFIX-capability.patch25
3 files changed, 93 insertions, 1 deletions
diff --git a/app-portage/esearch/ChangeLog b/app-portage/esearch/ChangeLog
index 10c596103e6e..faaf812feb3f 100644
--- a/app-portage/esearch/ChangeLog
+++ b/app-portage/esearch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/esearch
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/ChangeLog,v 1.73 2011/11/30 21:03:32 fuzzyray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/ChangeLog,v 1.74 2011/12/12 18:44:28 fuzzyray Exp $
+
+*esearch-1.0-r1 (12 Dec 2011)
+
+ 12 Dec 2011; Paul Varner <fuzzyray@gentoo.org>
+ +files/1.0-fix-EPREFIX-capability.patch, +esearch-1.0-r1.ebuild:
+ Revison bump to remove hardcoded /usr/lib/portage/pym path. Bug #394209
*esearch-1.0 (30 Nov 2011)
diff --git a/app-portage/esearch/esearch-1.0-r1.ebuild b/app-portage/esearch/esearch-1.0-r1.ebuild
new file mode 100644
index 000000000000..4bd018d522cd
--- /dev/null
+++ b/app-portage/esearch/esearch-1.0-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/esearch-1.0-r1.ebuild,v 1.1 2011/12/12 18:44:28 fuzzyray Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45]"
+PYTHON_USE_WITH="readline"
+PYTHON_NONVERSIONED_EXECUTABLES=(".*")
+
+inherit base distutils python
+
+DESCRIPTION="Replacement for 'emerge --search' with search-index"
+HOMEPAGE="http://david-peter.de/esearch.html"
+SRC_URI="mirror://github/fuzzyray/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="linguas_fr linguas_it"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+
+DEPEND="sys-apps/portage"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PV}-fix-EPREFIX-capability.patch )
+
+distutils_src_compile_pre_hook() {
+ echo VERSION="${PVR}" "$(PYTHON)" setup.py set_version
+ VERSION="${PVR}" "$(PYTHON)" setup.py set_version \
+ || die "setup.py set_version failed"
+}
+
+src_prepare() {
+ base_src_prepare
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ python_convert_shebangs -r "" build-*/scripts-*
+ distutils_src_install
+ dodoc eupdatedb.cron || die "dodoc failed"
+
+ # Remove unused man pages according to the linguas flags
+ if ! use linguas_fr ; then
+ rm -rf "${ED}"/usr/share/man/fr
+ fi
+
+ if ! use linguas_it ; then
+ rm -rf "${ED}"/usr/share/man/it
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ ewarn "Because file locations have changed, please run 'hash -r' in your active shells."
+}
diff --git a/app-portage/esearch/files/1.0-fix-EPREFIX-capability.patch b/app-portage/esearch/files/1.0-fix-EPREFIX-capability.patch
new file mode 100644
index 000000000000..edf9a600a2e2
--- /dev/null
+++ b/app-portage/esearch/files/1.0-fix-EPREFIX-capability.patch
@@ -0,0 +1,25 @@
+From 8399831cd2f5968fc45d0f1dc4e131368161e39a Mon Sep 17 00:00:00 2001
+From: Brian Dolbec <dolsen@gentoo.org>
+Date: Fri, 9 Dec 2011 23:58:52 -0800
+Subject: [PATCH] apply zmedico's patch to fix EPREFIX capability.
+
+---
+ esearch/search.py | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/esearch/search.py b/esearch/search.py
+index 8498687..f296cb7 100755
+--- a/esearch/search.py
++++ b/esearch/search.py
+@@ -15,7 +15,7 @@ from os import listdir, getenv, system
+ from os.path import isdir, exists
+ import re
+
+-sys.path.insert(0, "/usr/lib/portage/pym")
++#sys.path.insert(0, "/usr/lib/portage/pym")
+ # commented out so it can run from the git checkout
+ #sys.path.insert(0, "/usr/lib/esearch")
+
+--
+1.7.8
+