summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-01-24 23:36:12 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-01-24 23:36:12 +0000
commit50fb9d05a9cfbdb1e8c6db08ba11e799e90f8d7c (patch)
treedee529444221eadc8c2b537a48c9297e0e19f9f6 /app-portage
parentAdd x11-libs/libnotify mask for early breakage detection. (diff)
downloadgentoo-2-50fb9d05a9cfbdb1e8c6db08ba11e799e90f8d7c.tar.gz
gentoo-2-50fb9d05a9cfbdb1e8c6db08ba11e799e90f8d7c.tar.bz2
gentoo-2-50fb9d05a9cfbdb1e8c6db08ba11e799e90f8d7c.zip
Bump. Bug #352561: Allow --cpan_reload without other arguments. Bug #350070: failure to reset a file pointer caused creation of new packages where they existed already.
(Portage version: 2.2.0_alpha18/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/g-cpan/ChangeLog9
-rw-r--r--app-portage/g-cpan/g-cpan-0.16.4.ebuild38
2 files changed, 46 insertions, 1 deletions
diff --git a/app-portage/g-cpan/ChangeLog b/app-portage/g-cpan/ChangeLog
index 8f3a7df272d4..02a3953353d7 100644
--- a/app-portage/g-cpan/ChangeLog
+++ b/app-portage/g-cpan/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/g-cpan
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/g-cpan/ChangeLog,v 1.63 2011/01/24 07:41:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/g-cpan/ChangeLog,v 1.64 2011/01/24 23:36:12 robbat2 Exp $
+
+*g-cpan-0.16.4 (24 Jan 2011)
+
+ 24 Jan 2011; Robin H. Johnson <robbat2@gentoo.org> +g-cpan-0.16.4.ebuild:
+ Bump. Bug #352561: Allow --cpan_reload without other arguments. Bug #350070:
+ failure to reset a file pointer caused creation of new packages where they
+ existed already.
24 Jan 2011; Robin H. Johnson <robbat2@gentoo.org> -g-cpan-0.13.01.ebuild,
-g-cpan-0.14.1_rc1.ebuild, -g-cpan-0.15.0.ebuild, -g-cpan-0.16.0.ebuild,
diff --git a/app-portage/g-cpan/g-cpan-0.16.4.ebuild b/app-portage/g-cpan/g-cpan-0.16.4.ebuild
new file mode 100644
index 000000000000..b24668961bbd
--- /dev/null
+++ b/app-portage/g-cpan/g-cpan-0.16.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/g-cpan/g-cpan-0.16.4.ebuild,v 1.1 2011/01/24 23:36:12 robbat2 Exp $
+
+EAPI=2
+
+inherit perl-module
+
+DESCRIPTION="g-cpan: generate and install CPAN modules using portage"
+HOMEPAGE="http://www.gentoo.org/proj/en/perl/g-cpan.xml"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ http://dev.gentoo.org/~robbat2/distfiles/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ >=dev-perl/yaml-0.60
+ dev-perl/Shell-EnvImporter
+ dev-perl/Log-Agent"
+
+src_install() {
+ perl-module_src_install
+ diropts "-m0755"
+ dodir "/var/tmp/g-cpan"
+ keepdir "/var/tmp/g-cpan"
+ dodir "/var/log/g-cpan"
+ keepdir "/var/log/g-cpan"
+}
+
+pkg_postinst() {
+ elog "You may wish to adjust the permissions on /var/tmp/g-cpan"
+ elog "if you have users besides root expecting to use g-cpan."
+ einfo "Please note that some CPAN packages need additional manual"
+ einfo "parameters or tweaking, due to bugs in their build systems."
+}