summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2013-09-10 19:25:33 +0000
committerPaul Varner <fuzzyray@gentoo.org>2013-09-10 19:25:33 +0000
commit7fe44ebf26ff003d85331bfcfee0c7a8d9a48153 (patch)
treef96f52fe04844005bec0d5db7c1667e4460d7c8a /app-portage
parentarm stable, bug #480102 (diff)
downloadgentoo-2-7fe44ebf26ff003d85331bfcfee0c7a8d9a48153.tar.gz
gentoo-2-7fe44ebf26ff003d85331bfcfee0c7a8d9a48153.tar.bz2
gentoo-2-7fe44ebf26ff003d85331bfcfee0c7a8d9a48153.zip
Revison bump to add patches to fix revdep-rebuild bugs 476740 and 484340.
(Portage version: 2.2.2/cvs/Linux x86_64, signed Manifest commit with key 0xDCB4A7FF)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoolkit/ChangeLog9
-rw-r--r--app-portage/gentoolkit/files/0.3.0.8-revdep-rebuild-476740.patch33
-rw-r--r--app-portage/gentoolkit/files/0.3.0.8-revdep-rebuild-484340.patch46
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.3.0.8-r1.ebuild86
4 files changed, 173 insertions, 1 deletions
diff --git a/app-portage/gentoolkit/ChangeLog b/app-portage/gentoolkit/ChangeLog
index 8e411d435bc8..20964ddbbd1c 100644
--- a/app-portage/gentoolkit/ChangeLog
+++ b/app-portage/gentoolkit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/gentoolkit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.298 2013/09/05 18:25:00 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.299 2013/09/10 19:25:33 fuzzyray Exp $
+
+*gentoolkit-0.3.0.8-r1 (10 Sep 2013)
+
+ 10 Sep 2013; Paul Varner <fuzzyray@gentoo.org> +gentoolkit-0.3.0.8-r1.ebuild,
+ +files/0.3.0.8-revdep-rebuild-476740.patch,
+ +files/0.3.0.8-revdep-rebuild-484340.patch:
+ Revison bump to add patches to fix revdep-rebuild bugs 476740 and 484340.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> gentoolkit-9999.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/app-portage/gentoolkit/files/0.3.0.8-revdep-rebuild-476740.patch b/app-portage/gentoolkit/files/0.3.0.8-revdep-rebuild-476740.patch
new file mode 100644
index 000000000000..8832838bd33f
--- /dev/null
+++ b/app-portage/gentoolkit/files/0.3.0.8-revdep-rebuild-476740.patch
@@ -0,0 +1,33 @@
+From 87a01450ab33220f6f0821d4f4209004cdc3aa8b Mon Sep 17 00:00:00 2001
+From: Paul Varner <fuzzyray@gentoo.org>
+Date: Tue, 10 Sep 2013 13:52:28 -0500
+Subject: [PATCH] Fix Ctrl-C handling when running emerge (Bug 476740).
+
+---
+ bin/revdep-rebuild.sh | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/bin/revdep-rebuild.sh b/bin/revdep-rebuild.sh
+index 6cb5608..09f5135 100755
+--- a/bin/revdep-rebuild.sh
++++ b/bin/revdep-rebuild.sh
+@@ -1052,6 +1052,7 @@ portage_settings() {
+ if [[ -n ${REVDEP_REBUILD_DEFAULT_OPTS} ]]; then
+ EMERGE_DEFAULT_OPTS=("${REVDEP_REBUILD_DEFAULT_OPTS[@]}")
+ fi
++
+ }
+
+ ##
+@@ -1138,7 +1139,7 @@ rebuild() {
+ REBUILD_LIST=$(sort -u "$EBUILDS_FILE")
+ fi
+
+- trap - SIGHUP SIGINT SIGQUIT SIGABRT SIGTERM
++ trap "kill 0" SIGHUP SIGINT SIGQUIT SIGABRT SIGTERM
+
+ [[ $QUIET -ne 1 ]] && einfo 'All prepared. Starting rebuild'
+ echo "emerge --complete-graph=y --oneshot ${EMERGE_DEFAULT_OPTS[@]} ${EMERGE_OPTIONS[@]} $REBUILD_LIST"
+--
+1.8.3.2
+
diff --git a/app-portage/gentoolkit/files/0.3.0.8-revdep-rebuild-484340.patch b/app-portage/gentoolkit/files/0.3.0.8-revdep-rebuild-484340.patch
new file mode 100644
index 000000000000..1a0393dac48d
--- /dev/null
+++ b/app-portage/gentoolkit/files/0.3.0.8-revdep-rebuild-484340.patch
@@ -0,0 +1,46 @@
+From db997501ec8e0ef0c5e4426649c17d2498b40e06 Mon Sep 17 00:00:00 2001
+From: Paul Varner <fuzzyray@gentoo.org>
+Date: Tue, 10 Sep 2013 10:59:31 -0500
+Subject: [PATCH] Fix use of REVDEP_REBUILD_DEFAULT_OPTS (Bug 484340).
+
+---
+ bin/revdep-rebuild.sh | 7 ++-----
+ 1 file changed, 2 insertions(+), 5 deletions(-)
+
+diff --git a/bin/revdep-rebuild.sh b/bin/revdep-rebuild.sh
+index 7f848bc..6cb5608 100755
+--- a/bin/revdep-rebuild.sh
++++ b/bin/revdep-rebuild.sh
+@@ -1034,27 +1034,24 @@ portage_settings() {
+ local ORIG_SEARCH_DIRS="$SEARCH_DIRS"
+ local ORIG_SEARCH_DIRS_MASK="$SEARCH_DIRS_MASK"
+ local ORIG_LD_LIBRARY_MASK="$LD_LIBRARY_MASK"
+- local ORIG_REVDEP_REBUILD_DEFAULT_OPTS="$REVDEP_REBUILD_DEFAULT_OPTS"
+ unset SEARCH_DIRS
+ unset SEARCH_DIRS_MASK
+ unset LD_LIBRARY_MASK
+- unset REVDEP_REBUILD_DEFAULT_OPTS
+
+ eval $(portageq envvar -v PORTAGE_ROOT PORTAGE_NICENESS EMERGE_DEFAULT_OPTS NOCOLOR SEARCH_DIRS SEARCH_DIRS_MASK LD_LIBRARY_MASK REVDEP_REBUILD_DEFAULT_OPTS)
+ export NOCOLOR
+
+ # Convert quoted paths to array.
+ eval "EMERGE_DEFAULT_OPTS=(${EMERGE_DEFAULT_OPTS})"
++ eval "REVDEP_REBUILD_DEFAULT_OPTS=(${REVDEP_REBUILD_DEFAULT_OPTS})"
+ SEARCH_DIRS="$ORIG_SEARCH_DIRS $SEARCH_DIRS"
+ SEARCH_DIRS_MASK="$ORIG_SEARCH_DIRS_MASK $SEARCH_DIRS_MASK"
+ LD_LIBRARY_MASK="$ORIG_LD_LIBRARY_MASK $LD_LIBRARY_MASK"
+- REVDEP_REBUILD_DEFAULT_OPTS="$ORIG_REVDEP_REBUILD_DEFAULT_OPTS $REVDEP_REBUILD_DEFAULT_OPTS"
+
+ # Replace EMERGE_DEFAULT_OPTS with REVDEP_REBUILD_DEFAULT_OPTS (if it exists)
+ if [[ -n ${REVDEP_REBUILD_DEFAULT_OPTS} ]]; then
+- EMERGE_DEFAULT_OPTS=("$REVDEP_REBUILD_DEFAULT_OPTS")
++ EMERGE_DEFAULT_OPTS=("${REVDEP_REBUILD_DEFAULT_OPTS[@]}")
+ fi
+-
+ }
+
+ ##
+--
+1.8.3.2
+
diff --git a/app-portage/gentoolkit/gentoolkit-0.3.0.8-r1.ebuild b/app-portage/gentoolkit/gentoolkit-0.3.0.8-r1.ebuild
new file mode 100644
index 000000000000..957c7358e6fd
--- /dev/null
+++ b/app-portage/gentoolkit/gentoolkit-0.3.0.8-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/gentoolkit-0.3.0.8-r1.ebuild,v 1.1 2013/09/10 19:25:33 fuzzyray Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_6,2_7,3_2,3_3} pypy2_0)
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/tools/index.xml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="sys-apps/portage"
+RDEPEND="${DEPEND}
+ !<=app-portage/gentoolkit-dev-0.2.7
+ || ( >=sys-apps/coreutils-8.15 app-misc/realpath sys-freebsd/freebsd-bin )
+ sys-apps/gawk
+ sys-apps/grep
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-revdep-rebuild-484340.patch
+ "${FILESDIR}"/${PV}-revdep-rebuild-476740.patch
+)
+
+python_prepare_all() {
+ python_export_best
+ echo VERSION="${PVR}" "${PYTHON}" setup.py set_version
+ VERSION="${PVR}" "${PYTHON}" setup.py set_version
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # Rename the python versions of revdep-rebuild, since we are not ready
+ # to switch to the python version yet. Link /usr/bin/revdep-rebuild to
+ # revdep-rebuild.sh. Leaving the python version available for potential
+ # testing by a wider audience.
+ mv "${ED}"/usr/bin/revdep-rebuild "${ED}"/usr/bin/revdep-rebuild.py
+ dosym revdep-rebuild.sh /usr/bin/revdep-rebuild
+
+ # Create cache directory for revdep-rebuild
+ keepdir /var/cache/revdep-rebuild
+ use prefix || fowners root:root /var/cache/revdep-rebuild
+ fperms 0700 /var/cache/revdep-rebuild
+
+ # remove on Gentoo Prefix platforms where it's broken anyway
+ if use prefix; then
+ elog "The revdep-rebuild command is removed, the preserve-libs"
+ elog "feature of portage will handle issues."
+ rm "${ED}"/usr/bin/revdep-rebuild*
+ rm "${ED}"/usr/share/man/man1/revdep-rebuild.1
+ rm -rf "${ED}"/etc/revdep-rebuild
+ rm -rf "${ED}"/var
+ fi
+}
+
+pkg_postinst() {
+ # Only show the elog information on a new install
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "For further information on gentoolkit, please read the gentoolkit"
+ elog "guide: http://www.gentoo.org/doc/en/gentoolkit.xml"
+ elog
+ elog "Another alternative to equery is app-portage/portage-utils"
+ elog
+ elog "Additional tools that may be of interest:"
+ elog
+ elog " app-admin/eclean-kernel"
+ elog " app-portage/diffmask"
+ elog " app-portage/flaggie"
+ elog " app-portage/install-mask"
+ elog " app-portage/portpeek"
+ elog " app-portage/smart-live-rebuild"
+ fi
+}