summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2011-04-11 01:59:32 +0000
committerPaul Varner <fuzzyray@gentoo.org>2011-04-11 01:59:32 +0000
commit9091376374eb7f530b0f146955eb38ddcd290ce9 (patch)
tree34c3f0bebc5888169d150f49cf9a062071aecdd8 /app-portage
parentOfficially remove the old (bug #312089). (diff)
downloadgentoo-2-9091376374eb7f530b0f146955eb38ddcd290ce9.tar.gz
gentoo-2-9091376374eb7f530b0f146955eb38ddcd290ce9.tar.bz2
gentoo-2-9091376374eb7f530b0f146955eb38ddcd290ce9.zip
Version bump to 0.3.0, please take a look at bug 237964 for more information
about the changes in this release. Thanks to all contributors! (Portage version: 2.1.9.45/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoolkit/ChangeLog8
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.3.0.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/app-portage/gentoolkit/ChangeLog b/app-portage/gentoolkit/ChangeLog
index 3b69671711b0..633eee62ba7e 100644
--- a/app-portage/gentoolkit/ChangeLog
+++ b/app-portage/gentoolkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/gentoolkit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.209 2011/04/06 16:04:01 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.210 2011/04/11 01:59:32 fuzzyray Exp $
+
+*gentoolkit-0.3.0 (11 Apr 2011)
+
+ 11 Apr 2011; Paul Varner <fuzzyray@gentoo.org> +gentoolkit-0.3.0.ebuild:
+ Version bump to 0.3.0, please take a look at bug 237964 for more information
+ about the changes in this release. Thanks to all contributors!
06 Apr 2011; Jeremy Olexa <darkside@gentoo.org>
gentoolkit-0.3.0_rc11-r3.ebuild, gentoolkit-9999.ebuild:
diff --git a/app-portage/gentoolkit/gentoolkit-0.3.0.ebuild b/app-portage/gentoolkit/gentoolkit-0.3.0.ebuild
new file mode 100644
index 000000000000..e3f4a84c14f4
--- /dev/null
+++ b/app-portage/gentoolkit/gentoolkit-0.3.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/gentoolkit-0.3.0.ebuild,v 1.1 2011/04/11 01:59:32 fuzzyray Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45]"
+PYTHON_USE_WITH="xml"
+PYTHON_NONVERSIONED_EXECUTABLES=(".*")
+
+inherit distutils python eutils
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/tools/index.xml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# Drop "~m68k ~s390 ~sh ~sparc-fbsd ~x86-fbsd" due to dev-python/argparse dependency
+# Note: argparse is provided in python 2.7 and 3.2 (Bug 346005)
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x64-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="sys-apps/portage"
+RDEPEND="${DEPEND}
+ !<=app-portage/gentoolkit-dev-0.2.7
+ dev-python/argparse
+ || ( app-misc/realpath sys-freebsd/freebsd-bin )
+ sys-apps/gawk
+ sys-apps/grep"
+
+distutils_src_compile_pre_hook() {
+ echo VERSION="${PVR}" "$(PYTHON)" setup.py set_version
+ VERSION="${PVR}" "$(PYTHON)" setup.py set_version \
+ || die "setup.py set_version failed"
+}
+
+src_install() {
+ python_convert_shebangs -r "" build-*/scripts-*
+ distutils_src_install
+
+ # Create cache directory for revdep-rebuild
+ dodir /var/cache/revdep-rebuild
+ keepdir /var/cache/revdep-rebuild
+ use prefix || fowners root:root /var/cache/revdep-rebuild
+ fperms 0700 /var/cache/revdep-rebuild
+
+ # remove on Gentoo Prefix platforms where it's broken anyway
+ if use prefix; then
+ elog "The revdep-rebuild command is removed, the preserve-libs"
+ elog "feature of portage will handle issues."
+ rm "${ED}"/usr/bin/revdep-rebuild
+ rm "${ED}"/usr/share/man/man1/revdep-rebuild.1
+ rm -rf "${ED}"/etc/revdep-rebuild
+ rm -rf "${ED}"/var
+ fi
+
+ # Can distutils handle this?
+ dosym eclean /usr/bin/eclean-dist
+ dosym eclean /usr/bin/eclean-pkg
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ einfo
+ einfo "For further information on gentoolkit, please read the gentoolkit"
+ einfo "guide: http://www.gentoo.org/doc/en/gentoolkit.xml"
+ einfo
+ einfo "Another alternative to equery is app-portage/portage-utils"
+}