summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-11-22 05:44:27 +0000
committerMarius Mauch <genone@gentoo.org>2004-11-22 05:44:27 +0000
commita7a548505a9adc8ae175f9d92ac8ed34609de537 (patch)
tree272a9fddd382f0e203be2eb03ba8f9e1df606460 /app-portage
parentbug #72010. (Manifest recommit) (diff)
downloadgentoo-2-a7a548505a9adc8ae175f9d92ac8ed34609de537.tar.gz
gentoo-2-a7a548505a9adc8ae175f9d92ac8ed34609de537.tar.bz2
gentoo-2-a7a548505a9adc8ae175f9d92ac8ed34609de537.zip
another patch injection for ufed
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/ufed/ChangeLog15
-rw-r--r--app-portage/ufed/files/digest-ufed-0.35-r21
-rw-r--r--app-portage/ufed/files/disabled-defaults.patch13
-rw-r--r--app-portage/ufed/files/no-partial-match.patch11
-rw-r--r--app-portage/ufed/files/quote-escape.patch18
-rw-r--r--app-portage/ufed/files/too-many-flags.patch23
-rw-r--r--app-portage/ufed/ufed-0.35-r2.ebuild30
7 files changed, 110 insertions, 1 deletions
diff --git a/app-portage/ufed/ChangeLog b/app-portage/ufed/ChangeLog
index 5f2c3fc0d50e..9bb08c386b99 100644
--- a/app-portage/ufed/ChangeLog
+++ b/app-portage/ufed/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for app-portage/ufed
# Copyright 2003-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ChangeLog,v 1.8 2004/10/06 16:21:56 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ChangeLog,v 1.9 2004/11/22 05:44:27 genone Exp $
+
+*ufed-0.35-r2 (22 Nov 2004)
+
+ 22 Nov 2004; Marius Mauch <genone@gentoo.org>
+ +files/disabled-defaults.patch, +files/no-partial-match.patch,
+ +files/quote-escape.patch, +files/too-many-flags.patch,
+ +ufed-0.35-r2.ebuild:
+ new revision featuring patches for bugs #59004, #68691, #68924 and #70776.
+ Thanks to fn_x@hotmail.com for providing those. Also made the dialog
+ dep more strict.Ideally this should be bumped straight to stable as some of
+ these bugs prevent ufed from working at all, but the new dialog dep isn't yet
+ stable on all archs. ufed-0.35 will probably be the last version of the perl
+ version, it will likely be replaced by a python version soon.
*ufed-0.35-r1 (06 Oct 2004)
diff --git a/app-portage/ufed/files/digest-ufed-0.35-r2 b/app-portage/ufed/files/digest-ufed-0.35-r2
new file mode 100644
index 000000000000..3379e589a5e8
--- /dev/null
+++ b/app-portage/ufed/files/digest-ufed-0.35-r2
@@ -0,0 +1 @@
+MD5 1c652f530e0112e733730a5fa7967847 ufed-0.35.tar.bz2 15126
diff --git a/app-portage/ufed/files/disabled-defaults.patch b/app-portage/ufed/files/disabled-defaults.patch
new file mode 100644
index 000000000000..8d7edc0bd5dc
--- /dev/null
+++ b/app-portage/ufed/files/disabled-defaults.patch
@@ -0,0 +1,13 @@
+--- ufed-0.35.orig/ufed.pl
++++ ufed-0.35/ufed.pl
+@@ -672,7 +672,8 @@
+ #$All = "Make.def : " . join(' ', @make_defaults_flags) . "\n";
+
+ #Step 2)
+- $Results = resolve_flags(join (' ', @make_defaults_flags),
+- join (' ', @use_defaults_flags));
++ $Results = resolve_flags(resolve_flags('',
++ join (' ', @make_defaults_flags)),
++ join (' ', @use_defaults_flags));
+
+ #$All .= "Use.def : " . join(' ', @use_defaults_flags) . "\n";
diff --git a/app-portage/ufed/files/no-partial-match.patch b/app-portage/ufed/files/no-partial-match.patch
new file mode 100644
index 000000000000..d46718af0abd
--- /dev/null
+++ b/app-portage/ufed/files/no-partial-match.patch
@@ -0,0 +1,11 @@
+--- ufed-0.35.orig/ufed.pl
++++ ufed-0.35/ufed.pl
+@@ -753,7 +753,7 @@
+ for $i (@use_mask_flags)
+ {
+ next if($i eq "");
+- $final_list =~ s!-?$i!!g;
++ $final_list =~ s!-?\b$i\b!!g;
+ #$All .= "$i ";
+ }
+ #$All .= "\n";
diff --git a/app-portage/ufed/files/quote-escape.patch b/app-portage/ufed/files/quote-escape.patch
new file mode 100644
index 000000000000..92458f3bf274
--- /dev/null
+++ b/app-portage/ufed/files/quote-escape.patch
@@ -0,0 +1,18 @@
+--- ufed-0.35.orig/ufed.pl
++++ ufed-0.35/ufed.pl
+@@ -163,6 +163,7 @@
+ $line =~ s/[\r\n]//g;
+ ($flag, $desc) = ($line =~ m!([^ ]+)[ \t]+-[ \t]+(.*)!); # match the "flag - description" syntax
+ $desc =~ s/[ \t]+/ /;
++ $desc =~ s/[\\\$"]/\\$&/g;
+ $flag =~ s/[ \t]+//;
+
+ # now eliminate comments, blanklines and internal flags
+@@ -209,6 +210,7 @@
+ $line =~ s/[\r\n]//g;
+ ($package, $flag, $desc) = ($line =~ m!([^:]*):([^ ]+)[ \t]+-[ \t]+(.*)!); # match the "package:flag - description" syntax
+ $desc =~ s/[ \t]+/ /;
++ $desc =~ s/[\\\$"]/\\$&/g;
+ $flag =~ s/[ \t]+//;
+
+ # now eliminate comments, blanklines
diff --git a/app-portage/ufed/files/too-many-flags.patch b/app-portage/ufed/files/too-many-flags.patch
new file mode 100644
index 000000000000..7c9b2652e67c
--- /dev/null
+++ b/app-portage/ufed/files/too-many-flags.patch
@@ -0,0 +1,23 @@
+--- ufed-0.35.orig/ufed.pl
++++ ufed-0.35/ufed.pl
+@@ -294,8 +294,8 @@
+ # stderr output was not messing up the parsing of the results anymore.
+ # Thanks Brandon
+
+- $rc = system('exec 3> ' . $tempfile . ' ; DIALOG_ESC="" dialog '
+- . ' --output-fd 3'
++ my ($cmdfh, $cmdfile) = tempfile('dialog.XXXXXX', DIR => '/tmp', UNLINK => 1);
++ print $cmdfh ' --output-fd 3'
+ . ' --separate-output '
+ . '--no-shadow --backtitle "Gentoo Linux USE flags editor '
+ . $version . '" '
+@@ -305,7 +305,8 @@
+ . $lines . ' '
+ . $cols . ' '
+ . ($lines - 8) . ' '
+- . $items) >> 8;
++ . $items;
++ $rc = system('exec 3> ' . $tempfile . ' ; DIALOG_ESC="" dialog --file ' . $cmdfile) >> 8;
+ if ($rc == 1)
+ { return 'CANCEL'; }
+ if ($rc == 255)
diff --git a/app-portage/ufed/ufed-0.35-r2.ebuild b/app-portage/ufed/ufed-0.35-r2.ebuild
new file mode 100644
index 000000000000..7133844c7022
--- /dev/null
+++ b/app-portage/ufed/ufed-0.35-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ufed-0.35-r2.ebuild,v 1.1 2004/11/22 05:44:27 genone Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Linux USE flags editor"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc mips ~alpha ~arm ~hppa amd64 ~ia64 ~ppc64"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ >=dev-util/dialog-1.0.20040731
+ dev-perl/TermReadKey"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/*.patch
+}
+
+src_install() {
+ newsbin ufed.pl ufed || die
+ doman ufed.8
+ dodoc ChangeLog
+}