summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2011-08-11 20:06:16 +0000
committerPaul Varner <fuzzyray@gentoo.org>2011-08-11 20:06:16 +0000
commite78a50866d70e20b846dac26410b717fe9e3f43d (patch)
tree323cdcab5e042f995ce98f1e1de11f97f6515c07 /app-portage
parentFix underlinking, bug 369641 (diff)
downloadgentoo-2-e78a50866d70e20b846dac26410b717fe9e3f43d.tar.gz
gentoo-2-e78a50866d70e20b846dac26410b717fe9e3f43d.tar.bz2
gentoo-2-e78a50866d70e20b846dac26410b717fe9e3f43d.zip
Version Bump. Bug 375789 is the tracker bug for the 2.0.0 release.
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/layman/ChangeLog7
-rw-r--r--app-portage/layman/layman-2.0.0_rc2.ebuild89
2 files changed, 95 insertions, 1 deletions
diff --git a/app-portage/layman/ChangeLog b/app-portage/layman/ChangeLog
index dc65de3232f6..a77bfe63085b 100644
--- a/app-portage/layman/ChangeLog
+++ b/app-portage/layman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/layman
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.144 2011/08/08 16:28:35 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/ChangeLog,v 1.145 2011/08/11 20:06:16 fuzzyray Exp $
+
+*layman-2.0.0_rc2 (11 Aug 2011)
+
+ 11 Aug 2011; Paul Varner <fuzzyray@gentoo.org> +layman-2.0.0_rc2.ebuild:
+ Version Bump. Bug 375789 is the tracker bug for the 2.0.0 release.
08 Aug 2011; Jeremy Olexa <darkside@gentoo.org> layman-2.0.0_rc1-r1.ebuild:
add ~amd64-linux kw as well
diff --git a/app-portage/layman/layman-2.0.0_rc2.ebuild b/app-portage/layman/layman-2.0.0_rc2.ebuild
new file mode 100644
index 000000000000..683bbb67a7e1
--- /dev/null
+++ b/app-portage/layman/layman-2.0.0_rc2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/layman/layman-2.0.0_rc2.ebuild,v 1.1 2011/08/11 20:06:16 fuzzyray Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2:2.6"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit eutils distutils prefix
+
+DESCRIPTION="Tool to manage Gentoo overlays"
+HOMEPAGE="http://layman.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bazaar cvs darcs git mercurial subversion test"
+
+COMMON_DEPS="dev-lang/python[xml]"
+DEPEND="${COMMON_DEPS}
+ test? ( dev-vcs/subversion )"
+RDEPEND="${COMMON_DEPS}
+ bazaar? ( dev-vcs/bzr )
+ cvs? ( dev-vcs/cvs )
+ darcs? ( dev-vcs/darcs )
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? (
+ || (
+ >=dev-vcs/subversion-1.5.4[webdav-neon]
+ >=dev-vcs/subversion-1.5.4[webdav-serf]
+ )
+ )"
+
+src_prepare() {
+ eprefixify etc/layman.cfg layman/config.py
+}
+
+src_test() {
+ testing() {
+ for suite in layman/tests/{dtest,external}.py ; do
+ PYTHONPATH="." "$(PYTHON)" ${suite} \
+ || die "test suite '${suite}' failed"
+ done
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /etc/layman
+ doins etc/layman.cfg || die
+
+ doman doc/layman.8
+ dohtml doc/layman.8.html
+
+ keepdir /var/lib/layman
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ einfo "You are now ready to add overlays into your system."
+ einfo
+ einfo " layman -L"
+ einfo
+ einfo "will display a list of available overlays."
+ einfo
+ elog "Select an overlay and add it using"
+ elog
+ elog " layman -a overlay-name"
+ elog
+ elog "If this is the very first overlay you add with layman,"
+ elog "you need to append the following statement to your"
+ elog "/etc/make.conf file:"
+ elog
+ elog " source /var/lib/layman/make.conf"
+ elog
+ elog "If you modify the 'storage' parameter in the layman"
+ elog "configuration file (/etc/layman/layman.cfg) you will"
+ elog "need to adapt the path given above to the new storage"
+ elog "directory."
+ elog
+ ewarn "Please add the 'source' statement to make.conf only AFTER "
+ ewarn "you added your first overlay. Otherwise portage will fail."
+}