summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2015-01-27 20:32:50 +0000
committerBrian Dolbec <dolsen@gentoo.org>2015-01-27 20:32:50 +0000
commiteb9ff13cb137d9970792c4fc1769969bf7f3f7f4 (patch)
treea764152224f456148c28a353751cdbe1a5377fa9 /app-portage
parentReset to the last stable state (diff)
downloadgentoo-2-eb9ff13cb137d9970792c4fc1769969bf7f3f7f4.tar.gz
gentoo-2-eb9ff13cb137d9970792c4fc1769969bf7f3f7f4.tar.bz2
gentoo-2-eb9ff13cb137d9970792c4fc1769969bf7f3f7f4.zip
Bump for an additional patch
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x65E309F2189DB0B8)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/mirrorselect/ChangeLog9
-rw-r--r--app-portage/mirrorselect/files/mirrorselect-2.2.2-Add-outputmodefunctionassignment.patch24
-rw-r--r--app-portage/mirrorselect/mirrorselect-2.2.2-r2.ebuild (renamed from app-portage/mirrorselect/mirrorselect-2.2.2-r1.ebuild)7
3 files changed, 37 insertions, 3 deletions
diff --git a/app-portage/mirrorselect/ChangeLog b/app-portage/mirrorselect/ChangeLog
index 9a76090e7b66..f002d45fddbb 100644
--- a/app-portage/mirrorselect/ChangeLog
+++ b/app-portage/mirrorselect/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/mirrorselect
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/ChangeLog,v 1.150 2015/01/27 04:24:32 dolsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/ChangeLog,v 1.151 2015/01/27 20:32:50 dolsen Exp $
+
+*mirrorselect-2.2.2-r2 (27 Jan 2015)
+
+ 27 Jan 2015; Brian Dolbec <dolsen@gentoo.org> -mirrorselect-2.2.2-r1.ebuild,
+ +mirrorselect-2.2.2-r2.ebuild,
+ +files/mirrorselect-2.2.2-Add-outputmodefunctionassignment.patch:
+ Bump adding missed output assignment patch.
27 Jan 2015; Brian Dolbec <dolsen@gentoo.org> mirrorselect-2.2.2.ebuild,
+mirrorselect-2.2.2-r1.ebuild,
diff --git a/app-portage/mirrorselect/files/mirrorselect-2.2.2-Add-outputmodefunctionassignment.patch b/app-portage/mirrorselect/files/mirrorselect-2.2.2-Add-outputmodefunctionassignment.patch
new file mode 100644
index 000000000000..d170103a4657
--- /dev/null
+++ b/app-portage/mirrorselect/files/mirrorselect-2.2.2-Add-outputmodefunctionassignment.patch
@@ -0,0 +1,24 @@
+From e9dea3a98aa5031fecf1c7115de77e948e8d07ca Mon Sep 17 00:00:00 2001
+From: Brian Dolbec <dolsen@gentoo.org>
+Date: Tue, 27 Jan 2015 10:19:05 -0800
+Subject: [PATCH] Add missed output mode function assignment.
+
+---
+ mirrorselect/extractor.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/mirrorselect/extractor.py b/mirrorselect/extractor.py
+index 59efad1..06dce6c 100644
+--- a/mirrorselect/extractor.py
++++ b/mirrorselect/extractor.py
+@@ -107,6 +107,7 @@ class Extractor(object):
+ # setup the ssl-fetch ouptut map
+ connector_output = {
+ 'info':self.output.write,
++ 'debug': self.output.write,
+ 'error': self.output.print_err,
+ 'kwargs-info': {'level': 2},
+ 'kwargs-debug': {'level':2},
+--
+2.2.2
+
diff --git a/app-portage/mirrorselect/mirrorselect-2.2.2-r1.ebuild b/app-portage/mirrorselect/mirrorselect-2.2.2-r2.ebuild
index 8b6e3cc44d73..5114e0b1af60 100644
--- a/app-portage/mirrorselect/mirrorselect-2.2.2-r1.ebuild
+++ b/app-portage/mirrorselect/mirrorselect-2.2.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/mirrorselect-2.2.2-r1.ebuild,v 1.1 2015/01/27 04:24:32 dolsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/mirrorselect/mirrorselect-2.2.2-r2.ebuild,v 1.1 2015/01/27 20:32:50 dolsen Exp $
EAPI="5"
@@ -27,7 +27,10 @@ RDEPEND="
>=dev-python/ssl-fetch-0.3[${PYTHON_USEDEP}]
"
-PATCHES=( "${FILESDIR}/mirrorselect-2.2.2-Update-for-ssl-fetch-api-change.patch" )
+PATCHES=(
+ "${FILESDIR}/mirrorselect-2.2.2-Update-for-ssl-fetch-api-change.patch"
+ "${FILESDIR}/mirrorselect-2.2.2-Add-outputmodefunctionassignment.patch"
+)
python_prepare_all() {
python_setup