summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2006-04-24 00:06:32 +0000
committerAlec Warner <antarus@gentoo.org>2006-04-24 00:06:32 +0000
commitf8a9d350a9b0aab979eff7ec1ad17d15472bd32f (patch)
tree04d7b8f3693b003cc2f87c6a19ee946545010f34 /app-portage
parentStable on alpha wrt security bug #130623. (diff)
downloadgentoo-2-f8a9d350a9b0aab979eff7ec1ad17d15472bd32f.tar.gz
gentoo-2-f8a9d350a9b0aab979eff7ec1ad17d15472bd32f.tar.bz2
gentoo-2-f8a9d350a9b0aab979eff7ec1ad17d15472bd32f.zip
Fixed commit straight to stable, add a patch to fix missing ebuilds.
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/esearch/ChangeLog12
-rw-r--r--app-portage/esearch/esearch-0.7.1-r2.ebuild51
-rw-r--r--app-portage/esearch/files/97969-ignore-missing-ebuilds.patch15
-rw-r--r--app-portage/esearch/files/digest-esearch-0.7.1-r23
4 files changed, 79 insertions, 2 deletions
diff --git a/app-portage/esearch/ChangeLog b/app-portage/esearch/ChangeLog
index 6c9ed91ceb3f..518ac0da2021 100644
--- a/app-portage/esearch/ChangeLog
+++ b/app-portage/esearch/ChangeLog
@@ -1,10 +1,18 @@
# ChangeLog for app-portage/esearch
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/ChangeLog,v 1.44 2006/04/23 23:16:18 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/ChangeLog,v 1.45 2006/04/24 00:06:32 antarus Exp $
+
+*esearch-0.7.1-r2 (24 Apr 2006)
+
+ 24 Apr 2006; Alec Warner <antarus@gentoo.org>
+ +files/97969-ignore-missing-ebuilds.patch, -esearch-0.7.1-r1.ebuild,
+ +esearch-0.7.1-r2.ebuild:
+ Fixed commit straight to stable, add a patch to fix missing ebuilds.
+ Fix Changelog.
*esearch-0.7.1-r1 (23 Apr 2006)
- 23 Apr 2006; <skyfw@gentoo.org> +files/97462-esearch-metadata.patch,
+ 23 Apr 2006; Alec Warner <antarus@gentoo.org> +files/97462-esearch-metadata.patch,
+esearch-0.7.1-r1.ebuild:
Fix bug 97462, thanks to Jer@gentoo.org for the most excellent patch
diff --git a/app-portage/esearch/esearch-0.7.1-r2.ebuild b/app-portage/esearch/esearch-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..0e58028e8fc5
--- /dev/null
+++ b/app-portage/esearch/esearch-0.7.1-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/esearch/esearch-0.7.1-r2.ebuild,v 1.1 2006/04/24 00:06:32 antarus Exp $
+
+inherit eutils
+
+DESCRIPTION="Replacement for 'emerge --search' with search-index"
+HOMEPAGE="http://david-peter.de/esearch.html"
+SRC_URI="http://david-peter.de/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.2
+ >=sys-apps/portage-2.0.50"
+
+pkg_setup() {
+ if ! built_with_use dev-lang/python readline ; then
+ eerror "Python has to be build with 'readline' support!"
+ eerror "To do so: USE=\"readline\" emerge python"
+ eerror "Or, add \"readline\" to your USE string in"
+ eerror "/etc/make.conf"
+ die "Works only with python readline support"
+ fi
+}
+
+src_compile() {
+ epatch ${FILESDIR}/97462-esearch-metadata.patch || die "Failed to patch sources!"
+ epatch ${FILESDIR}/97969-ignore-missing-ebuilds.patch || die "Failed to patch sources!"
+}
+
+src_install() {
+ dodir /usr/bin/ /usr/sbin/
+
+ exeinto /usr/lib/esearch
+ doexe eupdatedb.py esearch.py esync.py common.py || die "doexe failed"
+
+ dosym /usr/lib/esearch/esearch.py /usr/bin/esearch
+ dosym /usr/lib/esearch/eupdatedb.py /usr/sbin/eupdatedb
+ dosym /usr/lib/esearch/esync.py /usr/sbin/esync
+
+ doman en/{esearch,eupdatedb,esync}.1
+ dodoc ChangeLog "${FILESDIR}/eupdatedb.cron"
+
+ if use linguas_it ; then
+ insinto /usr/share/man/it/man1
+ doins it/{esearch,eupdatedb,esync}.1
+ fi
+}
diff --git a/app-portage/esearch/files/97969-ignore-missing-ebuilds.patch b/app-portage/esearch/files/97969-ignore-missing-ebuilds.patch
new file mode 100644
index 000000000000..b2b31d29503d
--- /dev/null
+++ b/app-portage/esearch/files/97969-ignore-missing-ebuilds.patch
@@ -0,0 +1,15 @@
+--- /home/skyfw/gentoo/esearch.py 2006-04-23 19:48:38.088214000 -0400
++++ /home/skyfw/gentoo/esearch.new 2006-04-23 19:33:21.482929750 -0400
+@@ -222,7 +222,11 @@
+
+ if outputm == VERBOSE:
+ mpv = best(portdb.xmatch("match-all", pkg[1]))
+- iuse_split = string.split(portdb.aux_get(pkg[1] + "-" + pkg[3], ["IUSE"])[0], " ")
++ try:
++ iuse_split = string.split(portdb.aux_get(pkg[1] + "-" + pkg[3], ["IUSE"])[0], " ")
++ except KeyError, e:
++ print "Package %s is no longer in the portage tree." % pkg[1] + "-" + pkg[3]
++ continue
+ iuse_split.sort()
+ iuse = ""
+
diff --git a/app-portage/esearch/files/digest-esearch-0.7.1-r2 b/app-portage/esearch/files/digest-esearch-0.7.1-r2
new file mode 100644
index 000000000000..c90d746a1865
--- /dev/null
+++ b/app-portage/esearch/files/digest-esearch-0.7.1-r2
@@ -0,0 +1,3 @@
+MD5 4eaf4182ef82c8bc3550d2fedb946e3e esearch-0.7.1.tar.bz2 10401
+RMD160 40e765fdac44c8c11fafdf8e8cc0e3ad20ac675c esearch-0.7.1.tar.bz2 10401
+SHA256 3f8e23a3a0748747ceff562063caccae1c50b46c723add32165c9476e57a270d esearch-0.7.1.tar.bz2 10401