summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-04-19 15:23:16 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-04-19 15:23:16 +0000
commit353376a3e23ed7f8a6b15969fd4033b80ae35760 (patch)
treed86cc6f680781b0e504cdb9d3b9e12d75cc54959 /app-sci/electric
parentRemoved sh, text, file utils and added coreutils to packages.build (diff)
downloadgentoo-2-353376a3e23ed7f8a6b15969fd4033b80ae35760.tar.gz
gentoo-2-353376a3e23ed7f8a6b15969fd4033b80ae35760.tar.bz2
gentoo-2-353376a3e23ed7f8a6b15969fd4033b80ae35760.zip
Version bump and some changes that allow to chose between qt and motif GUI, see bug #22160 for details.
Diffstat (limited to 'app-sci/electric')
-rw-r--r--app-sci/electric/ChangeLog9
-rw-r--r--app-sci/electric/Manifest4
-rw-r--r--app-sci/electric/electric-6.08.ebuild37
-rw-r--r--app-sci/electric/files/6.08-fix-sandbox.patch23
-rw-r--r--app-sci/electric/files/6.08-qt.patch35
-rw-r--r--app-sci/electric/files/digest-electric-6.081
6 files changed, 108 insertions, 1 deletions
diff --git a/app-sci/electric/ChangeLog b/app-sci/electric/ChangeLog
index 5e557aee1895..408d7329c37a 100644
--- a/app-sci/electric/ChangeLog
+++ b/app-sci/electric/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-sci/electric
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/electric/ChangeLog,v 1.5 2004/04/05 14:04:34 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/electric/ChangeLog,v 1.6 2004/04/19 15:23:16 phosphan Exp $
+
+*electric-6.08 (19 Apr 2004)
+
+ 19 Apr 2004; Patrick Kursawe <phosphan@gentoo.org> electric-6.08.ebuild,
+ files/6.08-fix-sandbox.patch, files/6.08-qt.patch:
+ Version bump and some changes that allow to chose between qt and motif GUI,
+ see bug #22160 for details.
*electric-6.07-r1 (05 Apr 2004)
diff --git a/app-sci/electric/Manifest b/app-sci/electric/Manifest
index 5b1a238e7689..2c6d6ba94680 100644
--- a/app-sci/electric/Manifest
+++ b/app-sci/electric/Manifest
@@ -1,6 +1,10 @@
MD5 a1daa1dcdce4c1f9079e51d352229ed5 electric-6.07-r1.ebuild 778
+MD5 d1e533866aad24ba84469a4b5f392396 electric-6.08.ebuild 948
MD5 cc4b06fbe1d8bae762b90b7897d909e7 ChangeLog 969
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 c56b6fd870a5bd605746803e6c76ea3c electric-6.07.ebuild 715
MD5 360605382817275ccc10068be4fe9da6 files/digest-electric-6.07 66
+MD5 08ac6be372fdf34293ebc04a592c6063 files/digest-electric-6.08 66
+MD5 31522760b841deb101bacf8521455e79 files/6.08-fix-sandbox.patch 962
MD5 360605382817275ccc10068be4fe9da6 files/digest-electric-6.07-r1 66
+MD5 aaf0ac9ca614a144e057e71e2056dace files/6.08-qt.patch 1373
diff --git a/app-sci/electric/electric-6.08.ebuild b/app-sci/electric/electric-6.08.ebuild
new file mode 100644
index 000000000000..daa8671a03c4
--- /dev/null
+++ b/app-sci/electric/electric-6.08.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/electric/electric-6.08.ebuild,v 1.1 2004/04/19 15:23:16 phosphan Exp $
+
+inherit eutils
+
+IUSE="qt"
+
+DESCRIPTION="Electric is a sophisticated electrical CAD system that can handle many forms of circuit design"
+HOMEPAGE="http://www.gnu.org/software/electric/electric.html"
+SRC_URI="http://ftp.gnu.org/pub/gnu/electric/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="virtual/glibc
+ !qt? ( x11-libs/openmotif )
+ qt? ( >=x11-libs/qt-3.1 )"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/${PV}-fix-sandbox.patch
+ use qt && epatch ${FILESDIR}/${PV}-qt.patch
+}
+
+src_compile() {
+ econf || die "./configure failed"
+ sed -e 's:/usr/local/:/usr/:g' -i src/include/config.h
+ emake || die
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+
+ dodoc ChangeLog COPYING README
+}
diff --git a/app-sci/electric/files/6.08-fix-sandbox.patch b/app-sci/electric/files/6.08-fix-sandbox.patch
new file mode 100644
index 000000000000..d22aee6b1c1d
--- /dev/null
+++ b/app-sci/electric/files/6.08-fix-sandbox.patch
@@ -0,0 +1,23 @@
+--- Makefile.in.oric 2004-03-15 10:31:14.000000000 +1030
++++ Makefile.in 2004-03-15 10:31:27.000000000 +1030
+@@ -932,15 +932,15 @@
+ rm -f src/vhdl/*~ src/vhdl/"#"*"#"
+
+ install: all
+- $(INSTALL) -d -m755 @bindir@ /usr/share/electric/lib
+- $(INSTALL) -m755 $(PROGNAME) @bindir@/$(PROGNAME)
+- $(INSTALL) -m644 lib/.cadrc /usr/share/electric/lib
++ $(INSTALL) -d -m755 ${DESTDIR}/@bindir@ ${DESTDIR}/@datadir@/electric/lib
++ $(INSTALL) -m755 $(PROGNAME) ${DESTDIR}/@bindir@/$(PROGNAME)
++ $(INSTALL) -m644 lib/.cadrc ${DESTDIR}/@datadir@/electric/lib
+ @(cd lib ; \
+ for d in `$(FIND) . -type d -print`; do \
+- $(INSTALL) -d -m755 /usr/share/electric/lib/$$d ; \
++ $(INSTALL) -d -m755 ${DESTDIR}/@datadir@/electric/lib/$$d ; \
+ (cd $$d ; \
+ for f in `$(FIND) . -type f -maxdepth 1 -print`; do \
+- install -m644 $$f /usr/share/electric/lib/$$d/$$f ; \
++ install -m644 $$f ${DESTDIR}/@datadir@/electric/lib/$$d/$$f ; \
+ done ) ; \
+ done ) ;
+
diff --git a/app-sci/electric/files/6.08-qt.patch b/app-sci/electric/files/6.08-qt.patch
new file mode 100644
index 000000000000..137f1e943642
--- /dev/null
+++ b/app-sci/electric/files/6.08-qt.patch
@@ -0,0 +1,35 @@
+--- Makefile.in.oric 2004-03-15 10:31:14.000000000 +1030
++++ Makefile.in 2004-03-15 10:39:14.000000000 +1030
+@@ -1,10 +1,10 @@
+ ########################################################## USING QT
+ ##### If using Qt, uncomment these five lines
+-# GRAPH_FLAGS = -DUSEQT -DQT_THREAD_SUPPORT -I$(QTDIR)/include $(QUI_CFLAGS)
+-# GRAPH_LIBS = -L$(QTDIR)/lib $(QUI_LIBS) $(QT_LIB_EXTRAS)
+-# GRAPH_OBJS = $(GRAPH_OBJS_QT)
+-# GRAPH_SRC = $(GRAPH_SRC_QT)
+-# CCOMPILER = @CXX@
++GRAPH_FLAGS = -DUSEQT -DQT_THREAD_SUPPORT -I$(QTDIR)/include $(QUI_CFLAGS)
++GRAPH_LIBS = -L$(QTDIR)/lib $(QUI_LIBS) $(QT_LIB_EXTRAS)
++GRAPH_OBJS = $(GRAPH_OBJS_QT)
++GRAPH_SRC = $(GRAPH_SRC_QT)
++CCOMPILER = @CXX@
+
+ ##### Qt on UNIX/Linux: uncomment the next two lines:
+ ELECTRIC_TARGET = electric-target-unix
+@@ -20,11 +20,11 @@
+
+ ########################################################### USING MOTIF
+ ##### If using Motif (or OpenMotif/Lesstif), uncomment these five lines
+-GRAPH_FLAGS = @X_CFLAGS@
+-GRAPH_LIBS = -lXm @XMULIB@ -lXt @XPLIB@ @XEXTLIB@ -lX11
+-GRAPH_OBJS = $(GRAPH_OBJS_XT)
+-GRAPH_SRC = $(GRAPH_SRC_XT)
+-CCOMPILER = @PTHREAD_CC@
++#GRAPH_FLAGS = @X_CFLAGS@
++#GRAPH_LIBS = -lXm @XMULIB@ -lXt @XPLIB@ @XEXTLIB@ -lX11
++#GRAPH_OBJS = $(GRAPH_OBJS_XT)
++#GRAPH_SRC = $(GRAPH_SRC_XT)
++#CCOMPILER = @PTHREAD_CC@
+
+ ##### For the general-purpose X facility, uncomment this line
+ XPOWER = -DANYDEPTH
diff --git a/app-sci/electric/files/digest-electric-6.08 b/app-sci/electric/files/digest-electric-6.08
new file mode 100644
index 000000000000..75dcd5f32194
--- /dev/null
+++ b/app-sci/electric/files/digest-electric-6.08
@@ -0,0 +1 @@
+MD5 de428032f08d3d3ee8686f178ae6b160 electric-6.08.tar.gz 4386249