summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-11-20 10:14:44 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-11-20 10:14:44 +0000
commitdccccf1f402c4fe975cfc00db92668781e705768 (patch)
tree995fea307329e60ab0837d774365eb8f75d91538 /app-sci/epix/epix-0.8.10a-r1.ebuild
parentInstalling documentation aswell (diff)
downloadgentoo-2-dccccf1f402c4fe975cfc00db92668781e705768.tar.gz
gentoo-2-dccccf1f402c4fe975cfc00db92668781e705768.tar.bz2
gentoo-2-dccccf1f402c4fe975cfc00db92668781e705768.zip
Installing documentation aswell
Diffstat (limited to 'app-sci/epix/epix-0.8.10a-r1.ebuild')
-rw-r--r--app-sci/epix/epix-0.8.10a-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-sci/epix/epix-0.8.10a-r1.ebuild b/app-sci/epix/epix-0.8.10a-r1.ebuild
new file mode 100644
index 000000000000..cc4552ee6093
--- /dev/null
+++ b/app-sci/epix/epix-0.8.10a-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/epix/epix-0.8.10a-r1.ebuild,v 1.1 2003/11/20 10:14:37 phosphan Exp $
+
+DESCRIPTION="2- and 3-D plotter for creating images (to be used in LaTeX)"
+HOMEPAGE="http://mathcs.holycross.edu/~ahwang/current/ePiX.html"
+
+SRC_URI="http://mathcs.holycross.edu/~ahwang/software/${P}_complete.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND="app-shells/bash
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${P/a/}
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Some sedding to get things installed in the proper places.
+
+ sed -i -e "s:\${EPIX_SHAREDIR}/epix:\${EPIX_SHAREDIR}/${P}:" \
+ helpfiles.sh
+
+ sed -i -e "s:man man/man1 share:share share/man share/man/man1:;\
+ s:share/epix:share/${P}:g" pre-install.sh
+ chmod a+x pre-install.sh
+
+ sed -i -e "s:^INSTALL_DIR.*:INSTALL_DIR=/usr:" prepix
+}
+
+src_compile() {
+ emake CXX="${CXX}" CFLAGS="-c ${CFLAGS}" shrdir=${D}/usr/share\
+ mandir=${D}/usr/share/man/man1 epix contrib || die
+ echo > README.gentoo -e "The full documentation is well hidden in the epix*howto.ps.gz-file in the tutorial subdirectory"
+}
+
+src_install() {
+ dodir /usr/man/man1
+ make "prefix=${D}/usr/" install || die
+ dodoc README.gentoo
+ cd ${D}/usr/share/${PN}-${PV}
+ dodoc notes/*
+ rm -rf notes
+ docinto tutorial
+ dodoc tutorial/*
+ docinto tutorial/contrib
+ dodoc tutorial/contrib/*
+ rm -rf tutorial
+}