summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-12-14 03:06:22 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-12-14 03:06:22 +0000
commit58c2521004372e90241f31da3de9c19c53a39fec (patch)
treeade447561f09a6b41f6530073b24b6ffe00d2d5a /app-sci/octave
parentchaged CHOST=sparc-unknown-linux-gnu (diff)
downloadgentoo-2-58c2521004372e90241f31da3de9c19c53a39fec.tar.gz
gentoo-2-58c2521004372e90241f31da3de9c19c53a39fec.tar.bz2
gentoo-2-58c2521004372e90241f31da3de9c19c53a39fec.zip
new version
Diffstat (limited to 'app-sci/octave')
-rw-r--r--app-sci/octave/ChangeLog9
-rw-r--r--app-sci/octave/files/digest-octave-2.1.401
-rw-r--r--app-sci/octave/octave-2.1.40.ebuild64
3 files changed, 72 insertions, 2 deletions
diff --git a/app-sci/octave/ChangeLog b/app-sci/octave/ChangeLog
index e14dc290e215..1c3e78ef7c3a 100644
--- a/app-sci/octave/ChangeLog
+++ b/app-sci/octave/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for app-sci/octave
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.8 2002/11/06 06:23:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.9 2002/12/14 03:06:22 george Exp $
+
+*octave-2.1.40 (13 Dec 2002)
+
+ 13 Dec 2002; George Shapovalov <george@gentoo.org> octave-2.1.40.ebuild, files/digest-octave-2.1.40 :
+ new version
*octave-2.0.17-r1 (13 Jul 2002)
- 25 Oct 2002 George Shapovalov <george@gentoo.org> octave-2.0.17-r1.ebuild, files/digest-octave-2.0.17-r1 ;
+ 25 Oct 2002; George Shapovalov <george@gentoo.org> octave-2.0.17-r1.ebuild, files/digest-octave-2.0.17-r1 :
fix for sandbox violation
*octave-2.1.36-r1 (01 Oct 02)
diff --git a/app-sci/octave/files/digest-octave-2.1.40 b/app-sci/octave/files/digest-octave-2.1.40
new file mode 100644
index 000000000000..7e1849b9acec
--- /dev/null
+++ b/app-sci/octave/files/digest-octave-2.1.40
@@ -0,0 +1 @@
+MD5 cec32442121559c3bdf3d9ff86e09071 octave-2.1.40.tar.bz2 3825982
diff --git a/app-sci/octave/octave-2.1.40.ebuild b/app-sci/octave/octave-2.1.40.ebuild
new file mode 100644
index 000000000000..be701b9d1871
--- /dev/null
+++ b/app-sci/octave/octave-2.1.40.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.40.ebuild,v 1.1 2002/12/14 03:06:22 george Exp $
+
+DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations"
+SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2"
+HOMEPAGE="http://www.octave.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+IUSE="tetex"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r3
+ >=media-gfx/gnuplot-3.7.1-r3
+ >=dev-libs/fftw-2.1.3
+ >=dev-util/gperf-2.7.2
+ tetex ? ( >=tetex-1.0.7-r10 ) "
+PROVIDE="dev-lang/octave"
+
+# NOTE: octave supports blas/lapack from intel but this is not open
+# source nor is it free (as in beer OR speech) Check out...
+# http://developer.intel.com/software/products/mkl/mkl52/index.htm for
+# more information
+
+src_compile() {
+ # NOTE: This version actually works with gcc-3.x
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/state/octave \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --build=${CHOST} \
+ --target=${CHOST} \
+ --enable-dl \
+ --enable-shared \
+ --enable-rpath \
+ --enable-lite-kernel || die "configure failed"
+
+ patch -p1 < ${FILESDIR}/kill-dvips.diff || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "make install failed"
+ use tetex && octave-install-doc
+}
+
+octave-install-doc() {
+ echo "Installing documentation..."
+ insinto /usr/share/doc/${PF}
+ doins doc/faq/Octave-FAQ.dvi
+ doins doc/interpreter/octave.dvi
+ doins doc/liboctave/liboctave.dvi
+ doins doc/refcard/refcard-a4.dvi
+ doins doc/refcard/refcard-legal.dvi
+ doins doc/refcard/refcard-letter.dvi
+}