summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2003-11-28 23:58:59 +0000
committerTim Yamin <plasmaroo@gentoo.org>2003-11-28 23:58:59 +0000
commite57833579a4fa7462c633b166e830b3a6d2d4d87 (patch)
tree055f7ea84a6cd8587c0dad88a791d9fbe88b93ce /app-sci/tclspice
parentadded amd64 per bug 34520 (diff)
downloadgentoo-2-e57833579a4fa7462c633b166e830b3a6d2d4d87.tar.gz
gentoo-2-e57833579a4fa7462c633b166e830b3a6d2d4d87.tar.bz2
gentoo-2-e57833579a4fa7462c633b166e830b3a6d2d4d87.zip
Added a readline patch; bug #34079
Diffstat (limited to 'app-sci/tclspice')
-rw-r--r--app-sci/tclspice/ChangeLog6
-rw-r--r--app-sci/tclspice/Manifest6
-rw-r--r--app-sci/tclspice/metadata.xml3
-rw-r--r--app-sci/tclspice/tclspice-0.2.14.ebuild20
4 files changed, 29 insertions, 6 deletions
diff --git a/app-sci/tclspice/ChangeLog b/app-sci/tclspice/ChangeLog
index b677a58200df..8ffc26053cc0 100644
--- a/app-sci/tclspice/ChangeLog
+++ b/app-sci/tclspice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/tclspice
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/tclspice/ChangeLog,v 1.2 2003/08/31 14:04:25 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tclspice/ChangeLog,v 1.3 2003/11/28 23:58:52 plasmaroo Exp $
+
+ 28 Nov 2003; <plasmaroo@gentoo.org> tclspice-0.2.14.ebuild:
+ Added a readline patch; thanks to Terry Porter <techman at d2.net.au> for
+ submitting the bug [#34079].
*tclspice-0.2.14 (31 Aug 2003)
diff --git a/app-sci/tclspice/Manifest b/app-sci/tclspice/Manifest
index 0e3913d8919b..83bd8d9f1079 100644
--- a/app-sci/tclspice/Manifest
+++ b/app-sci/tclspice/Manifest
@@ -1,4 +1,4 @@
-MD5 b9a6ef2330e819f08951fc674b137045 ChangeLog 431
-MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 5d5b21c0ad90e93f73ebebfed56af61d tclspice-0.2.14.ebuild 781
+MD5 27a54873f69e6a238210ecf583555a88 ChangeLog 604
+MD5 e49bb02132d2cd74ad4e6ee291e102d9 metadata.xml 220
+MD5 5c920bd3913ca74e622b3f1477c49f75 tclspice-0.2.14.ebuild 1067
MD5 d62f61b6201e2be65948c87c0aaa98fa files/digest-tclspice-0.2.14 68
diff --git a/app-sci/tclspice/metadata.xml b/app-sci/tclspice/metadata.xml
index b229aec85b8f..e2035cdbb121 100644
--- a/app-sci/tclspice/metadata.xml
+++ b/app-sci/tclspice/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
+<maintainer>
+ <email>plasmaroo@gentoo.org</email>
+</maintainer>
</pkgmetadata>
diff --git a/app-sci/tclspice/tclspice-0.2.14.ebuild b/app-sci/tclspice/tclspice-0.2.14.ebuild
index 65d7b32a288c..ff599a8f0f6e 100644
--- a/app-sci/tclspice/tclspice-0.2.14.ebuild
+++ b/app-sci/tclspice/tclspice-0.2.14.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/tclspice/tclspice-0.2.14.ebuild,v 1.2 2003/11/22 14:08:53 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tclspice/tclspice-0.2.14.ebuild,v 1.3 2003/11/28 23:58:53 plasmaroo Exp $
DESCRIPTION="Spice circuit simulator with TCL scipting language and GUI"
HOMEPAGE="http://tclspice.sf.net/"
-SRC_URI="mirror://sourceforge/tclspice/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/tclspice/${P}.tar.gz
+ readline? ( http://www.brorson.com/gEDA/ngspice/${P}.sdb.diff )"
+IUSE="readline"
LICENSE="BSD"
SLOT="0"
@@ -15,8 +17,22 @@ DEPEND="dev-lang/tk
dev-tcltk/blt
dev-tcltk/tclreadline"
+RDEPEND="$DEPEND
+ readline? ( sys-libs/readline )"
+
S=${WORKDIR}/${PN}
+src_unpack() {
+
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ if [ `use readline` ]; then
+ epatch ${DISTDIR}/${P}.sdb.diff || die "'readline' patch failed!"
+ fi
+
+}
+
src_compile() {
econf --enable-xspice --enable-experimental --with-tcl