summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-16 22:07:50 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-16 22:07:50 +0000
commit5bf59ac87adeb9d575b737ac973cc4a16c3df1ca (patch)
tree67f8ef11c4c70b45077447e9783a67c6ac432981 /app-sci
parentversion bump (diff)
downloadgentoo-2-5bf59ac87adeb9d575b737ac973cc4a16c3df1ca.tar.gz
gentoo-2-5bf59ac87adeb9d575b737ac973cc4a16c3df1ca.tar.bz2
gentoo-2-5bf59ac87adeb9d575b737ac973cc4a16c3df1ca.zip
filter -ffast-math
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/octave/ChangeLog7
-rw-r--r--app-sci/octave/Manifest8
-rw-r--r--app-sci/octave/octave-2.0.17-r2.ebuild7
-rw-r--r--app-sci/octave/octave-2.1.36-r1.ebuild16
-rw-r--r--app-sci/octave/octave-2.1.49.ebuild11
5 files changed, 35 insertions, 14 deletions
diff --git a/app-sci/octave/ChangeLog b/app-sci/octave/ChangeLog
index cc7eb887c7a9..f8127ee87340 100644
--- a/app-sci/octave/ChangeLog
+++ b/app-sci/octave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/octave
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.17 2003/08/29 00:32:40 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.18 2003/09/16 22:07:49 seemant Exp $
+
+ 16 Sep 2003; Seemant Kulleen <seemant@gentoo.org> octave-2.0.17-r2.ebuild,
+ octave-2.1.36-r1.ebuild, octave-2.1.49.ebuild:
+ filter out -ffast-math, as it causes segfaults. Thanks to: Jani Kotakoski
+ <jkkoski@iki.fi> in bug #28809
28 Aug 2003; Jason Wever <weeve@gentoo.org> octave-2.1.49.ebuild:
Added ~sparc to keywords to fix bug 27486.
diff --git a/app-sci/octave/Manifest b/app-sci/octave/Manifest
index 8e281b0739da..390088692a68 100644
--- a/app-sci/octave/Manifest
+++ b/app-sci/octave/Manifest
@@ -1,7 +1,7 @@
-MD5 ff0f3cbd588746f253f0885408188567 octave-2.0.17-r2.ebuild 1113
-MD5 0f9c8928584dae641610d68f6f4ace8d octave-2.1.49.ebuild 1956
-MD5 8a7146db2e44d370827ab877f283c3e5 octave-2.1.36-r1.ebuild 1928
-MD5 c5ad8a98209cbe016f8a47a110f8a90b ChangeLog 3364
+MD5 2562993bd7a7af0d304ccd813107ce8e octave-2.0.17-r2.ebuild 1164
+MD5 86d838767a0458b0be84ba307f6c1d4d octave-2.1.49.ebuild 2008
+MD5 9be8e3268ecd3b68831583382c500ace octave-2.1.36-r1.ebuild 1982
+MD5 8f44b15fad3506aecb24b7835ba103c7 ChangeLog 3602
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 db65638ec0880bb6bd26be8f6fba1eee files/digest-octave-2.0.17-r2 67
MD5 c93a44a52d46ca6e8fed8c3c23877c0d files/digest-octave-2.1.36-r1 67
diff --git a/app-sci/octave/octave-2.0.17-r2.ebuild b/app-sci/octave/octave-2.0.17-r2.ebuild
index 38640718ece7..836dc73e354d 100644
--- a/app-sci/octave/octave-2.0.17-r2.ebuild
+++ b/app-sci/octave/octave-2.0.17-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.0.17-r2.ebuild,v 1.3 2003/04/06 06:32:11 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.0.17-r2.ebuild,v 1.4 2003/09/16 22:07:49 seemant Exp $
+
+inherit flag-o-matic
IUSE=""
@@ -19,6 +21,9 @@ KEYWORDS="x86 ppc"
SLOT="0"
src_compile() {
+
+ filter-flags -ffast-math
+
# NOTE: This version only works with gcc-2.x not gcc-3.x
econf \
--enable-dl \
diff --git a/app-sci/octave/octave-2.1.36-r1.ebuild b/app-sci/octave/octave-2.1.36-r1.ebuild
index 6a3fc611991f..a36e4fed584e 100644
--- a/app-sci/octave/octave-2.1.36-r1.ebuild
+++ b/app-sci/octave/octave-2.1.36-r1.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.36-r1.ebuild,v 1.7 2003/02/13 09:24:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.36-r1.ebuild,v 1.8 2003/09/16 22:07:49 seemant Exp $
+
+inherit flag-o-matic eutils
+
+IUSE="tetex"
DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations"
-SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2"
HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2"
+SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
-SLOT="0"
-IUSE="tetex"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2-r3
@@ -27,11 +30,14 @@ PROVIDE="dev-lang/octave"
src_unpack() {
unpack ${A}
cd ${WORKDIR}
- patch -p0 < ${FILESDIR}/filebuf.diff
+ epatch ${FILESDIR}/filebuf.diff
}
src_compile() {
+
+ filter-flags -ffast-math
+
# NOTE: This version actually works with gcc-3.x
./configure --prefix=/usr \
--sysconfdir=/etc \
diff --git a/app-sci/octave/octave-2.1.49.ebuild b/app-sci/octave/octave-2.1.49.ebuild
index c3e13da316ca..e96074342977 100644
--- a/app-sci/octave/octave-2.1.49.ebuild
+++ b/app-sci/octave/octave-2.1.49.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.49.ebuild,v 1.3 2003/08/29 00:32:40 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.49.ebuild,v 1.4 2003/09/16 22:07:49 seemant Exp $
+inherit flag-o-matic
+
+IUSE="static readline zlib tetex"
DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations"
SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2"
HOMEPAGE="http://www.octave.org/"
+SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ~ppc ~alpha ~sparc"
-SLOT="0"
-IUSE="static readline zlib tetex"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2-r3
@@ -25,6 +27,9 @@ DEPEND="virtual/glibc
# more information
src_compile() {
+
+ filter-flags -ffast-math
+
local myconf
use static || myconf="--disable-static --enable-shared --enable-dl"