summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2003-11-28 21:26:58 +0000
committerTim Yamin <plasmaroo@gentoo.org>2003-11-28 21:26:58 +0000
commit6f55f1ac43113c6091eb3460367338f23502c8aa (patch)
tree33096e0aa1a8b79b375272e8877717bb06a9a08e /app-sci
parentInitial commit... (diff)
downloadgentoo-2-6f55f1ac43113c6091eb3460367338f23502c8aa.tar.gz
gentoo-2-6f55f1ac43113c6091eb3460367338f23502c8aa.tar.bz2
gentoo-2-6f55f1ac43113c6091eb3460367338f23502c8aa.zip
Initial commit...
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/ng-spice-rework/ChangeLog9
-rw-r--r--app-sci/ng-spice-rework/Manifest4
-rw-r--r--app-sci/ng-spice-rework/files/digest-ng-spice-rework-141
-rw-r--r--app-sci/ng-spice-rework/metadata.xml8
-rw-r--r--app-sci/ng-spice-rework/ng-spice-rework-14.ebuild29
5 files changed, 49 insertions, 2 deletions
diff --git a/app-sci/ng-spice-rework/ChangeLog b/app-sci/ng-spice-rework/ChangeLog
new file mode 100644
index 000000000000..067754cd33d5
--- /dev/null
+++ b/app-sci/ng-spice-rework/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-sci/ng-spice-rework
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/ng-spice-rework/ChangeLog,v 1.1 2003/11/28 21:26:50 plasmaroo Exp $
+
+*ng-spice-rework-14 (28 Nov 2003)
+
+ 28 Nov 2003; <plasmaroo@gentoo.org> ng-spice-rework-14.ebuild:
+ Initial commit.
+
diff --git a/app-sci/ng-spice-rework/Manifest b/app-sci/ng-spice-rework/Manifest
index 6d69f6d7f525..9e1e01e98077 100644
--- a/app-sci/ng-spice-rework/Manifest
+++ b/app-sci/ng-spice-rework/Manifest
@@ -1,4 +1,4 @@
-MD5 fef08e94229cfc25a09d861928d4d183 ChangeLog 251
-MD5 83013c11da290a912481a1e9f04d836d ng-spice-rework-14.ebuild 740
+MD5 dfafcadf12bdcbb5801347608eacaf47 ChangeLog 350
+MD5 128a473c2cf37313925e31defb8826c4 ng-spice-rework-14.ebuild 729
MD5 e49bb02132d2cd74ad4e6ee291e102d9 metadata.xml 220
MD5 419df059e644593b30561622cf904785 files/digest-ng-spice-rework-14 71
diff --git a/app-sci/ng-spice-rework/files/digest-ng-spice-rework-14 b/app-sci/ng-spice-rework/files/digest-ng-spice-rework-14
new file mode 100644
index 000000000000..bd917676e6e5
--- /dev/null
+++ b/app-sci/ng-spice-rework/files/digest-ng-spice-rework-14
@@ -0,0 +1 @@
+MD5 5405d78a531fe9f30d70c35a8a469690 ng-spice-rework-14.tar.gz 2762582
diff --git a/app-sci/ng-spice-rework/metadata.xml b/app-sci/ng-spice-rework/metadata.xml
new file mode 100644
index 000000000000..e2035cdbb121
--- /dev/null
+++ b/app-sci/ng-spice-rework/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>plasmaroo@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-sci/ng-spice-rework/ng-spice-rework-14.ebuild b/app-sci/ng-spice-rework/ng-spice-rework-14.ebuild
new file mode 100644
index 000000000000..f1b1d2e5e780
--- /dev/null
+++ b/app-sci/ng-spice-rework/ng-spice-rework-14.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc. and Tim Yamin <plasmaroo@gentoo.org> <plasmaroo@squirrelsoft.org.uk>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/ng-spice-rework/ng-spice-rework-14.ebuild,v 1.1 2003/11/28 21:26:50 plasmaroo Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="NGSpice - The Next Generation Spice (Circuit Emulator)"
+SRC_URI="http://www.geda.seul.org/dist/${P}.tar.gz"
+HOMEPAGE="http://ngspice.sourceforge.net"
+
+SLOT="0"
+LICENSE="BSD GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_compile() {
+
+ econf || die
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc COPYING COPYRIGHT CREDITS ChangeLog README
+
+}