summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-07 20:04:45 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-07 20:04:45 +0000
commite4cb2fcb6b7aa340b59b61394fa64a6840e4a93f (patch)
tree405020acc5b883318638d12712c1f0a5f60d6f41 /app-sci
parentforgot the gcc eclass (diff)
downloadgentoo-2-e4cb2fcb6b7aa340b59b61394fa64a6840e4a93f.tar.gz
gentoo-2-e4cb2fcb6b7aa340b59b61394fa64a6840e4a93f.tar.bz2
gentoo-2-e4cb2fcb6b7aa340b59b61394fa64a6840e4a93f.zip
add inherit eutils
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/tclspice/tclspice-0.2.14.ebuild27
1 files changed, 9 insertions, 18 deletions
diff --git a/app-sci/tclspice/tclspice-0.2.14.ebuild b/app-sci/tclspice/tclspice-0.2.14.ebuild
index cd06f5582bd9..91d36630f81f 100644
--- a/app-sci/tclspice/tclspice-0.2.14.ebuild
+++ b/app-sci/tclspice/tclspice-0.2.14.ebuild
@@ -1,52 +1,43 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/tclspice/tclspice-0.2.14.ebuild,v 1.4 2004/02/01 16:33:03 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/tclspice/tclspice-0.2.14.ebuild,v 1.5 2004/04/07 20:04:45 vapier Exp $
-DESCRIPTION="Spice circuit simulator with TCL scipting language and GUI"
-HOMEPAGE="http://tclspice.sf.net/"
+inherit eutils
+DESCRIPTION="Spice circuit simulator with TCL scipting language and GUI"
+HOMEPAGE="http://tclspice.sourceforge.net/"
SRC_URI="mirror://sourceforge/tclspice/${P}.tar.gz
readline? ( http://www.brorson.com/gEDA/ngspice/${P}.sdb.diff )"
-IUSE="readline"
LICENSE="BSD"
SLOT="0"
-
KEYWORDS="x86 ~sparc"
+IUSE="readline"
+
DEPEND="dev-lang/tk
>=dev-tcltk/blt-2.4z
>=dev-tcltk/tclreadline-2.1.0"
-
-RDEPEND="$DEPEND
+RDEPEND="${DEPEND}
readline? ( sys-libs/readline )"
S=${WORKDIR}/${PN}
src_unpack() {
-
unpack ${P}.tar.gz
cd ${S}
-
- if [ `use readline` ]; then
- epatch ${DISTDIR}/${P}.sdb.diff || die "'readline' patch failed!"
- fi
-
+ use readline && epatch ${DISTDIR}/${P}.sdb.diff
}
src_compile() {
-
econf --enable-xspice --enable-experimental --with-tcl
emake tcl || die
-
}
src_install() {
-
make DESTDIR=${D} install-tcl || die
cd ${S}
dodoc README README.Tcl ChangeLog
cd src/tcl
docinto tcl
- dodoc ChangeLog README
-
+ dodoc ChangeLog README
}