summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-12-25 13:04:58 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-12-25 13:04:58 +0000
commit11d20bd9e996e06db5c0b83fe3811b9b3c27b566 (patch)
tree5f504dfe68880f231b1815bd4434fd9e647fe400 /app-shells/bash-completion/bash-completion-20041017-r3.ebuild
parentInitial 2.6.10 release. inotify upgraded to 0.17, squashfs to 2.1, new versio... (diff)
downloadgentoo-2-11d20bd9e996e06db5c0b83fe3811b9b3c27b566.tar.gz
gentoo-2-11d20bd9e996e06db5c0b83fe3811b9b3c27b566.tar.bz2
gentoo-2-11d20bd9e996e06db5c0b83fe3811b9b3c27b566.zip
RDEPEND on bash or zsh, since zsh is also able to read bash-completions; bug 75384. Also added some einfo's with URL's to more info for zsh users.
Diffstat (limited to 'app-shells/bash-completion/bash-completion-20041017-r3.ebuild')
-rw-r--r--app-shells/bash-completion/bash-completion-20041017-r3.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/app-shells/bash-completion/bash-completion-20041017-r3.ebuild b/app-shells/bash-completion/bash-completion-20041017-r3.ebuild
index 6a6e69b896c6..28174cae9e9d 100644
--- a/app-shells/bash-completion/bash-completion-20041017-r3.ebuild
+++ b/app-shells/bash-completion/bash-completion-20041017-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20041017-r3.ebuild,v 1.1 2004/12/06 16:28:44 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20041017-r3.ebuild,v 1.2 2004/12/25 13:04:58 ka0ttic Exp $
inherit eutils
@@ -18,7 +18,10 @@ IUSE=""
DEPEND="app-arch/tar
app-arch/bzip2"
-RDEPEND=">=app-shells/bash-2.05a"
+RDEPEND="|| (
+ >=app-shells/bash-2.05a
+ app-shells/zsh
+ )"
S="${WORKDIR}/${PN/-/_}"
@@ -67,4 +70,12 @@ pkg_postinst() {
ewarn "Please run etc-update to replace /etc/bash_completion.d/gentoo with a symlink."
fi
echo
+
+ if has_version 'app-shells/zsh' ; then
+ einfo "If you are interested in using the provided bash completion functions with"
+ einfo "zsh, valuable tips on the effective use of bashcompinit are available:"
+ einfo " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ einfo " http://zshwiki.org/ZshSwitchingTo"
+ echo
+ fi
}