summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-23 23:07:21 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-23 23:07:21 +0000
commitc9272e7a7730f712fe06764deb37cec299791ab1 (patch)
treec367205ce6fd5d8896abd4783da3adf373ef0b81 /app-shells/bash/bash-3.0-r13.ebuild
parentfix should_we_gcc_config/should_we_eselect_compiler and add some comments to ... (diff)
downloadgentoo-2-c9272e7a7730f712fe06764deb37cec299791ab1.tar.gz
gentoo-2-c9272e7a7730f712fe06764deb37cec299791ab1.tar.bz2
gentoo-2-c9272e7a7730f712fe06764deb37cec299791ab1.zip
remove dead curses sed, make sure we force bash to build against curses, and fixup static linking where appropriate
(Portage version: 2.1_pre6-r6)
Diffstat (limited to 'app-shells/bash/bash-3.0-r13.ebuild')
-rw-r--r--app-shells/bash/bash-3.0-r13.ebuild16
1 files changed, 4 insertions, 12 deletions
diff --git a/app-shells/bash/bash-3.0-r13.ebuild b/app-shells/bash/bash-3.0-r13.ebuild
index d3136dcc13c6..a00517904f53 100644
--- a/app-shells/bash/bash-3.0-r13.ebuild
+++ b/app-shells/bash/bash-3.0-r13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r13.ebuild,v 1.3 2006/03/08 01:21:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r13.ebuild,v 1.4 2006/03/23 23:07:21 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -83,8 +83,6 @@ src_unpack() {
# Add strnlen function for non-glibc systems, as one of Fedora's patches
# requires it.
epatch "${FILESDIR}"/${P}-strnlen.patch
-
- sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
}
src_compile() {
@@ -105,21 +103,15 @@ src_compile() {
#use static && export LDFLAGS="${LDFLAGS} -static"
use nls || myconf="${myconf} --disable-nls"
- echo 'int main(){}' > "${T}"/term-test.c
- if ! $(tc-getCC) -static -lncurses "${T}"/term-test.c 2> /dev/null ; then
- export bash_cv_termcap_lib=gnutermcap
- else
- export bash_cv_termcap_lib=libcurses
- myconf="${myconf} --with-curses"
- fi
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses
+ myconf="${myconf} --with-curses"
econf \
$(use_with afs) \
--disable-profiling \
--without-gnu-malloc \
${myconf} || die
- # Make sure we always link statically with ncurses
- sed -i "/^TERMCAP_LIB/s:-lncurses:-Wl,-Bstatic -lncurses -Wl,-Bdynamic:" Makefile || die "sed failed"
emake -j1 || die "make failed" # see bug 102426
}