summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-03-04 20:18:41 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-03-04 20:18:41 +0000
commit6b9a66f559a8aa611e5b9e82286513b989d87db3 (patch)
tree408ea7f2de5c0e1f0416a8c2dff119425474862b /app-shells/pdmenu
parentVersion bump for bug #208120 thanks to Steffen Stramm (diff)
downloadgentoo-2-6b9a66f559a8aa611e5b9e82286513b989d87db3.tar.gz
gentoo-2-6b9a66f559a8aa611e5b9e82286513b989d87db3.tar.bz2
gentoo-2-6b9a66f559a8aa611e5b9e82286513b989d87db3.zip
Version bump for bug #208457
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-shells/pdmenu')
-rw-r--r--app-shells/pdmenu/ChangeLog7
-rw-r--r--app-shells/pdmenu/pdmenu-1.2.93.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/app-shells/pdmenu/ChangeLog b/app-shells/pdmenu/ChangeLog
index 266ce333a7c1..1a6964c99a69 100644
--- a/app-shells/pdmenu/ChangeLog
+++ b/app-shells/pdmenu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/pdmenu
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdmenu/ChangeLog,v 1.10 2008/02/09 11:37:14 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdmenu/ChangeLog,v 1.11 2008/03/04 20:18:41 jokey Exp $
+
+*pdmenu-1.2.93 (04 Mar 2008)
+
+ 04 Mar 2008; Markus Ullmann <jokey@gentoo.org> +pdmenu-1.2.93.ebuild:
+ Version bump for bug #208457
09 Feb 2008; Samuli Suominen <drac@gentoo.org> pdmenu-1.2.89.ebuild:
Keyword ~amd64 and verify it works with slang 2.1.3.
diff --git a/app-shells/pdmenu/pdmenu-1.2.93.ebuild b/app-shells/pdmenu/pdmenu-1.2.93.ebuild
new file mode 100644
index 000000000000..62808fe203d6
--- /dev/null
+++ b/app-shells/pdmenu/pdmenu-1.2.93.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdmenu/pdmenu-1.2.93.ebuild,v 1.1 2008/03/04 20:18:41 jokey Exp $
+
+DESCRIPTION="A simple console menu program"
+HOMEPAGE="http://www.kitenet.net/programs/pdmenu/"
+SRC_URI="mirror://debian/pool/main/p/pdmenu/pdmenu_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~x86"
+IUSE="nls gpm examples"
+
+DEPEND="sys-libs/slang
+ gpm? ( sys-libs/gpm )
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}
+
+RESTRICT="test"
+
+src_compile() {
+ econf \
+ $(use_with gpm) \
+ $(use_enable nls) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodoc doc/ANNOUNCE doc/BUGS doc/TODO
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ mv doc/pdmenu.man doc/pdmenu.1
+ mv doc/pdmenurc.man doc/pdmenurc.5
+ doman doc/pdmenu.1 doc/pdmenurc.5
+
+ dobin pdmenu
+}
+
+pkg_postinst() {
+ ewarn "Note this part from man page: Security warning! Any exec command"
+ ewarn "that uses the 'edit' flag will be a security hole. The user need"
+ ewarn "only to enter text with a ';' in it, and they can run an"
+ ewarn "arbitrary command after the semicolon!"
+}