summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-09-01 16:21:19 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-09-01 16:21:19 +0000
commit6116f974e1c98675c0095293f660bdc79c90332c (patch)
treee05bcafc81f243b49882d40c6975264c6c6ddb11 /app-shells/sash/sash-3.7-r3.ebuild
parentMarked ~hppa (bug #381313). (diff)
downloadgentoo-2-6116f974e1c98675c0095293f660bdc79c90332c.tar.gz
gentoo-2-6116f974e1c98675c0095293f660bdc79c90332c.tar.bz2
gentoo-2-6116f974e1c98675c0095293f660bdc79c90332c.zip
Remove readline USE flag and patch given that the patch itself is custom and not vanilla, and this is orphaned.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-shells/sash/sash-3.7-r3.ebuild')
-rw-r--r--app-shells/sash/sash-3.7-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-shells/sash/sash-3.7-r3.ebuild b/app-shells/sash/sash-3.7-r3.ebuild
new file mode 100644
index 000000000000..52b00c43b5f8
--- /dev/null
+++ b/app-shells/sash/sash-3.7-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.7-r3.ebuild,v 1.1 2011/09/01 16:21:19 flameeyes Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A small (static) UNIX Shell"
+HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+DEPEND=">=sys-libs/zlib-1.2.3"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/sash-3.6-fix-includes.patch
+ epatch "${FILESDIR}"/sash-3.7-builtin.patch
+
+ sed -i \
+ -e "s:-O3:${CFLAGS}:" \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ emake LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ into /
+ dobin sash
+ doman sash.1
+ dodoc README
+}