summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorParag Mehta <pm@gentoo.org>2001-07-03 12:19:26 +0000
committerParag Mehta <pm@gentoo.org>2001-07-03 12:19:26 +0000
commit4916573c45a0a110f3bae3d173c4bae03272002c (patch)
treeec19fc4e167b4b22124fcc2b09e310412bd4ff65 /app-shells/zsh
parentnew version for Fetchmail (diff)
downloadgentoo-2-4916573c45a0a110f3bae3d173c4bae03272002c.tar.gz
gentoo-2-4916573c45a0a110f3bae3d173c4bae03272002c.tar.bz2
gentoo-2-4916573c45a0a110f3bae3d173c4bae03272002c.zip
Newer Release of Zsh.
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/files/digest-zsh-4.0.21
-rw-r--r--app-shells/zsh/zsh-4.0.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-shells/zsh/files/digest-zsh-4.0.2 b/app-shells/zsh/files/digest-zsh-4.0.2
new file mode 100644
index 000000000000..59dcf0b0af67
--- /dev/null
+++ b/app-shells/zsh/files/digest-zsh-4.0.2
@@ -0,0 +1 @@
+MD5 38611d4ddd2547668d48867772ce214e zsh-4.0.2.tar.gz
diff --git a/app-shells/zsh/zsh-4.0.2.ebuild b/app-shells/zsh/zsh-4.0.2.ebuild
new file mode 100644
index 000000000000..512c662135f9
--- /dev/null
+++ b/app-shells/zsh/zsh-4.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# This ebuild by Parag Mehta <pm@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.2.ebuild,v 1.1 2001/07/03 12:19:26 pm Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+SRC_URI="ftp://ftp.zsh.org/pub/${A}"
+HOMEPAGE="www.zsh.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1"
+
+src_compile() {
+
+ try ./configure --prefix=/ --mandir=/usr/share/man \
+ --libdir=/usr/lib --host=${CHOST}
+ try make
+}
+
+src_install() {
+
+ try make prefix=${D} mandir=${D}/usr/share/man \
+ libdir=${D}/usr/lib \
+ install.bin install.man install.modules
+
+ dodoc ChangeLog META-FAQ README
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+
+}
+
+
+
+