summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-11-06 00:39:19 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-11-06 00:39:19 +0000
commit68b4b46c357787d8d0740f8899b8ec528d9b34f7 (patch)
tree782ef0ed112e9fb3da0f0b3c1f439e3ba6403443 /app-shells/zsh
parentversion bump (diff)
downloadgentoo-2-68b4b46c357787d8d0740f8899b8ec528d9b34f7.tar.gz
gentoo-2-68b4b46c357787d8d0740f8899b8ec528d9b34f7.tar.bz2
gentoo-2-68b4b46c357787d8d0740f8899b8ec528d9b34f7.zip
Removing sed that tried to force static linking with libpcre and closing bug #182534.
(Portage version: 2.1.3.16)
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/ChangeLog7
-rw-r--r--app-shells/zsh/zsh-4.3.2-r2.ebuild8
-rw-r--r--app-shells/zsh/zsh-4.3.4.ebuild6
3 files changed, 13 insertions, 8 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 0c298d8982cf..b177a4818a82 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/zsh
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.114 2007/08/16 09:52:54 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.115 2007/11/06 00:39:19 wolf31o2 Exp $
+
+ 06 Nov 2007; Chris Gianelloni <wolf31o2@gentoo.org> zsh-4.3.2-r2.ebuild,
+ zsh-4.3.4.ebuild:
+ Removing sed that tried to force static linking with libpcre and closing bug
+ #182534.
16 Aug 2007; Roy Marples <uberlord@gentoo.org>
+files/zsh-4.3.4-configure-changequote.patch, zsh-4.3.4.ebuild:
diff --git a/app-shells/zsh/zsh-4.3.2-r2.ebuild b/app-shells/zsh/zsh-4.3.2-r2.ebuild
index 677c2fd26bbc..c42b62f7c70d 100644
--- a/app-shells/zsh/zsh-4.3.2-r2.ebuild
+++ b/app-shells/zsh/zsh-4.3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.3.2-r2.ebuild,v 1.12 2007/06/14 18:16:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.3.2-r2.ebuild,v 1.13 2007/11/06 00:39:19 wolf31o2 Exp $
inherit eutils multilib
@@ -69,10 +69,10 @@ src_compile() {
sed -i -e "s/link=no/link=static/g" \
-e "s/load=no/load=yes/g" \
config.modules || die
- else
+# else
# avoid linking to libs in /usr/lib, see Bug #27064
- sed -i -e "/LIBS/s%-lpcre%/usr/$(get_libdir)/libpcre.a%" \
- Makefile || die
+# sed -i -e "/LIBS/s%-lpcre%/usr/$(get_libdir)/libpcre.a%" \
+# Makefile || die
fi
# emake still b0rks
diff --git a/app-shells/zsh/zsh-4.3.4.ebuild b/app-shells/zsh/zsh-4.3.4.ebuild
index ebc9671458a2..b1c5ea61c267 100644
--- a/app-shells/zsh/zsh-4.3.4.ebuild
+++ b/app-shells/zsh/zsh-4.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.3.4.ebuild,v 1.3 2007/08/16 09:52:54 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.3.4.ebuild,v 1.4 2007/11/06 00:39:19 wolf31o2 Exp $
inherit eutils multilib autotools
@@ -73,8 +73,8 @@ src_compile() {
sed -i -e "s/link=no/link=static/g" \
-e "s/load=no/load=yes/g" \
config.modules || die
- else
- sed -i -e "/LIBS/s%-lpcre%/usr/$(get_libdir)/libpcre.a%" Makefile
+# else
+# sed -i -e "/LIBS/s%-lpcre%/usr/$(get_libdir)/libpcre.a%" Makefile
fi
emake || die "make failed"