summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-11-15 16:05:16 +0000
committerTilman Klar <phoenix@gentoo.org>2002-11-15 16:05:16 +0000
commit6c87d441d948367d876d9cbc4215030da1328551 (patch)
tree2d37b9ab2bf020eb4c9525fa76023f28bfcfd522 /app-shells/zsh
parentcleanup and update (diff)
downloadgentoo-2-6c87d441d948367d876d9cbc4215030da1328551.tar.gz
gentoo-2-6c87d441d948367d876d9cbc4215030da1328551.tar.bz2
gentoo-2-6c87d441d948367d876d9cbc4215030da1328551.zip
Fixed a serious bug where zsh didnt source /etc/profile* - check bug 10724 for details.
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/ChangeLog12
-rw-r--r--app-shells/zsh/files/digest-zsh-4.0.6-r32
-rw-r--r--app-shells/zsh/files/zshenv15
-rw-r--r--app-shells/zsh/zsh-4.0.4-r2.ebuild3
-rw-r--r--app-shells/zsh/zsh-4.0.5.ebuild3
-rw-r--r--app-shells/zsh/zsh-4.0.6-r1.ebuild4
-rw-r--r--app-shells/zsh/zsh-4.0.6-r2.ebuild4
-rw-r--r--app-shells/zsh/zsh-4.0.6-r3.ebuild57
8 files changed, 95 insertions, 5 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index d76475d7d62b..78779dce468f 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-shells/zsh
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.12 2002/11/08 15:33:21 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.13 2002/11/15 16:05:16 phoenix Exp $
+
+*zsh-4.0.6-r3 (15 Oct 2002)
+
+ 15 Oct 2002; phoen][x <phoenixk@gentoo.org> zsh-4.0.6-r3.ebuild :
+
+ Fixed a quite serious issues: zsh didnt source /etc/profile.env
+ and /etc/profile. Removed /etc/zsh/zshlogin and /etc/zsh/zshrc
+ and replaced /etc/zsh/zshenv with a script which sources /etc/profile*.
+ Thanks to James Michael Fultz <jmf@gtcom.net> for the contribution.
+ This closes bug #10724.
*zsh-4.0.6-r2 (05 Oct 2002)
diff --git a/app-shells/zsh/files/digest-zsh-4.0.6-r3 b/app-shells/zsh/files/digest-zsh-4.0.6-r3
new file mode 100644
index 000000000000..9364361da9b5
--- /dev/null
+++ b/app-shells/zsh/files/digest-zsh-4.0.6-r3
@@ -0,0 +1,2 @@
+MD5 6a86da9120e97ebe03afd6a51f717c0f zsh-4.0.6.tar.gz 2146169
+MD5 c8faa44cae89a15cd3616c0dc803fb40 zsh_4.0.6-15.diff.gz 36360
diff --git a/app-shells/zsh/files/zshenv b/app-shells/zsh/files/zshenv
new file mode 100644
index 000000000000..4d350d569f5a
--- /dev/null
+++ b/app-shells/zsh/files/zshenv
@@ -0,0 +1,15 @@
+[[ -o rcs ]] || return 0
+
+[[ -e "/etc/profile.env" ]] && source /etc/profile.env
+
+#077 would be more secure, but 022 is generally quite realistic
+umask 022
+
+if [[ $(/usr/bin/whoami) == 'root' ]]
+then
+ export PATH="/bin:/sbin:/usr/bin:/usr/sbin:${ROOTPATH}"
+else
+ export PATH="/bin:/usr/bin:${PATH}"
+fi
+unset ROOTPATH
+
diff --git a/app-shells/zsh/zsh-4.0.4-r2.ebuild b/app-shells/zsh/zsh-4.0.4-r2.ebuild
index e3f62371c2ee..b7a96cd6bf4a 100644
--- a/app-shells/zsh/zsh-4.0.4-r2.ebuild
+++ b/app-shells/zsh/zsh-4.0.4-r2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# This ebuild by Parag Mehta <pm@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.4-r2.ebuild,v 1.8 2002/10/04 05:02:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.4-r2.ebuild,v 1.9 2002/11/15 16:05:16 phoenix Exp $
+IUSE=""
S=${WORKDIR}/${P}
DESCRIPTION="UNIX Shell similar to the Korn shell"
diff --git a/app-shells/zsh/zsh-4.0.5.ebuild b/app-shells/zsh/zsh-4.0.5.ebuild
index b1ff1229f4ae..9209e5bd0b26 100644
--- a/app-shells/zsh/zsh-4.0.5.ebuild
+++ b/app-shells/zsh/zsh-4.0.5.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.5.ebuild,v 1.5 2002/10/20 18:40:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.5.ebuild,v 1.6 2002/11/15 16:05:16 phoenix Exp $
+IUSE=""
S=${WORKDIR}/${P}
DESCRIPTION="UNIX Shell similar to the Korn shell"
diff --git a/app-shells/zsh/zsh-4.0.6-r1.ebuild b/app-shells/zsh/zsh-4.0.6-r1.ebuild
index 5d01c6b75b63..b8daf33367de 100644
--- a/app-shells/zsh/zsh-4.0.6-r1.ebuild
+++ b/app-shells/zsh/zsh-4.0.6-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.6-r1.ebuild,v 1.2 2002/10/04 05:02:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.6-r1.ebuild,v 1.3 2002/11/15 16:05:16 phoenix Exp $
+
+IUSE=""
DESCRIPTION="UNIX Shell similar to the Korn shell"
SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.gz"
diff --git a/app-shells/zsh/zsh-4.0.6-r2.ebuild b/app-shells/zsh/zsh-4.0.6-r2.ebuild
index ab0298586f14..4b6cb8be0936 100644
--- a/app-shells/zsh/zsh-4.0.6-r2.ebuild
+++ b/app-shells/zsh/zsh-4.0.6-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.6-r2.ebuild,v 1.2 2002/11/08 15:33:21 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.6-r2.ebuild,v 1.3 2002/11/15 16:05:16 phoenix Exp $
+
+IUSE=""
DESCRIPTION="UNIX Shell similar to the Korn shell"
MYPATCH="zsh_4.0.6-15.diff"
diff --git a/app-shells/zsh/zsh-4.0.6-r3.ebuild b/app-shells/zsh/zsh-4.0.6-r3.ebuild
new file mode 100644
index 000000000000..70cf9b0c6534
--- /dev/null
+++ b/app-shells/zsh/zsh-4.0.6-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.6-r3.ebuild,v 1.1 2002/11/15 16:05:16 phoenix Exp $
+
+IUSE=""
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+MYPATCH="zsh_4.0.6-15.diff"
+SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.gz
+ http://ftp.debian.org/debian/pool/main/z/${PN}/${MYPATCH}.gz"
+HOMEPAGE="www.zsh.org/"
+SLOT="0"
+LICENSE="ZSH"
+
+DEPEND=">=sys-libs/ncurses-5.1"
+
+KEYWORDS="x86 alpha ~ppc ~sparc ~sparc64"
+
+src_unpack() {
+ unpack ${A}
+ patch -p0 < ${MYPATCH}
+}
+
+
+src_compile() {
+ econf \
+ --bindir=/bin \
+ --libdir=/usr/lib \
+ --enable-maildir-support \
+ --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv \
+ --enable-zshlogin=/etc/zsh/zshlogin \
+ --enable-zshrc=/etc/zsh/zshrc \
+ --enable-fndir=/usr/share/zsh/${PV}/functions \
+ --enable-site-fndir=/usr/share/zsh/site-functions \
+ --enable-function-subdirs || die "configure failed"
+ # emake still b0rks
+ make || die "make failed"
+ #make check || die "make check failed"
+}
+
+src_install() {
+ einstall \
+ bindir=${D}/bin \
+ libdir=${D}/usr/lib \
+ fndir=${D}/usr/share/zsh/${PV}/functions \
+ sitefndir=${D}/usr/share/zsh/site-functions \
+ install.bin install.man install.modules \
+ install.info install.fns || die "make install failed"
+
+ dodoc ChangeLog META-FAQ README INSTALL LICENCE config.modules
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+
+ insinto /etc/zsh
+ doins ${FILESDIR}/zshenv
+}