summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2010-01-22 01:22:10 +0000
committerDawid Węgliński <cla@gentoo.org>2010-01-22 01:22:10 +0000
commit0583acdb3aef34436d20aa9742bd3037ee3db2d1 (patch)
treed02fd06008382776e10a68c979cb9314356ec669 /app-shells
parentstable sparc, bug 301764 (diff)
downloadgentoo-2-0583acdb3aef34436d20aa9742bd3037ee3db2d1.tar.gz
gentoo-2-0583acdb3aef34436d20aa9742bd3037ee3db2d1.tar.bz2
gentoo-2-0583acdb3aef34436d20aa9742bd3037ee3db2d1.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ksh/ChangeLog9
-rw-r--r--app-shells/ksh/ksh-93.20090505.ebuild71
2 files changed, 78 insertions, 2 deletions
diff --git a/app-shells/ksh/ChangeLog b/app-shells/ksh/ChangeLog
index 2e85a9ec62e9..9d0d57812793 100644
--- a/app-shells/ksh/ChangeLog
+++ b/app-shells/ksh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/ksh
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.39 2009/09/06 19:05:41 idl0r Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.40 2010/01/22 01:22:10 cla Exp $
+
+*ksh-93.20090505 (22 Jan 2010)
+
+ 22 Jan 2010; Dawid Węgliński <cla@gentoo.org> +ksh-93.20090505.ebuild:
+ Version bump
06 Sep 2009; Christian Ruppert <idl0r@gentoo.org>
-files/ksh-93.20030724-libs.diff, ksh-93.20071105.ebuild,
diff --git a/app-shells/ksh/ksh-93.20090505.ebuild b/app-shells/ksh/ksh-93.20090505.ebuild
new file mode 100644
index 000000000000..7d1bc2b82d3f
--- /dev/null
+++ b/app-shells/ksh/ksh-93.20090505.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20090505.ebuild,v 1.1 2010/01/22 01:22:10 cla Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+RELEASE="2009-05-05"
+LOCALE_RELEASE="2007-11-05"
+INIT_RELEASE="${RELEASE}"
+
+DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
+HOMEPAGE="http://www.kornshell.com/"
+SRC_URI="nls? ( mirror://gentoo/ast-ksh-locale.${LOCALE_RELEASE}.tgz )
+ mirror://gentoo/INIT.${INIT_RELEASE}.tgz
+ mirror://gentoo/ast-ksh.${RELEASE}.tgz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="!app-shells/pdksh"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ # the AT&T build tools look in here for packages.
+ mkdir -p "${S}"/lib/package/tgz
+
+ # move the packages into place.
+ cp "${DISTDIR}"/ast-ksh.${RELEASE}.tgz "${S}"/lib/package/tgz/ || die
+
+ if use nls; then
+ cp "${DISTDIR}"/ast-ksh-locale.${LOCALE_RELEASE}.tgz "${S}"/lib/package/tgz/ || die
+ fi
+
+ # INIT provides the basic tools to start building.
+ unpack INIT.${INIT_RELEASE}.tgz
+
+ # `package read` will unpack any tarballs put in place.
+ "${S}"/bin/package read || die
+}
+
+src_compile() {
+ strip-flags; export CCFLAGS="${CFLAGS}"
+
+ cd "${S}"; ./bin/package only make ast-ksh CC="$(tc-getCC)" || die
+
+ # install the optional locale data.
+ if use nls; then
+ cd "${S}"; ./bin/package only make ast-ksh-locale CC="$(tc-getCC)"
+ fi
+}
+
+src_install() {
+ exeinto /bin
+
+ doexe "${S}"/arch/linux.*/bin/ksh || die
+
+ newman "${S}"/arch/linux.*/man/man1/sh.1 ksh.1
+
+ dodoc lib/package/LICENSES/ast
+ dohtml lib/package/ast-ksh.html
+
+ if use nls; then
+ dodir /usr/share
+ mv "${S}"/share/lib/locale "${D}"/usr/share
+ find "${D}"/usr/share/locale -type f -name 'LC_TIME' -exec rm -rf {} \; 2>/dev/null
+ fi
+}