summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-07-11 18:54:56 +0000
committerUlrich Müller <ulm@gentoo.org>2012-07-11 18:54:56 +0000
commit169c01c208de3476ee99e2f9bcc641197f02bc50 (patch)
tree3b437f2b4062d2b75d240592e1cb5c8bf367bb61 /app-shells
parentversion bump (diff)
downloadgentoo-2-169c01c208de3476ee99e2f9bcc641197f02bc50.tar.gz
gentoo-2-169c01c208de3476ee99e2f9bcc641197f02bc50.tar.bz2
gentoo-2-169c01c208de3476ee99e2f9bcc641197f02bc50.zip
Don't install dysfunctional esh-mode.el for Emacs, bug 425780.
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/esh/ChangeLog7
-rw-r--r--app-shells/esh/esh-0.8.5-r2.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/app-shells/esh/ChangeLog b/app-shells/esh/ChangeLog
index 62c03a6331d5..c5571dfdade5 100644
--- a/app-shells/esh/ChangeLog
+++ b/app-shells/esh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/esh
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/ChangeLog,v 1.24 2012/05/10 15:20:04 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/ChangeLog,v 1.25 2012/07/11 18:54:56 ulm Exp $
+
+*esh-0.8.5-r2 (11 Jul 2012)
+
+ 11 Jul 2012; Ulrich Müller <ulm@gentoo.org> +esh-0.8.5-r2.ebuild:
+ Don't install dysfunctional esh-mode.el for Emacs, bug 425780.
10 May 2012; Agostino Sarubbo <ago@gentoo.org> -esh-0.8.5.ebuild:
Remove old
diff --git a/app-shells/esh/esh-0.8.5-r2.ebuild b/app-shells/esh/esh-0.8.5-r2.ebuild
new file mode 100644
index 000000000000..e30571fb442e
--- /dev/null
+++ b/app-shells/esh/esh-0.8.5-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8.5-r2.ebuild,v 1.1 2012/07/11 18:54:56 ulm Exp $
+
+EAPI="2"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
+HOMEPAGE="http://slon.ttk.ru/esh/"
+SRC_URI="http://slon.ttk.ru/esh/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e 's|-g ||' \
+ -e 's|-DMEM_DEBUG ||' \
+ -e 's|^CFLAGS|&+|g' \
+ -e 's|^LIB=|LIB= -lncurses |' \
+ -e 's|$(CC) |&$(CFLAGS) $(LDFLAGS) |g' \
+ -e 's:-ltermcap::' \
+ Makefile || die "sed Makefile"
+ }
+src_compile() {
+ # For some reason, this tarball has binary files in it for x86.
+ # Make clean so we can rebuild for our arch and optimization.
+ emake clean
+
+ use debug && append-flags -DMEM_DEBUG
+
+ emake \
+ CC="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin esh || die
+ doinfo doc/esh.info
+ dodoc CHANGELOG CREDITS GC_README HEADER READLINE-HACKS TODO
+ dohtml doc/*.html
+ docinto examples
+ dodoc examples/*
+}