summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-31 17:20:43 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-31 17:20:43 +0000
commit1896802bf9dc12343cee58868ef3d9e05f2ee82c (patch)
treeea768629dec28f29cbd970a750be15879e66b986 /app-shells
parentAdd syntax highlighting fix (bug #52363) (Manifest recommit) (diff)
downloadgentoo-2-1896802bf9dc12343cee58868ef3d9e05f2ee82c.tar.gz
gentoo-2-1896802bf9dc12343cee58868ef3d9e05f2ee82c.tar.bz2
gentoo-2-1896802bf9dc12343cee58868ef3d9e05f2ee82c.zip
arm KEYWORDS
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ksh/ksh-93.20040229.ebuild7
-rw-r--r--app-shells/zsh/zsh-4.2.0-r1.ebuild26
2 files changed, 15 insertions, 18 deletions
diff --git a/app-shells/ksh/ksh-93.20040229.ebuild b/app-shells/ksh/ksh-93.20040229.ebuild
index 85e5e9985a2b..161fe2865a0d 100644
--- a/app-shells/ksh/ksh-93.20040229.ebuild
+++ b/app-shells/ksh/ksh-93.20040229.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20040229.ebuild,v 1.3 2004/04/27 17:25:22 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20040229.ebuild,v 1.4 2004/05/31 17:17:45 vapier Exp $
inherit ccc eutils flag-o-matic
@@ -13,10 +13,11 @@ SRC_URI="http://www.research.att.com/~gsf/download/tgz/INIT.${RELEASE}.tgz
LICENSE="ATT"
SLOT="0"
-KEYWORDS="~x86 ~alpha ~sparc s390"
+KEYWORDS="~x86 ~sparc ~alpha arm s390"
IUSE="static nls"
-DEPEND="virtual/glibc !app-shells/pdksh"
+DEPEND="virtual/glibc
+ !app-shells/pdksh"
S=${WORKDIR}
diff --git a/app-shells/zsh/zsh-4.2.0-r1.ebuild b/app-shells/zsh/zsh-4.2.0-r1.ebuild
index a7e81ba8482b..98266a698e40 100644
--- a/app-shells/zsh/zsh-4.2.0-r1.ebuild
+++ b/app-shells/zsh/zsh-4.2.0-r1.ebuild
@@ -1,31 +1,28 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.2.0-r1.ebuild,v 1.1 2004/05/03 18:46:32 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.2.0-r1.ebuild,v 1.2 2004/05/31 17:20:43 vapier Exp $
inherit eutils
-IUSE="maildir ncurses static doc pcre cap"
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="http://www.zsh.org/"
-
MYDATE="20040204"
MY_P="${P/_pre/-pre-}"
-
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="http://www.zsh.org/"
SRC_URI="ftp://ftp.zsh.org/pub/${MY_P}.tar.bz2
cjk? ( http://www.ono.org/software/dist/${P}-euc-0.2.patch.gz )
doc? ( ftp://ftp.zsh.org/pub/${MY_P}-doc.tar.bz2 )"
-SLOT="0"
LICENSE="ZSH"
-KEYWORDS="~x86 ~alpha ~ppc ~sparc ~amd64 ~hppa"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha arm ~hppa ~amd64"
+IUSE="maildir ncurses static doc pcre cap"
-DEPEND="sys-apps/groff
- >=sys-apps/sed-4
- ${RDEPEND}"
RDEPEND="pcre? ( >=dev-libs/libpcre-3.9 )
cap? ( sys-libs/libcap )
ncurses? ( >=sys-libs/ncurses-5.1 )"
+DEPEND="sys-apps/groff
+ >=sys-apps/sed-4
+ ${RDEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -66,7 +63,7 @@ src_compile() {
`use_enable cap` \
${myconf} || die "configure failed"
- if [ -n "`use static`" ] ; then
+ if use static ; then
# compile all modules statically, see Bug #27392
sed -i -e "s/link=no/link=static/g" \
-e "s/load=no/load=yes/g" \
@@ -102,7 +99,7 @@ src_install() {
dodoc ChangeLog* META-FAQ README INSTALL LICENCE config.modules
- if [ "`use doc`" ] ; then
+ if use doc ; then
dohtml Doc/*
insinto /usr/share/doc/${PF}
doins Doc/zsh{.dvi,_us.ps,_a4.ps}
@@ -122,7 +119,6 @@ pkg_preinst() {
}
pkg_postinst() {
-
einfo
einfo "If you want to enable Portage completion and Gentoo prompt,"
einfo "add"