summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-05-29 23:07:59 +0000
committerMike Frysinger <vapier@gentoo.org>2009-05-29 23:07:59 +0000
commit36323d38cece5ea71b67ed6a3c4ebf1f9ee4d57c (patch)
tree52c96445c440f45f4976ac3b11870927209ad0c7 /app-shells
parentUpdate repos to point to git #269705 by William Keaney. (diff)
downloadgentoo-2-36323d38cece5ea71b67ed6a3c4ebf1f9ee4d57c.tar.gz
gentoo-2-36323d38cece5ea71b67ed6a3c4ebf1f9ee4d57c.tar.bz2
gentoo-2-36323d38cece5ea71b67ed6a3c4ebf1f9ee4d57c.zip
Add dependency fix by Peter Alfredsen for parallel builds #267613.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog6
-rw-r--r--app-shells/bash/bash-4.0_p24.ebuild3
-rw-r--r--app-shells/bash/files/bash-4.0-parallel-build.patch20
3 files changed, 27 insertions, 2 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 1caaa459c7cf..86df5915ab2b 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.217 2009/05/17 20:59:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.218 2009/05/29 23:07:58 vapier Exp $
+
+ 29 May 2009; Mike Frysinger <vapier@gentoo.org> bash-4.0_p24.ebuild,
+ +files/bash-4.0-parallel-build.patch:
+ Add dependency fix by Peter Alfredsen for parallel builds #267613.
*bash-4.0_p24 (17 May 2009)
diff --git a/app-shells/bash/bash-4.0_p24.ebuild b/app-shells/bash/bash-4.0_p24.ebuild
index bbde94e00464..0c39b1cfd862 100644
--- a/app-shells/bash/bash-4.0_p24.ebuild
+++ b/app-shells/bash/bash-4.0_p24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0_p24.ebuild,v 1.1 2009/05/17 20:59:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0_p24.ebuild,v 1.2 2009/05/29 23:07:58 vapier Exp $
EAPI="1"
@@ -69,6 +69,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-3.2-parallel-build.patch #189671
epatch "${FILESDIR}"/${PN}-4.0-ldflags-for-build.patch #211947
epatch "${FILESDIR}"/${PN}-4.0-negative-return.patch
+ epatch "${FILESDIR}"/${PN}-4.0-parallel-build.patch #267613
# Log bash commands to syslog #91327
if use bashlogger ; then
ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
diff --git a/app-shells/bash/files/bash-4.0-parallel-build.patch b/app-shells/bash/files/bash-4.0-parallel-build.patch
new file mode 100644
index 000000000000..aed92c644429
--- /dev/null
+++ b/app-shells/bash/files/bash-4.0-parallel-build.patch
@@ -0,0 +1,20 @@
+http://bugs.gentoo.org/267613
+
+add missing dep
+
+patch by Peter Alfredsen
+
+--- bash-4.0/Makefile.in
++++ bash-4.0/Makefile.in
+@@ -1022,10 +1022,11 @@
+ subst.o: flags.h jobs.h siglist.h execute_cmd.h ${BASHINCDIR}/filecntl.h trap.h pathexp.h
+ subst.o: mailcheck.h input.h $(DEFSRC)/getopt.h $(DEFSRC)/common.h
+ subst.o: bashline.h bashhist.h ${GLOB_LIBSRC}/strmatch.h
+ subst.o: ${BASHINCDIR}/chartypes.h
+ subst.o: ${BASHINCDIR}/shmbutil.h
++subst.o: ${DEFDIR}/builtext.h
+ test.o: bashtypes.h ${BASHINCDIR}/posixstat.h ${BASHINCDIR}/filecntl.h
+ test.o: shell.h syntax.h config.h bashjmp.h ${BASHINCDIR}/posixjmp.h command.h ${BASHINCDIR}/stdc.h error.h
+ test.o: general.h xmalloc.h bashtypes.h variables.h arrayfunc.h conftypes.h array.h hashlib.h
+ test.o: quit.h ${BASHINCDIR}/maxpath.h unwind_prot.h dispose_cmd.h
+ test.o: make_cmd.h subst.h sig.h pathnames.h externs.h test.h