summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-09-05 18:30:54 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-09-05 18:30:54 +0000
commit3bd34af1d99fdbc9249dba146f1ae34ccd82fc9f (patch)
tree3bf9cb3e9a128233d65bcfc014cda0058be0efe0 /app-shells
parentremoved stable keywords, cuz that last commit also included the vh1 program f... (diff)
downloadgentoo-2-3bd34af1d99fdbc9249dba146f1ae34ccd82fc9f.tar.gz
gentoo-2-3bd34af1d99fdbc9249dba146f1ae34ccd82fc9f.tar.bz2
gentoo-2-3bd34af1d99fdbc9249dba146f1ae34ccd82fc9f.zip
stable bump, made whitespace repoman compliant
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/csh/ChangeLog6
-rw-r--r--app-shells/csh/Manifest4
-rw-r--r--app-shells/csh/csh-1.29-r2.ebuild36
3 files changed, 25 insertions, 21 deletions
diff --git a/app-shells/csh/ChangeLog b/app-shells/csh/ChangeLog
index 3ec275810939..0fc68814698d 100644
--- a/app-shells/csh/ChangeLog
+++ b/app-shells/csh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/csh
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.9 2003/07/31 12:47:40 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.10 2003/09/05 18:30:42 taviso Exp $
+
+ 05 Sep 2003; Tavis Ormandy <taviso@gentoo.org> csh-1.29-r2.ebuild:
+ stable on x86 and alpha.
+ made compliant with repoman's new whitespace syntax detection.
*csh-1.29-r2 (31 Jul 2003)
diff --git a/app-shells/csh/Manifest b/app-shells/csh/Manifest
index f90af1aca731..b2d16ed71a11 100644
--- a/app-shells/csh/Manifest
+++ b/app-shells/csh/Manifest
@@ -1,7 +1,7 @@
MD5 24974796f8712ee41f927e1e76ff5a70 csh-1.29.ebuild 3803
MD5 c9ed16e56100fb9511e19c7e00371705 csh-1.29-r1.ebuild 4060
-MD5 00775d652bc2397997cf9c53532771da csh-1.29-r2.ebuild 4335
-MD5 b52762964210239aa0de2efc9e1a0179 ChangeLog 1964
+MD5 5ecf5bef3e3cad1ca1311c11fe6fe8a0 csh-1.29-r2.ebuild 4314
+MD5 3019bbce2833e8d5a8fd63babed04252 ChangeLog 2127
MD5 ce0694a6af9197d929533e9d0dfcb706 metadata.xml 706
MD5 49c0a95e6881eb7e2932d149f62f0de2 files/mksignames.c 10722
MD5 49ee962115384f8a0acedfcf225fd27a files/digest-csh-1.29 148
diff --git a/app-shells/csh/csh-1.29-r2.ebuild b/app-shells/csh/csh-1.29-r2.ebuild
index b722ec8478bb..30c44af12767 100644
--- a/app-shells/csh/csh-1.29-r2.ebuild
+++ b/app-shells/csh/csh-1.29-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r2.ebuild,v 1.2 2003/07/31 12:47:41 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r2.ebuild,v 1.3 2003/09/05 18:30:42 taviso Exp $
inherit flag-o-matic eutils ccc
@@ -10,7 +10,7 @@ SRC_URI="http://cvs.gentoo.org/~taviso/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86 ~alpha"
+KEYWORDS="x86 alpha"
IUSE="static doc"
DEPEND="virtual/glibc
@@ -24,7 +24,7 @@ S=${WORKDIR}/src/bin/csh
src_unpack() {
# unpack the source tarball
unpack ${A}
-
+
# hide some BSDisms, mostly my work, got some hints from the
# debian project (they use an older OpenBSD csh, though).
cd ${S}; epatch ${FILESDIR}/linux-vs-bsd.diff || die "patching failed."
@@ -33,7 +33,7 @@ src_unpack() {
# patch contributed by splite <splite-gentoo@sigint.cs.purdue.edu>
# #24290
epatch ${FILESDIR}/retype-input.diff || die "patching failed."
-
+
# copy some required files over, from NetBSD
cd ${S}; cp ${WORKDIR}/printf.c \
@@ -41,8 +41,8 @@ src_unpack() {
${WORKDIR}/vis.c \
${FILESDIR}/dot.login \
${FILESDIR}/dot.cshrc \
- ${S}
-
+ ${S}
+
# this parses the output of the bash builtin `kill`
# and creates an array of signal names for csh.
@@ -53,16 +53,16 @@ src_unpack() {
printf "/* automatically generated during %s build */\n\n" ${PF} > ${S}/signames.h
printf "const char *const sys_signame[NSIG + 3] = {\n" >> ${S}/signames.h
printf "\t\"EXIT\",\t\n" >> ${S}/signames.h
-
+
let cnt++
-
+
for i in `kill -l`
do
let $((cnt++))%2 && continue
einfo " Adding ${i}..."
printf "\t\"%s\",\n" ${i} >> ${S}/signames.h
done
-
+
printf "\t\"DEBUG\",\n\t\"ERR\",\n\t(char *)0x0\n};\n\n" >> ${S}/signames.h
einfo "Making some final tweaks..."
@@ -85,20 +85,20 @@ src_compile() {
# maybe they dont warn on BSD, but _damn_.
export NOGCCERROR=1
-
+
# if csh is a users preferred shell, they may want
# a static binary to help on the event of fs emergency.
use static && append-ldflags -static
-
+
# pmake is a portage binary as well, so specify full path.
# if yours isnt in /usr/bin, you can set PMAKE_PATH.
einfo "Starting build..."
${PMAKE_PATH:-/usr/bin/}pmake || die "compile failed."
-
+
echo
- size csh
+ size csh
echo
-
+
# make the c shell guide
use doc && {
einfo "Making documentation..."
@@ -108,7 +108,7 @@ src_compile() {
cd ${S}
einfo "Making empty configuration files.."
- printf "#\n# System-wide .cshrc file for csh(1).\n\n" > csh.cshrc
+ printf "#\n# System-wide .cshrc file for csh(1).\n\n" > csh.cshrc
printf "#\n# System-wide .login file for csh(1).\n\n" > csh.login
printf "if ( -f /etc/csh.env ) source /etc/csh.env\n" >> csh.login
printf "#\n# System-wide .logout file for csh(1).\n\n" > csh.logout
@@ -117,12 +117,12 @@ src_compile() {
src_install() {
exeinto /bin
doexe csh
-
+
doman csh.1
-
+
use doc && dodoc USD.doc/paper.ps
dodoc dot.cshrc dot.login
-
+
insinto /etc
doins csh.cshrc csh.login csh.logout
}