summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2004-06-12 14:54:16 +0000
committerChristian Birchinger <joker@gentoo.org>2004-06-12 14:54:16 +0000
commit4c90f382c452436da4a9cbc7ce5357adc59b36f6 (patch)
treefaeb08f36c75a349d47eac4dd5cee2a026b2bd5f /app-shells
parentSecurity fixes (bug 53707) (Manifest recommit) (diff)
downloadgentoo-2-4c90f382c452436da4a9cbc7ce5357adc59b36f6.tar.gz
gentoo-2-4c90f382c452436da4a9cbc7ce5357adc59b36f6.tar.bz2
gentoo-2-4c90f382c452436da4a9cbc7ce5357adc59b36f6.zip
Added a new gentoo completion from http://sourceforge.net/projects/gentoo-bashcomp/
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog9
-rw-r--r--app-shells/bash-completion/bash-completion-20040526-r1.ebuild74
-rw-r--r--app-shells/bash-completion/files/digest-bash-completion-20040526-r12
3 files changed, 84 insertions, 1 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index e8be18e6cd67..3f748a22275c 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.62 2004/05/30 05:59:43 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.63 2004/06/12 14:54:16 joker Exp $
+
+*bash-completion-20040526-r1 (12 Jun 2004)
+
+ 12 Jun 2004; Christian Birchinger <joker@gentoo.org>
+ bash-completion-20040526-r1.ebuild:
+ Added a new gentoo completion from
+ http://sourceforge.net/projects/gentoo-bashcomp/
29 May 2004; Michael Sterrett <mr_bones_@gentoo.org>
bash-completion-20040331-r1.ebuild, bash-completion-20040526.ebuild:
diff --git a/app-shells/bash-completion/bash-completion-20040526-r1.ebuild b/app-shells/bash-completion/bash-completion-20040526-r1.ebuild
new file mode 100644
index 000000000000..d0a3ae51fa14
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20040526-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20040526-r1.ebuild,v 1.1 2004/06/12 14:54:16 joker Exp $
+
+GENCOMP_VERS="1.0_beta"
+
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)."
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2
+ mirror://sourceforge/gentoo-bashcomp/gentoo-bashcomp-${GENCOMP_VERS}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~s390"
+
+S=${WORKDIR}/${PN/-/_}
+
+DEPEND="app-arch/tar
+ app-arch/bzip2"
+
+RDEPEND=">=app-shells/bash-2.05a"
+
+src_install() {
+ insinto /etc
+ doins bash_completion
+
+ insinto /usr/share/bash-completion
+ doins contrib/*
+
+ insinto /etc/profile.d
+ doins ${FILESDIR}/bash-completion
+
+ dodoc Changelog README
+
+ cd ${WORKDIR}/gentoo-bashcomp-${GENCOMP_VERS}
+ insinto /etc/bash_completion.d
+ doins src/gentoo
+
+ docinto gentoo
+ dodoc AUTHORS NEWS TODO
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "activate completion support in your bash:"
+ einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
+ einfo
+ einfo "Additional complete functions can be enabled by symlinking them from"
+ einfo "/usr/share/bash-completion to /etc/bash_completion.d"
+
+ if [ -f /etc/bash_completion.d/gentoo.completion ]
+ then
+ echo
+ ewarn "The file 'gentoo.completion' in '/etc/bash_completion.d/' has been"
+ ewarn "replaced with 'gentoo'. Remove gentoo.completion to avoid problems."
+ fi
+
+ local bcfile moved
+ for bcfile in /etc/bash_completion.d/{unrar,harbour,isql,larch,lilypond,p4,ri}
+ do
+
+ [ -f "${bcfile}" -a ! -L "${bcfile}" ] && moved="${bcfile##*/} ${moved}"
+ done
+
+ if [ -n "${moved}" ]
+ then
+ echo
+ ewarn "The contrib files: ${moved}"
+ ewarn "have been moved to /usr/share/bash-completion. Please DELETE"
+ ewarn "those old files in /etc/bash_completion.d and create symlinks."
+ fi
+ echo
+}
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20040526-r1 b/app-shells/bash-completion/files/digest-bash-completion-20040526-r1
new file mode 100644
index 000000000000..1172914ca206
--- /dev/null
+++ b/app-shells/bash-completion/files/digest-bash-completion-20040526-r1
@@ -0,0 +1,2 @@
+MD5 026f1a22f8a32c6f06872c718a65a39b bash-completion-20040526.tar.bz2 81773
+MD5 8776015ce9bbf116e34a149ef0846c85 gentoo-bashcomp-1.0_beta.tar.gz 13346