summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-11 23:05:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-11 23:05:10 +0000
commit4e4f4e778918ca566f9299f6034ca638d3b6aaba (patch)
tree349cdf20e0afa5d43eefbc1a210d327cf6867620 /app-shells
parentversion bump, cleanup (diff)
downloadgentoo-2-4e4f4e778918ca566f9299f6034ca638d3b6aaba.tar.gz
gentoo-2-4e4f4e778918ca566f9299f6034ca638d3b6aaba.tar.bz2
gentoo-2-4e4f4e778918ca566f9299f6034ca638d3b6aaba.zip
Use insinto/doins rather than dodir/cp (fix possible issues with permissions on the files), and also make sure not to install the Makefile.am/in pairs.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog7
-rw-r--r--app-shells/bash-completion/bash-completion-1.3.ebuild15
2 files changed, 14 insertions, 8 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 57c7e4dd6452..0773e6409123 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash-completion
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.232 2011/03/31 17:33:54 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.233 2011/04/11 23:05:10 flameeyes Exp $
+
+ 11 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ bash-completion-1.3.ebuild:
+ Use insinto/doins rather than dodir/cp (fix possible issues with permissions
+ on the files), and also make sure not to install the Makefile.am/in pairs.
31 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org>
bash-completion-1.3.ebuild:
diff --git a/app-shells/bash-completion/bash-completion-1.3.ebuild b/app-shells/bash-completion/bash-completion-1.3.ebuild
index 68018187c68a..97eda02ba0ab 100644
--- a/app-shells/bash-completion/bash-completion-1.3.ebuild
+++ b/app-shells/bash-completion/bash-completion-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-1.3.ebuild,v 1.6 2011/03/31 17:33:54 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-1.3.ebuild,v 1.7 2011/04/11 23:05:10 flameeyes Exp $
EAPI=3
inherit prefix
@@ -23,6 +23,8 @@ PDEPEND="app-shells/gentoo-bashcomp"
src_prepare() {
cp "${FILESDIR}"/bash-completion.sh-gentoo-1.2 "${T}"/bash-completion.sh || die
eprefixify "${T}"/bash-completion.sh
+
+ find "${S}"/completions -name 'Makefile*' -delete
}
src_configure() { :; } # no-op
@@ -30,14 +32,13 @@ src_compile() { :; } # no-op
src_install() {
# Gentoo specific bash-completion.sh file.
- dodir /etc/profile.d
- cp "${T}"/bash-completion.sh \
- "${ED}"/etc/profile.d/bash-completion.sh || die "cp failed"
+ insinto /etc/profile.d
+ doins "${T}"/bash-completion.sh || die
# All files from contrib/ in source package get installed
- dodir /usr/share/bash-completion
- cp -r "${S}"/completions/* "${ED}"/usr/share/bash-completion/ \
- || die "installation failed to move files"
+ insinto /usr/share/bash-completion
+ doins -r "${S}"/completions/* || die
+
awk -v D="$ED" '
BEGIN { out=".pre" }
/^# A lot of the following one-liners/ { out="base" }