summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-03 02:53:27 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-03 02:53:27 +0000
commit79e061fedd6c39da9134e458953ea9d51a0908fd (patch)
tree2fd8d6010f3d56fa756202a051c0f7ec179ccf8f /app-shells
parentadd deplib checking to fix things like glib-1.2 (diff)
downloadgentoo-2-79e061fedd6c39da9134e458953ea9d51a0908fd.tar.gz
gentoo-2-79e061fedd6c39da9134e458953ea9d51a0908fd.tar.bz2
gentoo-2-79e061fedd6c39da9134e458953ea9d51a0908fd.zip
m68k love
(Portage version: 2.0.51.21)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-2.05b-r9.ebuild14
-rw-r--r--app-shells/bash/bash-3.0-r11.ebuild4
2 files changed, 8 insertions, 10 deletions
diff --git a/app-shells/bash/bash-2.05b-r9.ebuild b/app-shells/bash/bash-2.05b-r9.ebuild
index 1535d4106ee9..ef6b3c1249bf 100644
--- a/app-shells/bash/bash-2.05b-r9.ebuild
+++ b/app-shells/bash/bash-2.05b-r9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r9.ebuild,v 1.28 2005/01/01 15:56:24 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r9.ebuild,v 1.29 2005/05/03 02:53:27 vapier Exp $
-inherit eutils flag-o-matic gnuconfig gcc
+inherit eutils flag-o-matic toolchain-funcs
# Official patches
PLEVEL="x002 x003 x004 x005 x006 x007"
@@ -15,8 +15,8 @@ SRC_URI="mirror://gnu/bash/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="nls build uclibc"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE="nls build minimal"
# we link statically with ncurses
DEPEND=">=sys-libs/ncurses-5.2-r2"
@@ -61,8 +61,6 @@ src_unpack() {
# especially easy with 2.6 kernels.
echo '#define PGRP_PIPE 1' >> config-bot.h
- gnuconfig_update
-
sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
}
@@ -85,7 +83,7 @@ src_compile() {
use nls || myconf="${myconf} --disable-nls"
echo 'int main(){}' > ${T}/term-test.c
- if ! $(gcc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
+ if ! $(tc-getCC) -static -lncurses ${T}/term-test.c 2> /dev/null ; then
export bash_cv_termcap_lib=gnutermcap
else
export bash_cv_termcap_lib=libcurses
@@ -109,7 +107,7 @@ src_install() {
dosym bash /bin/sh
dosym bash /bin/rbash
- use uclibc && rm -f ${D}/usr/bin/bashbug ${D}/usr/share/man*/bashbug*
+ use minimal && rm -f ${D}/usr/bin/bashbug ${D}/usr/share/man*/bashbug*
use build \
&& rm -rf ${D}/usr \
diff --git a/app-shells/bash/bash-3.0-r11.ebuild b/app-shells/bash/bash-3.0-r11.ebuild
index 9ee2a8ea7520..9f2fae21f7db 100644
--- a/app-shells/bash/bash-3.0-r11.ebuild
+++ b/app-shells/bash/bash-3.0-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r11.ebuild,v 1.4 2005/04/30 07:33:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r11.ebuild,v 1.5 2005/05/03 02:53:27 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -23,7 +23,7 @@ SRC_URI="mirror://gnu/bash/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="nls build"
# we link statically with ncurses