summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-06-13 02:48:48 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-06-13 02:48:48 +0000
commit88d6b414a74ce182b97a6ab82823817de9ecaee2 (patch)
tree4ec1ca2fb61645bec0282fed7289cb428cd5f2de /app-shells
parentVersion bump. Includes support for rc-service (bug 227139), layman (bug 22427... (diff)
downloadgentoo-2-88d6b414a74ce182b97a6ab82823817de9ecaee2.tar.gz
gentoo-2-88d6b414a74ce182b97a6ab82823817de9ecaee2.tar.bz2
gentoo-2-88d6b414a74ce182b97a6ab82823817de9ecaee2.zip
Add upstream patch for buggy chsh behavior, bug 271521
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog9
-rw-r--r--app-shells/bash-completion/bash-completion-1.0-r5.ebuild (renamed from app-shells/bash-completion/bash-completion-1.0-r4.ebuild)4
-rw-r--r--app-shells/bash-completion/files/bash-completion-1.0-shadow-compat.patch30
3 files changed, 41 insertions, 2 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index 5806563cb89e..c715879a02dd 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/bash-completion
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.181 2009/06/03 22:23:07 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.182 2009/06/13 02:48:48 darkside Exp $
+
+*bash-completion-1.0-r5 (13 Jun 2009)
+
+ 13 Jun 2009; Jeremy Olexa <darkside@gentoo.org>
+ +files/bash-completion-1.0-shadow-compat.patch,
+ -bash-completion-1.0-r4.ebuild, +bash-completion-1.0-r5.ebuild:
+ Add upstream patch for buggy chsh behavior, bug 271521
*bash-completion-1.0-r4 (03 Jun 2009)
diff --git a/app-shells/bash-completion/bash-completion-1.0-r4.ebuild b/app-shells/bash-completion/bash-completion-1.0-r5.ebuild
index e54491647d6b..0e1eeed155d0 100644
--- a/app-shells/bash-completion/bash-completion-1.0-r4.ebuild
+++ b/app-shells/bash-completion/bash-completion-1.0-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-1.0-r4.ebuild,v 1.1 2009/06/03 22:23:07 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-1.0-r5.ebuild,v 1.1 2009/06/13 02:48:48 darkside Exp $
EAPI="2"
@@ -31,6 +31,8 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-1.0-bash4.patch"
# module-init-tools-3.8 changed locations
sed -i 's:/sbin/lsmod:/bin/lsmod:' bash_completion
+ # Fixed in next release
+ epatch "${FILESDIR}/${PN}-1.0-shadow-compat.patch"
}
diff --git a/app-shells/bash-completion/files/bash-completion-1.0-shadow-compat.patch b/app-shells/bash-completion/files/bash-completion-1.0-shadow-compat.patch
new file mode 100644
index 000000000000..55a9781ebd30
--- /dev/null
+++ b/app-shells/bash-completion/files/bash-completion-1.0-shadow-compat.patch
@@ -0,0 +1,30 @@
+commit 86574164df810ecbd53ae841c15b38e5b06dc068
+Author: Ville Skyttä <ville.skytta@iki.fi>
+Date: Tue Apr 14 00:46:12 2009 +0300
+
+ Always use /etc/shells for chsh -s completion, don't complete on
+ comment lines in it.
+
+ Invoking chsh -l does unwanted things on some systems, such as FreeBSD.
+
+diff --git a/bash_completion b/bash_completion
+index e50da69..6f84e31 100644
+--- a/bash_completion
++++ b/bash_completion
+@@ -2569,13 +2569,10 @@ _chsh()
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ if [ "$prev" = "-s" ]; then
+- if [ -f /etc/debian_version ]; then
+- COMPREPLY=( $( </etc/shells ) )
+- else
+- COMPREPLY=( $( chsh -l | grep "^$cur" ) )
+- fi
++ COMPREPLY=( $( compgen -W '$( grep "^[[:space:]]*/" \
++ /etc/shells 2>/dev/null )' -- $cur ) )
+ else
+- COMPREPLY=( $( compgen -u -- $cur ) )
++ COMPREPLY=( $( compgen -u -- $cur ) )
+ fi
+
+ return 0