summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2004-07-04 15:12:02 +0000
committerChristian Birchinger <joker@gentoo.org>2004-07-04 15:12:02 +0000
commit923ed8e03fd076407e19b0647b4ab020e7ac6908 (patch)
tree2088cfb965c430cad59629b845db5ca7cf1eaa97 /app-shells
parentVersion bumped. Ebuild submitted by Michael Kohl <citizen428@cargal.org>, clo... (diff)
downloadgentoo-2-923ed8e03fd076407e19b0647b4ab020e7ac6908.tar.gz
gentoo-2-923ed8e03fd076407e19b0647b4ab020e7ac6908.tar.bz2
gentoo-2-923ed8e03fd076407e19b0647b4ab020e7ac6908.zip
Version bump
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog8
-rw-r--r--app-shells/bash-completion/bash-completion-20040704.ebuild74
-rw-r--r--app-shells/bash-completion/files/digest-bash-completion-200407042
3 files changed, 83 insertions, 1 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index b39fc47c9548..2d5ebd04566e 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.66 2004/07/01 11:54:30 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.67 2004/07/04 15:12:02 joker Exp $
+
+*bash-completion-20040704 (04 Jul 2004)
+
+ 04 Jul 2004; Christian Birchinger <joker@gentoo.org>
+ +bash-completion-20040704.ebuild:
+ Version bump
01 Jul 2004; Christian Birchinger <joker@gentoo.org>
bash-completion-20040526-r2.ebuild:
diff --git a/app-shells/bash-completion/bash-completion-20040704.ebuild b/app-shells/bash-completion/bash-completion-20040704.ebuild
new file mode 100644
index 000000000000..62b9d1d55d01
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20040704.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20040704.ebuild,v 1.1 2004/07/04 15:12:02 joker Exp $
+
+GENCOMP_VERS="1.0_beta"
+
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)"
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2
+ mirror://sourceforge/gentoo-bashcomp/gentoo-bashcomp-${GENCOMP_VERS}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~s390"
+IUSE=""
+
+DEPEND="app-arch/tar
+ app-arch/bzip2"
+RDEPEND=">=app-shells/bash-2.05a"
+
+S=${WORKDIR}/${PN/-/_}
+
+src_install() {
+ insinto /etc
+ doins bash_completion
+
+ insinto /usr/share/bash-completion
+ doins contrib/*
+
+ exeinto /etc/profile.d
+ doexe ${FILESDIR}/bash-completion
+
+ dodoc Changelog README
+
+ cd ${WORKDIR}/gentoo-bashcomp-${GENCOMP_VERS}
+ insinto /etc/bash_completion.d
+ doins src/gentoo
+
+ docinto gentoo
+ dodoc AUTHORS NEWS TODO
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "activate completion support in your bash:"
+ einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
+ einfo
+ einfo "Additional complete functions can be enabled by symlinking them from"
+ einfo "/usr/share/bash-completion to /etc/bash_completion.d"
+
+ if [ -f ${ROOT}/etc/bash_completion.d/gentoo.completion ]
+ then
+ echo
+ ewarn "The file 'gentoo.completion' in '/etc/bash_completion.d/' has been"
+ ewarn "replaced with 'gentoo'. Remove gentoo.completion to avoid problems."
+ fi
+
+ local bcfile moved
+ for bcfile in ${ROOT}/etc/bash_completion.d/{unrar,harbour,isql,larch,lilypond,p4,ri}
+ do
+
+ [ -f "${bcfile}" -a ! -L "${bcfile}" ] && moved="${bcfile##*/} ${moved}"
+ done
+
+ if [ -n "${moved}" ]
+ then
+ echo
+ ewarn "The contrib files: ${moved}"
+ ewarn "have been moved to /usr/share/bash-completion. Please DELETE"
+ ewarn "those old files in /etc/bash_completion.d and create symlinks."
+ fi
+ echo
+}
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20040704 b/app-shells/bash-completion/files/digest-bash-completion-20040704
new file mode 100644
index 000000000000..71d744fd8807
--- /dev/null
+++ b/app-shells/bash-completion/files/digest-bash-completion-20040704
@@ -0,0 +1,2 @@
+MD5 1a0991f4ff892ed6fed1c6cf39ee7022 bash-completion-20040704.tar.bz2 82544
+MD5 8776015ce9bbf116e34a149ef0846c85 gentoo-bashcomp-1.0_beta.tar.gz 13346