summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-04-09 13:24:07 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-04-09 13:24:07 +0000
commitd17a94b0b4cdbec96e63c190dc28f471725bbaac (patch)
tree3139bc746d6ea6d3f68cd4864de29597d5b4f96b /app-shells
parentSparc stable, Bug #265523. (diff)
downloadgentoo-2-d17a94b0b4cdbec96e63c190dc28f471725bbaac.tar.gz
gentoo-2-d17a94b0b4cdbec96e63c190dc28f471725bbaac.tar.bz2
gentoo-2-d17a94b0b4cdbec96e63c190dc28f471725bbaac.zip
Add patch for bash4, see bug 262246
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog9
-rw-r--r--app-shells/bash-completion/bash-completion-1.0-r1.ebuild (renamed from app-shells/bash-completion/bash-completion-1.0.ebuild)3
-rw-r--r--app-shells/bash-completion/files/bash-completion-1.0-bash4.patch28
3 files changed, 38 insertions, 2 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index aa41250289f2..c683b442742c 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.166 2009/04/09 05:27:58 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.167 2009/04/09 13:24:07 darkside Exp $
+
+*bash-completion-1.0-r1 (09 Apr 2009)
+
+ 09 Apr 2009; Jeremy Olexa <darkside@gentoo.org>
+ +files/bash-completion-1.0-bash4.patch, -bash-completion-1.0.ebuild,
+ +bash-completion-1.0-r1.ebuild:
+ Add patch for bash4, see bug 262246
09 Apr 2009; Jeremy Olexa <darkside@gentoo.org>
bash-completion-1.0.ebuild, bash-completion-20081219-r1.ebuild:
diff --git a/app-shells/bash-completion/bash-completion-1.0.ebuild b/app-shells/bash-completion/bash-completion-1.0-r1.ebuild
index 1a5ba58953bf..c4a9cf6845ee 100644
--- a/app-shells/bash-completion/bash-completion-1.0.ebuild
+++ b/app-shells/bash-completion/bash-completion-1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-1.0.ebuild,v 1.3 2009/04/09 05:27:58 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-1.0-r1.ebuild,v 1.1 2009/04/09 13:24:07 darkside Exp $
EAPI="2"
@@ -27,6 +27,7 @@ PDEPEND="app-shells/gentoo-bashcomp"
src_prepare() {
epatch "${FILESDIR}/${PN}-1.0-gentoo.patch"
+ epatch "${FILESDIR}/${PN}-1.0-bash4.patch"
}
src_install() {
diff --git a/app-shells/bash-completion/files/bash-completion-1.0-bash4.patch b/app-shells/bash-completion/files/bash-completion-1.0-bash4.patch
new file mode 100644
index 000000000000..85f5794b5394
--- /dev/null
+++ b/app-shells/bash-completion/files/bash-completion-1.0-bash4.patch
@@ -0,0 +1,28 @@
+commit 1421e55aac075e13491cd212b796bdd453214a2c
+Author: Mike Kelly <pioto@pioto.org>
+Date: Thu Apr 2 11:16:46 2009 -0400
+
+ Fix _filedir on bash 4.
+
+ We don't need to double-quote things for compgen w/ bash 4. Just putting
+ each file in double quotes is sufficient.
+
+ See: http://lists.gnu.org/archive/html/bug-bash/2009-03/msg00155.html
+
+diff --git a/bash_completion b/bash_completion
+index 0246cd8..4d21cf8 100644
+--- a/bash_completion
++++ b/bash_completion
+@@ -209,6 +209,12 @@ quote()
+ # results in the original argument
+ quote_readline()
+ {
++ if [[ "${BASH_VERSINFO[0]}" -ge 4 ]] ; then
++ # This function isn't really necessary on bash 4
++ # See: http://lists.gnu.org/archive/html/bug-bash/2009-03/msg00155.html
++ echo "${1}"
++ return
++ fi
+ local t="${1//\\/\\\\}"
+ echo \'${t//\'/\'\\\'\'}\' #'# Help vim syntax highlighting
+ }