summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-28 22:03:55 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-28 22:03:55 +0000
commite4483f987f471da7f25cabc3b7123f9dc23cafde (patch)
tree4a54ec1d993f73c695334556f909184529177355 /app-shells
parentadd sed-4 dep (Manifest recommit) (diff)
downloadgentoo-2-e4483f987f471da7f25cabc3b7123f9dc23cafde.tar.gz
gentoo-2-e4483f987f471da7f25cabc3b7123f9dc23cafde.tar.bz2
gentoo-2-e4483f987f471da7f25cabc3b7123f9dc23cafde.zip
glibc -> libc, add sed-4 dep
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/csh/ChangeLog6
-rw-r--r--app-shells/csh/csh-1.29-r2.ebuild15
-rw-r--r--app-shells/csh/csh-1.29-r3.ebuild15
3 files changed, 21 insertions, 15 deletions
diff --git a/app-shells/csh/ChangeLog b/app-shells/csh/ChangeLog
index abb970334230..79b94c937481 100644
--- a/app-shells/csh/ChangeLog
+++ b/app-shells/csh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/csh
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.20 2004/06/24 22:23:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/ChangeLog,v 1.21 2004/06/28 22:03:55 agriffis Exp $
+
+ 28 Jun 2004; Aron Griffis <agriffis@gentoo.org> csh-1.29-r2.ebuild,
+ csh-1.29-r3.ebuild:
+ glibc -> libc, add sed-4 dep
15 May 2004; Danny van Dyk <kugelfang@gentoo.org> csh-1.29-r3.ebuild:
Marked ~amd64.
diff --git a/app-shells/csh/csh-1.29-r2.ebuild b/app-shells/csh/csh-1.29-r2.ebuild
index 797e0a745e49..2a2ddf6ca23b 100644
--- a/app-shells/csh/csh-1.29-r2.ebuild
+++ b/app-shells/csh/csh-1.29-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r2.ebuild,v 1.10 2004/06/24 22:23:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r2.ebuild,v 1.11 2004/06/28 22:03:55 agriffis Exp $
inherit flag-o-matic eutils ccc
@@ -13,8 +13,9 @@ SLOT="0"
KEYWORDS="x86 alpha ia64"
IUSE="static doc"
-DEPEND="sys-devel/pmake !app-shells/tcsh"
-RDEPEND="virtual/glibc"
+DEPEND="sys-devel/pmake !app-shells/tcsh
+ >=sys-apps/sed-4"
+RDEPEND="virtual/libc"
S=${WORKDIR}/src/bin/csh
@@ -126,16 +127,16 @@ src_install() {
pkg_postinst() {
echo
- use doc && {
+ if use doc; then
einfo "An Introduction to the C shell by Bill Joy, a "
einfo "postscript document included with this shell has"
einfo "been installed in /usr/share/doc/${PF}, if you are new"
einfo "to the C shell, you may find it interesting."
- } || {
- einfo "You didnt have the \`doc\` use flag set, the"
+ else
+ einfo "You don't have USE=doc, so the"
einfo "postscript document \"An Introduction to the C"
einfo "shell by Bill Joy\" was not installed."
- }
+ fi
echo
einfo "Example login scripts have been installed in /usr/share/doc/${PF}."
einfo "You can install a simple dot.cshrc like this:"
diff --git a/app-shells/csh/csh-1.29-r3.ebuild b/app-shells/csh/csh-1.29-r3.ebuild
index cbe381fa5a82..832afd82a2cc 100644
--- a/app-shells/csh/csh-1.29-r3.ebuild
+++ b/app-shells/csh/csh-1.29-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r3.ebuild,v 1.7 2004/06/24 22:23:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r3.ebuild,v 1.8 2004/06/28 22:03:55 agriffis Exp $
inherit flag-o-matic eutils ccc
@@ -13,8 +13,9 @@ SLOT="0"
KEYWORDS="x86 alpha arm ~amd64 ia64"
IUSE="static doc"
-DEPEND="sys-devel/pmake !app-shells/tcsh"
-RDEPEND="virtual/glibc"
+DEPEND="sys-devel/pmake !app-shells/tcsh
+ >=sys-apps/sed-4"
+RDEPEND="virtual/libc"
S=${WORKDIR}/src/bin/csh
@@ -126,16 +127,16 @@ src_install() {
pkg_postinst() {
echo
- use doc && {
+ if use doc; then
einfo "An Introduction to the C shell by Bill Joy, a "
einfo "postscript document included with this shell has"
einfo "been installed in /usr/share/doc/${PF}, if you are new"
einfo "to the C shell, you may find it interesting."
- } || {
- einfo "You didnt have the \`doc\` use flag set, the"
+ else
+ einfo "You don't have USE=doc, so the"
einfo "postscript document \"An Introduction to the C"
einfo "shell by Bill Joy\" was not installed."
- }
+ fi
echo
einfo "Example login scripts have been installed in /usr/share/doc/${PF}."
einfo "You can install a simple dot.cshrc like this:"