summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-12-14 17:00:57 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-12-14 17:00:57 +0000
commit389ce84b53cf3c0433a1d1c7d70b6dbdacbfa688 (patch)
tree7344471ff2bec3014bf89db693a70a6092d1932d /app-text/a2ps/a2ps-4.14-r1.ebuild
parentFilter -O* on arm/ia64/sparc (bug #296901). (diff)
downloadgentoo-2-389ce84b53cf3c0433a1d1c7d70b6dbdacbfa688.tar.gz
gentoo-2-389ce84b53cf3c0433a1d1c7d70b6dbdacbfa688.tar.bz2
gentoo-2-389ce84b53cf3c0433a1d1c7d70b6dbdacbfa688.zip
Added RESTRICT="test", bug #171002. Replaced cjk USE flag to linguas_ja. Added a patch for obstack.h, bug #269638. clean up.
(Portage version: 2.1.7.13/cvs/Linux x86_64)
Diffstat (limited to 'app-text/a2ps/a2ps-4.14-r1.ebuild')
-rw-r--r--app-text/a2ps/a2ps-4.14-r1.ebuild112
1 files changed, 112 insertions, 0 deletions
diff --git a/app-text/a2ps/a2ps-4.14-r1.ebuild b/app-text/a2ps/a2ps-4.14-r1.ebuild
new file mode 100644
index 000000000000..ba65004c05f9
--- /dev/null
+++ b/app-text/a2ps/a2ps-4.14-r1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.14-r1.ebuild,v 1.1 2009/12/14 17:00:57 matsuu Exp $
+
+inherit eutils autotools elisp-common
+
+DESCRIPTION="Any to PostScript filter"
+HOMEPAGE="http://www.inf.enst.fr/~demaille/a2ps/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ linguas_ja? ( mirror://gentoo/${P}-ja_nls.patch.gz )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs nls latex vanilla userland_BSD userland_GNU linguas_ja"
+
+RESTRICT="test"
+
+DEPEND=">=dev-util/gperf-2.7.2
+ || ( >=dev-util/yacc-1.9.1 sys-devel/bison )
+ virtual/ghostscript
+ >=app-text/psutils-1.17
+ emacs? ( virtual/emacs )
+ latex? ( virtual/latex-base )
+ nls? ( sys-devel/gettext )"
+RDEPEND="virtual/ghostscript
+ app-text/wdiff
+ userland_GNU? ( || ( >=sys-apps/coreutils-6.10-r1 sys-apps/mktemp ) )
+ userland_BSD? ( sys-freebsd/freebsd-ubin )
+ >=app-text/psutils-1.17
+ emacs? ( virtual/emacs )
+ latex? ( virtual/latex-base )
+ nls? ( virtual/libintl )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+S="${WORKDIR}/${PN}-${PV:0:4}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-4.13c-locale-gentoo.diff"
+ # this will break
+ #epatch "${FILESDIR}/${PN}-4.13c-stdarg.patch"
+ use vanilla || epatch "${FILESDIR}/${PN}-4.13-stdout.diff"
+ use linguas_ja && epatch "${DISTDIR}/${P}-ja_nls.patch.gz"
+
+ # fix fnmatch replacement, bug #134546
+ epatch "${FILESDIR}/${PN}-4.13c-fnmatch-replacement.patch"
+
+ # bug #122026
+ epatch "${FILESDIR}/${P}-psset.patch"
+
+ # fix emacs printing, bug #114627
+ epatch "${FILESDIR}/a2ps-4.13c-emacs.patch"
+
+ # fix chmod error, #167670
+ epatch "${FILESDIR}/a2ps-4.13-manpage-chmod.patch"
+
+ # add configure check for mempcpy, bug 216588
+ epatch "${FILESDIR}/${P}-check-mempcpy.patch"
+
+ # fix compilation error due to invalid stpcpy() prototype, bug 216588
+ epatch "${FILESDIR}/${P}-fix-stpcpy-proto.patch"
+
+ # fix compilation error due to obstack.h issue, bug 269638
+ epatch "${FILESDIR}/${P}-ptrdiff_t.patch"
+
+ eautoreconf
+}
+
+src_compile() {
+ local myconf="COM_netscape=no COM_acroread=no"
+
+ if ! use emacs ; then
+ myconf="${myconf} EMACS=no"
+ fi
+
+ if ! use latex ; then
+ myconf="${myconf} COM_latex=no"
+ fi
+
+ export LANG=C LC_ALL=C
+
+ econf \
+ --sysconfdir=/etc/a2ps \
+ $(use_enable nls) \
+ ${myconf} || die "econf failed"
+
+ # parallel make b0rked
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ fi
+
+ dodoc ANNOUNCE AUTHORS ChangeLog FAQ NEWS README* THANKS TODO
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}