summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2005-08-30 18:51:45 +0000
committerLuis Medinas <metalgod@gentoo.org>2005-08-30 18:51:45 +0000
commit687a3d46dfda8c8894b34be1e5cb84fe26ac4116 (patch)
treeb3a38d113939c4ec7b9296a99dcc13e9d2698769 /app-text/a2ps/files
parentStable on sparc (diff)
downloadgentoo-2-687a3d46dfda8c8894b34be1e5cb84fe26ac4116.tar.gz
gentoo-2-687a3d46dfda8c8894b34be1e5cb84fe26ac4116.tar.bz2
gentoo-2-687a3d46dfda8c8894b34be1e5cb84fe26ac4116.zip
Added a new patch to fix build on AMD64 thanks to Holger Thon <ht_gentoo04@arcor.de>. Clean up the ebuild
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-text/a2ps/files')
-rw-r--r--app-text/a2ps/files/a2ps-4.13c-stdarg.patch74
-rw-r--r--app-text/a2ps/files/digest-a2ps-4.13c-r32
2 files changed, 76 insertions, 0 deletions
diff --git a/app-text/a2ps/files/a2ps-4.13c-stdarg.patch b/app-text/a2ps/files/a2ps-4.13c-stdarg.patch
new file mode 100644
index 000000000000..4ff12125836a
--- /dev/null
+++ b/app-text/a2ps/files/a2ps-4.13c-stdarg.patch
@@ -0,0 +1,74 @@
+--- a2ps-4.13-orig/configure.in 2005-08-14 14:13:42.000000000 +0200
++++ a2ps-4.13/configure.in 2005-08-14 14:18:20.000000000 +0200
+@@ -157,6 +157,22 @@
+ [Define to rpl_fnmatch if the replacement function should be used.])
+ fi
+
++# Check for C99 va_copy
++AC_CACHE_CHECK([
++ AC_TRY_LINK([#include <stdarg.h>],
++ [
++ va_list va1, va2;
++
++ va_copy(va2, va1);
++ va_end(va2);
++ ],
++ [ac_cv_va_copy="yes"],[ac_cv_va_copy="no"]
++ )
++])
++if test "x$ac_cv_va_copy"="xyes"; then
++ AC_DEFINE(HAVE_VA_COPY,1,[Define to 1 if C99 va_copy function should be used])
++fi
++
+ # Needed checks for tinyterm.[ch]
+ ad_TINYTERM_CHECKS
+
+--- a2ps-4.13-orig/lib/printlen.c 2002-03-04 19:46:25.000000000 +0100
++++ a2ps-4.13/lib/printlen.c 2005-08-14 14:29:08.000000000 +0200
+@@ -27,15 +27,24 @@
+
+ unsigned long strtoul ();
+
++#if !defined(HAVE_VA_COPY)
+ static int
+ int_printflen (const char *format, va_list *args)
++#else
++static int
++int_printflen (const char *format, va_list args)
++#endif
+ {
+ const char *cp;
+ int total_width = 0;
+ int width = 0;
+ va_list ap;
+
++#ifndef HAVE_VA_COPY
+ memcpy (&ap, args, sizeof (va_list));
++#else
++ va_copy(ap, args);
++#endif
+
+ for (cp = format ; *cp ; cp++)
+ {
+@@ -93,13 +102,21 @@
+ }
+ }
+ }
++
++#ifdef HAVE_VA_COPY
++ va_end(ap);
++#endif
+ return total_width;
+ }
+
+ int
+ vprintflen (const char *format, va_list args)
+ {
++#if !defined(HAVE_VA_COPY)
+ return int_printflen (format, &args);
++#else
++ return int_printflen (format, args);
++#endif
+ }
+
+ int
diff --git a/app-text/a2ps/files/digest-a2ps-4.13c-r3 b/app-text/a2ps/files/digest-a2ps-4.13c-r3
new file mode 100644
index 000000000000..4abfd89450cb
--- /dev/null
+++ b/app-text/a2ps/files/digest-a2ps-4.13c-r3
@@ -0,0 +1,2 @@
+MD5 97164e84ba911e4604155507e0893669 a2ps-4.13c.tar.gz 2395885
+MD5 e315466f75d99c0c1ca563d82f2ace2e a2ps-4.13c-ja_nls.patch.gz 38189