summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 20:56:25 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 20:56:25 +0000
commit6108d13ce7958f9444c85dd78149590514ff16ff (patch)
treed33090314c27a4e2996a83678ebc86520dc10d57 /app-text/antiword
parentInitial import, #252981 (diff)
downloadgentoo-2-6108d13ce7958f9444c85dd78149590514ff16ff.tar.gz
gentoo-2-6108d13ce7958f9444c85dd78149590514ff16ff.tar.bz2
gentoo-2-6108d13ce7958f9444c85dd78149590514ff16ff.zip
QA: Respect CC (bug 243708), respect LDFLAGS
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-text/antiword')
-rw-r--r--app-text/antiword/ChangeLog5
-rw-r--r--app-text/antiword/antiword-0.37.ebuild14
2 files changed, 12 insertions, 7 deletions
diff --git a/app-text/antiword/ChangeLog b/app-text/antiword/ChangeLog
index f2ca9d267b04..38abbd03db75 100644
--- a/app-text/antiword/ChangeLog
+++ b/app-text/antiword/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/antiword
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/ChangeLog,v 1.38 2008/08/16 17:03:07 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/ChangeLog,v 1.39 2008/12/30 20:56:25 angelos Exp $
+
+ 30 Dec 2008; Christoph Mende <angelos@gentoo.org> antiword-0.37.ebuild:
+ QA: Respect CC (bug 243708), respect LDFLAGS
16 Aug 2008; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove pclouds from metadata.xml (#49680)
diff --git a/app-text/antiword/antiword-0.37.ebuild b/app-text/antiword/antiword-0.37.ebuild
index 788772f60587..163c28508204 100644
--- a/app-text/antiword/antiword-0.37.ebuild
+++ b/app-text/antiword/antiword-0.37.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/antiword-0.37.ebuild,v 1.9 2007/10/25 20:22:19 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/antiword-0.37.ebuild,v 1.10 2008/12/30 20:56:25 angelos Exp $
inherit eutils
@@ -18,19 +18,21 @@ KEYWORDS="alpha amd64 ~hppa ppc ppc64 sparc x86"
PATCHDIR=${WORKDIR}/gentoo-antiword/patches
src_unpack() {
- unpack ${A} ; cd ${S}
+ unpack ${A}
+ cd "${S}"
EPATCH_SUFFIX="diff" \
epatch ${PATCHDIR}
}
src_compile() {
- emake OPT="${CFLAGS}" || die
+ emake OPT="${CFLAGS}" CC="$(tc-getCC)" LD="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}" || die "emake failed"
}
src_install() {
- make DESTDIR=${D} global_install || die
+ make DESTDIR="${D}" global_install || die
- use kde || rm -f ${D}/usr/bin/kantiword
+ use kde || rm -f "${D}"/usr/bin/kantiword
insinto /usr/share/${PN}/examples
doins Docs/testdoc.doc Docs/antiword.php